x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UnrealEngineInstaller.msi StandaloneRenderer Error

The UnrealEngineInstaller.msi is not working. It gives the following error: alt text

Background: I previously had Unreal Engine 4 installed on my G:\ drive. I cancelled my subscription and that drive was removed and overwritten without actually uninstalling UE4 properly. Trying to run the uninstaller gave the same error in the above picture.

I started my subscription again and downloaded the installer.

At first it started up wanting to only install to the G:\ drive again and said it was out of space and would not allow me to select any other location.

I used an uninstall program to try and get rid of the leftover Unreal info from the previous install, and now the installer doesn't list a location to try installing to and if I click install anyway it gives the error pictured above.

I've attached the requested install log.

link text

Your help is greatly appreciated, I just want to get back to developing!


Update: I have been working to clean out the old references to G:\ and in reference to the error messages from the installer in the registry. I've used CCleaner and RegScanner to try to find the old references and it has gotten rid of the 'StandaloneRenderer' error. It then came up with the same type of error but then said 'UnrealEngineLauncher'. I got rid of that one too.

The current error is: alt text This one doesn't give me anything to go off of in my registry searching. I'm still searching unreal, ue4, etc and doing more cleanup, but I'm starting to run out of ideas. I'm hoping you have some more.

The error info from the log:

 MSI (s) (60:B4) [22:09:57:948]: SECREPAIR: Error determining package source type 
 MSI (s) (60:B4) [22:09:57:948]: SECUREREPAIR: SecureRepair Failed. Error code: 524970113A8 
 Error 1316. The specified account already exists.
 MSI (s) (60:B4) [22:09:59:608]: Product: Unreal Engine -- Error 1316. The specified account already exists.

Full log attached: link text

Product Version: Epic Games Launcher
Tags:
more ▼

asked Oct 21 '14 at 02:24 AM in Installation & Setup

avatar image

markdj
1 2 3 5

avatar image 0xDEADBEEF STAFF Oct 21 '14 at 05:49 AM

That is an issue I have not seen before. I'll have to see what info I can dig up. A quick internet search provides a number of hits on the error message you are seeing so I think I'll start there.

avatar image 0xDEADBEEF STAFF Oct 21 '14 at 06:17 AM

There seem to be a few posts online concerning similar issues. The most common cause seems to be Windows paths pointing to folders that do not exist. You probably have some odd path issues due to the removal of your old G: drive.

If you are comfortable navigating/using regedit, try the following(Always backup the registry before making any changes):

  1. Start->Run, type regedit and hit enter(Select yes if it asks to run with elevated privileges)

  2. Navigate to: KEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

  3. Check for any paths that point to folders that do not exist anymore or have moved. These will need to be fixed as they will cause all sorts of issues with other installers/programs too. Backup registry before making any changes.

avatar image markdj Oct 21 '14 at 02:32 PM

Thanks, I'll try this tonight and let you know how it works.

avatar image markdj Oct 22 '14 at 01:16 AM

So that location doesn't actually seem to have any paths that need to be changed. They're all the relative paths like %Public% etc, and those paths still work. Is that really the location you meant? Any other ideas?

Thanks

alt text

captur2e.png (23.8 kB)
avatar image Muzaheed Aug 07 '15 at 03:39 PM

go to "Engine\Extras\UnrealEngineLauncher "

right click on ""UnrealEngineInstaller.msi"

then click uninstall

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

As far as I can tell, these are not issues that are specific to the Unreal Engine installer but to msi installers in general. I will try to help where I can.

After some digging, it appears that Microsoft makes a utility that may help in this case. You could try using the following Microsoft utility: Link

more ▼

answered Oct 22 '14 at 03:47 AM

avatar image

0xDEADBEEF STAFF
1.5k 18 12 47

avatar image markdj Oct 22 '14 at 04:40 AM

Thank you! This did it! That's an extremely valuable Microsoft utility there, one of the first auto fix tools I've ever used that has actually worked.

avatar image dizzyispower Jul 20 '16 at 10:39 PM

This worked for me on Windows 10.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question