x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Navmesh Doesn't show after building

Reproduce Steps: - Use your own static mesh. I'm using a corridor, all four sides are covered by walls. - Use navmesh bound to contain the static mesh corridor. - Build.

The green navmesh doesn't show. At first I though there is no navmesh built, but after I adjust the navmesh bound, the green areas show without a 2nd building.

Product Version: Not Selected
Tags:
more ▼

asked Oct 21 '14 at 07:08 AM in Bug Reports

avatar image

kindfox
60 5 7 9

avatar image Ben Halliday STAFF Oct 21 '14 at 07:43 PM

Hey kindfox,

I wasn't able to reproduce this issue. Which version of the engine are you using? When you place the Nav Mesh Bounds Volume in the level, do you see the Recast Nav Mesh appear? If you go to Project Settings > Navigation System, what is the Dirty Areas Update Freq set at? You mention your static mesh being a corridor.. could you either provide that asset here or show me an image so I can recreate it? Thanks!

avatar image kindfox Oct 22 '14 at 03:50 AM

Hi Ben, it's ok. I use P to toggle visibility now, it works

avatar image kindfox Oct 22 '14 at 03:51 AM

Moving the static mesh a little also works. I didn't change the Dirty Area Update Freq, it's 60

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Sometimes you just need to move the mesh a little bit. That will cause it to refresh and repaint to show the green (or red) navigation paths.

  • Press P to toggle visibilty

  • Make sure the Mesh is covering the entire area

  • Rebuild Paths

more ▼

answered Oct 21 '14 at 07:14 AM

avatar image

Janyx
497 67 65 212

avatar image kindfox Oct 21 '14 at 07:34 AM

yeah, I figured. just want to point out so Epic would fix that. Thank you!

avatar image tardygrade Apr 14 '15 at 10:43 PM

Yeah... this is still a problem. Was following a tutorial and couldn't get it to build. Then saw this and moved it back and forth, pressed P a few times, moved back and forth again , and then it finally showed up.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question