x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Light01.uasset from GitHub has errors

The asset \StarterContent\Audio\Light01.uasset from the github zip files seems corrupt.

It is different from the one shipped with the launcher build in its last few bytes, and it stops cooking with an error, and halts the editor when selected or used in any way. I downloaded the zip files twice, I dont think the error is introduced on my end.

Just to make it clear. The 4.5 launcher version of the asset works fine in my 4.5 head git (whats getting 4.5.1) build of the engine, the github version does not.

Product Version: Not Selected
Tags:
more ▼

asked Oct 21 '14 at 07:27 PM in Bug Reports

avatar image

Mikand79
6 2 4

avatar image Tim C ♦♦ STAFF Oct 24 '14 at 08:12 PM

Hi Mikand79,

Could you confirm if this is happening for you in both 4.5.0 and 4.5.1, or is it just one of those versions? Are you getting any error message when you try to use this asset?

avatar image Mikand79 Oct 25 '14 at 06:28 PM

The faulty asset is in the dependency zips of 4.5.0 on github, its fine in the dependencies of 4.5.1.

avatar image Mikand79 Oct 25 '14 at 06:47 PM

The engine does not report any error when it accesses the faulty file in editor or game, just dies. The packaging tools report the file as inaccessible and stop the process of packaging. As said, the file has so to see errors in the last few bytes.

avatar image Tim C ♦♦ STAFF Oct 27 '14 at 09:40 PM

I ran some more tests with 4.5.0 from GitHub vs 4.5.0 from the Launcher, and I was able to see the package process fail in the GitHub version. However, I received the exact same results when I removed the Light01.uasset file from the project.

I also did not see any crashes or other problems when playing the game in the Editor or in Standalone mode. I was able to play the sound in the Editor, as well as placing it into the game and having it play there.

I was using a new Blank Project to test this. Are you using a different template for your project where you are seeing this issue?

avatar image Mikand79 Oct 28 '14 at 09:49 AM

Hi Tim,

Sorry to hear you are unable to package a blank project with 4.5.0 without the faulty asset.

The Test project I made for the issue is indeed a Blank BP Project.

The GitHub version of the engine is build with everything that's available for windows, that is html, linux and android stuff is there.

I don't seem to have access to 4.5.0 on the launcher, only the later one, and I updated my github build to 4.5.1 so I cannot use the exact fitting versions to test what I say anymore.

But I got both assets in question. I cannot rightclick or drag the faulty asset, got a relevant log entry for you what happens when I do it in 4.5.1.

BTW the dbghelp.dll that gets shipped with the dependencies doensn't work at my computer, didn't ever, the debug tools provided version does.

The Light01.uasset from the dependencies in different in the last 6 bytes from the one that comes with the launcher. I don't know whats stored at those places.

Log from packaging for Windows 64:

 [2014.10.28-09.37.06:989][619]MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2014.10.28-09.37.06:726][  0]LogCookCommandlet:Display: Loading U:/Projects/TestProject/Content/StarterContent/Audio/Light02_Cue.uasset
 
 [2014.10.28-09.37.06:989][619]MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2014.10.28-09.37.06:849][  0]LogCookCommandlet:Display: Processing package ../../../../../Projects/TestProject

saving of the log ends here, in the editor log I can see "...LogLinker:Warning: Unable to load package ", the rest is hidden by the packaging progress dialog.

I assume its Light01.uasset. The editor processes then stops.

avatar image Mikand79 Oct 28 '14 at 09:53 AM

And logs when right clicking the asset:

 [2014.10.28-09.16.44:065][568]LogLinker:Warning: Unable to load package (../../../../../Projects/TestProject/Content/StarterContent/Audio/Light01.uasset). Post Tag is not valid. File might be corrupted.
 [2014.10.28-09.16.44:065][568]LogWindows:Error: Windows GetLastError: Der Vorgang wurde erfolgreich beendet. (0)
 [2014.10.28-09.16.44:289][568]LogCrashTracker: 
 
 [2014.10.28-09.17.28:085][568]LogCrashTracker: 
 
 [2014.10.28-09.17.28:085][568]LogWindows: === Critical error: ===
 Fatal error: [File:U:\UE\4.5\Engine\Source\Runtime\Core\Private\HAL\FileManagerGeneric.cpp] [Line: 608] 
 Invalid BufferCount=0 while reading ../../../../../Projects/TestProject/Content/StarterContent/Audio/Light01.uasset. Pos=364532, Size=364532, PrecacheSize=2147483647, PrecacheOffset=364532
 
 KERNELBASE.dll!UnknownFunction (0x00007ffa1464606c) + 0 bytes [UnknownFile:0]
 UE4Editor-Core.dll!FOutputDeviceWindowsError::Serialize() (0x00007ff9f3674f84) + 0 bytes [u:\ue\4.5\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
 UE4Editor-Core.dll!FMsg::Logf__VA() (0x00007ff9f35094ef) + 0 bytes [u:\ue\4.5\engine\source\runtime\core\private\misc\outputdevice.cpp:522]
 UE4Editor-Core.dll!FArchiveFileReaderGeneric::InternalPrecache() (0x00007ff9f3418647) + 0 bytes [u:\ue\4.5\engine\source\runtime\core\private\hal\filemanagergeneric.cpp:610]
 UE4Editor-Core.dll!FArchiveFileReaderGeneric::Serialize() (0x00007ff9f343557d) + 0 bytes [u:\ue\4.5\engine\source\runtime\core\private\hal\filemanagergeneric.cpp:647]
 UE4Editor-CoreUObject.dll!operator<<() (0x00007ff9f2e3f0cc) + 12 bytes [u:\ue\4.5\engine\source\runtime\coreuobject\private\uobject\packagefilesummary.cpp:13]
 UE4Editor-CoreUObject.dll!ULinkerLoad::SerializePackageFileSummary() (0x00007ff9f2e83ab4) + 0 bytes [u:\ue\4.5\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:840]

rest doesn't fit.

avatar image Mikand79 Oct 28 '14 at 10:01 AM

Oh and the Editor doesn't crash when I package, it just stops doing anything.

Attaching the debugger and breaking it shows its spinning on a lock or something in Engine\Source\Runtime\Core\Private\Windows\TextStoreACP.cpp line 195.

Probably the right thing to do would be assuring from your side that the file is indeed corrupt and its not faulty memory or HD space on my side, and if it is replace the asset or notify engine users about and make bug tracker entries for all the issues it caused :)

avatar image Adam Davis STAFF Jan 08 '15 at 07:07 PM

Hi Mikand79,

I apologize for the delay in getting back to you! Are you still experiencing these errors with later github builds?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Mikand79,

We have not heard from you in quite some time. I am marking this as accepted for tracking purposes. If you are still experiencing this error, please comment back with the requested information. Thank you.

more ▼

answered Jan 13 '15 at 07:38 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question