x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Android for distribution fails to load on device

It successfully compiles. How ever the game crashes out almost instantly if I have for distribution checked. If I uncheck it. The game runs and I even see google play services window at boot if I uncheck for distribution.

Log files say these things I think are the cause. 10-21 17:47:52.477: V/GamesNativeSDK(1767): Using classes from /data/data/com.epicgames.Marble/app_.gpg.classloader/b6757673c393a41909bbab0d950640e3.jar. 10-21 17:47:52.480: I/dalvikvm(1767): Failed resolving Lcom/google/android/gms/games/NativeSdkCallbacks; interface 7 'Lcom/google/android/gms/common/api/GoogleApiClient$ConnectionCallbacks;' 10-21 17:47:52.481: W/dalvikvm(1767): Link of class 'Lcom/google/android/gms/games/NativeSdkCallbacks;' failed 10-21 17:47:52.481: E/GamesNativeSDK(1767): Exception in dalvik/system/DexClassLoader.loadClass: java.lang.ClassNotFoundException: Didn't find class "com.google.android.gms.games.NativeSdkCallbacks" on path: DexPathList[[zip file "/data/data/com.epicgames.Marble/app_.gpg.classloader/b6757673c393a41909bbab0d950640e3.jar"],nativeLibraryDirectories=[/vendor/lib, /system/lib]]. 10-21 17:47:52.481: E/dalvikvm(1767): ERROR: couldn't find native method 10-21 17:47:52.499: I/ActivityManager(9664): Process com.epicgames.Marble (pid 1767) has died. 10-21 17:47:52.499: I/WindowState(9664): WIN DEATH: Window{429eb888 u0 com.epicgames.Marble/com.epicgames.ue4.GameActivity}

Product Version: Not Selected
Tags:
more ▼

asked Oct 21 '14 at 10:04 PM in Bug Reports

avatar image

SteveFox1620
71 5 7 13

avatar image SteveFox1620 Oct 29 '14 at 01:31 AM

I have a possible work around and can perhaps shed light on what the issue is. Using 4.5.1 compiled from source or not. I compiled out both with and with out distribution checked. I extracted the apk files from both results. I then took the AndroidManifest.xml file from the distribution apk and copied it over the one that had distribution unchecked. I then deleted the signing folder. Rezipped the files, and renamed it to .apk. Resigned it, zipaligned it, and it works! Google play store lets me upload the apk file and it doesn't crash back to the desktop when I run it.

avatar image SteveFox1620 Dec 03 '14 at 08:22 PM

I just wanted to update that 4.6 does NOT fix this issue either.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Howdy SteveFox,

Thank you for reporting this issue. I have tested this issue on the new 4.6.1 build and on the 4.7 preview build on the error is still occurring. I have however, tested the issue on a newer internal build and the error is no longer occurring. I am unsure as to when the fix for this will be implemented into a released build but the issue has been resolved.

Please let me know if you have any additional questions.

Thanks and have a great day!

more ▼

answered Dec 17 '14 at 10:24 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

avatar image SteveFox1620 Dec 17 '14 at 10:30 PM

Thank you for confirming the issue. I appreciate the information about it not working on 4.7 either. I'm glad to hear it will be fixed eventually since it is in the internal build. Thanks.

avatar image SteveFox1620 Feb 26 '15 at 11:42 PM

Confirmed still has the same issue on 4.7

avatar image [Epic] Gribbs ♦♦ STAFF Feb 27 '15 at 05:02 PM

Hey SteveFox,

Thank you for the update about the issue not being resolved in the 4.7 release of UE4. We have just released a hotfix for 4.7 (4.7.1) and I was wondering if you would be able to give this build a try and let me know if this issue has been resolved.

Thanks!

avatar image SteveFox1620 Feb 27 '15 at 06:15 PM

Getting the same thing on 4.7.1 The same fix still works, so I think its the same issue.

avatar image [Epic] Gribbs ♦♦ STAFF Mar 04 '15 at 10:20 PM

Hey Steve,

Would you be able to give this a shot on 4.7.2 and see if this still occurs? I may have to re-visit this issue.

Thanks!

avatar image SteveFox1620 Mar 05 '15 at 03:05 AM

Same issue on 4.7.2

avatar image [Epic] Gribbs ♦♦ STAFF Mar 05 '15 at 06:46 PM

Hey SteveFox,

Thanks for all of the information that you have provided. I have entered JIRA report UE-11350 into our bug database so that the issue may be addressed in a future release. I am unsure as to when this issue may be resolved but I will be sure to keep you posted as I know more about the bug.

Thanks and have a great day!

avatar image [Epic] Gribbs ♦♦ STAFF Mar 10 '15 at 08:00 PM

Howdy SteveFox,

I have just received some information about your issue. When you are packaging your project for Distribution, do you have the Distribution signing section filled out under the Project Settings>Android section?

Also, have you created a Key Store for your project. This is vital when packaging your project for distribution.

Thanks!

avatar image SteveFox1620 Mar 11 '15 at 08:58 PM

Yes I transferred all information over from the old xml file setup. Yes I have created a key store file. Yes I moved it into project/build/android. The project would fail to build If I had not. As I said, the project builds it just doesn't work.I have to cook two versions each time. I have to decompress the apk, copy the dist version of the file AndroidManifest.xml over top of the non dist version, recompress, ,rename, resign, and realign. Then it works.

avatar image [Epic] Gribbs ♦♦ STAFF Mar 12 '15 at 05:26 PM

Which version of the Android NDK and SDK would you be using? Also, Could you provide the two copies of your AndroidManifest.xml files?

Thanks!

avatar image SteveFox1620 Mar 12 '15 at 07:32 PM

Just noticed this got marked as resolved. Funny I guess missed that one. Can I get the fix since this was resolved?

avatar image [Epic] Gribbs ♦♦ STAFF Mar 12 '15 at 07:34 PM

Sorry about that. When a comment is provided by myself, it will mark it as resolved if I provided the first answer. I will be sure to check as I respond to your comments.

avatar image SteveFox1620 Mar 12 '15 at 08:58 PM

Thanks. I'm using the version included with the download tadp-2.0r8-windows. I'd like to use the latest version as it has had a lot of optimizations but last I knew you had to use this version. I will get those posted as soon as I get home. I can also send would need to be direct all three packages if you want them. Cooked with out dist, with dist, and then the fixed version that works.

avatar image wittlief ♦♦ STAFF Mar 25 '15 at 07:51 PM

Hi SteveFox1620,

I spoke to the Android dev with regards to users being obliged to use tadp-2.0r8 and he advised that upgrading is fine as long as you are using the 4.7 update of the engine, but you should make sure you have SDK 19 and NDK checked when installing. So feel free to update, it should be fine if you make those two changes.

avatar image SteveFox1620 Mar 13 '15 at 02:10 AM

xml files in one zip archive. Let me know if there is any thing else you need. Thanks

It wlink text

xml_files.zip (3.3 kB)
avatar image SteveFox1620 Mar 17 '15 at 08:00 PM

Was not fixed in 4.7.3 either.

avatar image [Epic] Gribbs ♦♦ STAFF Mar 19 '15 at 05:58 PM

Hey Steve,

I may have found this issue. You may be having issues with the proguard txt file not transferring over with upgrading your project with new builds.

Go to this location in windows explorer: Location of your engine>4.7>Engine>Build>Android>Java. You should be able to see a file named proguard-project.txt . Please let me know if you do not.

If it is in that location, Open up a new windows explorer window, and locate the your Unreal projects folder. Locate the project you are attempting to package and use this route to check and see if the proguard-project.txt file is located within this location: [Project]>Intermediate>Android> APK.

If it is, delete the proguard text file in the projects folder and copy and paste the text file from the Java folder.

Let me know if this helps with the issue any.

Thanks!

avatar image SteveFox1620 Mar 19 '15 at 07:56 PM

It did not seem to help. I was hoping it would as the file inside the project was only 2KB. The one inside the java folder was 3KB. Using the new file did not fix it though.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We just recently put a demo of our game up on Google Play. We ran into the same problem. Hopefully it is ACTUALLY the same problem and can help you.

Get this: in the manifest where your package name is, the com.whatever.yo, we had to leave the last part at default where it automatically generates it based on on the project name. Our package name through Google was com.deviousgamers.ihatemyjobdemo, and we had to rename our project to ihatemyjobdemo for it to generate correctly. Typing in the name manually in the manifest did NOT work.

Obviously it ended up working, or we wouldn't have a demo up. It sounds bizarre and you might initially be like Nah dude that's not the issue. But it's worth a shot. We were in a pretty desperate stage when we were trying things like that lol.

Here's the demo if you're curious btw https://play.google.com/store/apps/details?id=com.deviousgamers.ihatemyjobdemo

EDIT: We are using 4.6.1. 4.7.x drops our mobile fps, unfortunately.

more ▼

answered Mar 05 '15 at 05:55 AM

avatar image

DG Gage
1.6k 62 31 129

avatar image SteveFox1620 Mar 05 '15 at 07:07 AM

I appreciate your response. In 4.7 those settings are finally inside the editor. I tried changing the last part from .Marble back to .[PROJECT]. It did seem to add the .Marble back correctly during the cook on the files. Unfortunately it did not help and it instantly drops me back to the home screen still. I actually seen your app on the store the other day when I was browsing. I thought to myself great idea for a game haha. I wish you luck with your game. Thanks again for the information. I will leave the end part as default from now on just in case it helps in the future.

avatar image DG Gage Mar 05 '15 at 12:46 PM

Dang, too bad.

And thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So when Google Play services were enabled for our about-to-be-released launch version, I experienced your problem. Crashes on distribution build, works fine with development or shipping without distribution. Google Play unchecked, distribution works.

I did what Sean said about updating my proguard file, and made sure to include it in Intermediate > Android > APK and in Build > Android, just to be safe.

Still didn't work.

However, I found this post:

https://answers.unrealengine.com/questions/177637/47-android-shipping-crash-on-launch.html

You add this to the proguard file:

 -keep class * extends android.media.MediaPlayer {
     public *;
  }
  

I had tried that post's solution before with no success, but now, combined with Sean's advice of updating the proguard, and THEN adding this code, I am now able to use Google Play services and launch my game with distribution.

I really hope this helps you out.

more ▼

answered Mar 29 '15 at 08:44 PM

avatar image

DG Gage
1.6k 62 31 129

avatar image birdfreeyahoo Apr 19 '15 at 05:12 PM

worked for me thanks

avatar image SteveFox1620 Apr 22 '15 at 07:11 AM

I opened up my file and found that line all ready in there. Are you saying you have it twice in your file and that fixes it?

avatar image DG Gage Apr 22 '15 at 11:48 AM

It wasn't in mine, so I guess your problem elsewhere. :(

avatar image SteveFox1620 Apr 22 '15 at 07:20 PM

Thanks any way. At least someone tried. I'm still wondering why this thread is marked as resolved. It's no wonder no one is getting any help on this known issue.

avatar image SteveFox1620 Jul 07 '15 at 07:04 PM

Still an issue in 4.8.1

avatar image KillerSneak Jul 08 '15 at 09:54 AM

Still can't get a Shipping/Distribution to work I'm having the same problem. I think it has to do with the game now being put into a folder UE4Game.

So even when you're able to build a "For Distribution" / Shipping game it will not work from the app store or installing it locally. For now you're stuck with a non Distribution / Shipping game

I'm having the exact same problem

Working:

Build configuration: Shipping

Full rebuild

Not Working:

Build configuration: Shipping

Full rebuild

For Distribution

-

A full shipping for distribution build will give the error:

Failed to open descriptor file

https://answers.unrealengine.com/questions/193172/failed-to-open-descriptor-file-2.html

avatar image Ben Halliday STAFF Jul 08 '15 at 09:59 PM

Hi KillerSneak,

We will be tracking the issues you are experiencing on the post that you made:

https://answers.unrealengine.com/questions/253779/cant-alpha-test-from-google-play.html

Please refrain from posting your issue on multiple threads on AnswerHub. We will address the issue on your post. Make sure you include any logs you can, as requested by wittlief.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question