x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Foliage bug (Brightness changing with camera movement)

Hi.

I have a strange foliage bug on my landscape. Groups of grass instances are changing brightness, when I move camera. This video shows bug: http://www.youtube.com/watch?v=ydflegeIwS4

Grass near the road become darker or brighter.

Engine scalability settings are all Epic. Other settings and material: alt textalt text

Product Version: Not Selected
Tags:
grass.png (41.0 kB)
mat.png (88.7 kB)
more ▼

asked Oct 22 '14 at 02:53 PM in Rendering

avatar image

wmask
81 3 8 11

avatar image wmask Oct 23 '14 at 09:09 PM

Flickering ends when I uncheck Cast Dynamic Shadow on grass instance. It's not a solution, because I need dynamic shadows on foliage. Maybe not on grass but on trees and another big objects.

I also get this warning: alt text

How to enable dynamic shadows and avoid this visual bug and warning?

grass2.png (829.8 kB)
avatar image wmask Oct 24 '14 at 09:46 AM

Detailed bug description: 1) Foliage looks good when I uncheck Cast Dynamic Shadows - but it's not a solution. 2) Foliage looks good when I set DistanceField Shadow Distance less then 7k for this level.

You can see it in the video from Editor.

http://www.youtube.com/watch?v=PxIm-uSUqeE

How to fix it?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello wmask,

I do see what you are describing, and it seems you do have a fix for your issue. Since grass is so dense you generally don't want to even have shadows turned on for that amount of foliage. The warning message is correct as well, when you set each foliage instance to receive dynamic shadows that will take a lot of processing away from the areas where you will need it and become inefficient. I suggest turning off the dynamic shadows for those specific instances and you can turn on static shadows.

When it comes to larger objects like trees that sway, or even large rocks you can turn these shadows on and if their spacing is appropriate the shadows and processing required to avoid the error message should be fine. I have posted a few images to show you how I set up a little scene I worked on a while ago using the foliage tool and optimizing the shadows. Let me know if this helps you with your issue!

Shows that these objects are foliage alt text

Shadows per instances of trees alt text

For the Bushes in the scene I have unchecked the dynamic shadows and checked the static shadows. This provides a good compromise.

more ▼

answered Oct 27 '14 at 03:04 PM

avatar image wmask Oct 27 '14 at 09:08 PM

Thx, Andrew. I turned off dynamic shadows and changed grass model a bit. Now it looks better even without shadows.

avatar image AndrewHurley Oct 28 '14 at 01:10 PM

No problem! Glad to have been of help

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question