x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Ingame rendered text broken?

Im working on a build of the shooter game, and had a simple text render in the world. "Press "E" to use" or something, works great in editor, and in earlier builds i made, but this is the result after I build and run the game now...

alt text

I have not changed any code or font content since the last build where the text was working, added a map, and a few blueprints, thats it. Whats going on!?!?!? What can cause this??

Product Version: Not Selected
Tags:
problem.jpg (86.2 kB)
more ▼

asked Oct 22 '14 at 09:56 PM in Bug Reports

avatar image

MADHOUSE
373 22 37 58

avatar image Adam Davis STAFF Oct 23 '14 at 08:03 PM

Hi MADHOUSE,

Does this occur on a clean project with no additional content? What device are you packaging for?

avatar image MADHOUSE Nov 08 '14 at 02:05 PM

Thanks for your reply! I will try and build a clean project, but it seems to be localized to my modified shootergame project, as it has the same problem if I build that project on a different machine with a fresh UE4 install

edit: I am building shipping build for windows

avatar image Adam Davis STAFF Nov 10 '14 at 04:57 PM

Hi MADHOUSE,

Are you using the base font or have you opened up the engine contents and used one of the additional fonts?

avatar image MADHOUSE Dec 02 '14 at 06:28 PM

I seem to be using RobotDistanecField from the EngineFonts folder, i based my blueprint on one of the blueprint office example blueprints, using the part for rendering text when the player is near.

If i copy that blueprint to a fresh fps (c++) project, or rather just use the same add textrendercomponent node , i need to change text material to M_UnlitText_01 since it is the only one to pick. the result is that the text shows up as normal in the editor, but when I build (32bit win shipping) and run, the text wont show up at all this time. hmm im confused. I will try some things..

avatar image Adam Davis STAFF Dec 02 '14 at 06:38 PM

Have you seen this occur in a blueprint based project or is it only in c++ that these errors seem to occur?

avatar image MADHOUSE Dec 02 '14 at 07:01 PM

Hmm I only tried in the c++ based template and shootergame, not rly sure what caused it, Is it supposed to include used content from the engine folder? somehow that is no longer occuring for the fonts atleast, wierd that it would also happen on a different computer with a fresh UE4 install, perhaps some project or config setting that I accidentaly changed?

avatar image MADHOUSE Dec 02 '14 at 06:47 PM

Okay, I think it is solved now. I dont know why it worked before, but it seems to not include the content from the Engine folder anymore, so if i copy EngineFonts to the Game folder, and redirect the blueprint node to the copied font/material files, it also works fine ingame after shipping build.

avatar image TSpartanT Oct 24 '14 at 11:34 PM

Having the same problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

You have to copy the text files your using over from the "Engine" folder to the "Game" Folder. This includes them in the build path. It fixed ours, hope it works for you.

more ▼

answered Oct 25 '14 at 12:08 AM

avatar image

TSpartanT
116 17 20 26

avatar image kjuik Oct 27 '14 at 05:10 PM

I'm having the same problem, even with all the text 'hard-coded' in blueprints - I have no text files to move.

broken font.png (803.6 kB)
avatar image Adam Davis STAFF Oct 27 '14 at 09:28 PM

Hi kjuik,

In the editor, try turning on "show engine contents" which can be found by going to your content browser view options.

avatar image kjuik Oct 27 '14 at 10:56 PM

Thank you for your interest (: I'm sorry, I didn't understand that you meant in-editor folders, rather than Build folder's subfolders.

Yes, I have already copied the default font from the Engine folder to my Game folder, and I have been playing with that copy. It didn't work that way either. the best I have achieved is a fallback to default system font, when displaying text with HUD->DisplayText http://screenshooter.net/4912384/khohbrh

avatar image Adam Davis STAFF Oct 28 '14 at 02:51 PM

Hi kjuik,

Which font were you attempting to use for your render to texture?

avatar image kjuik Oct 29 '14 at 04:21 PM

I've been trying the basic RoboDistanceField with DetaultTextMaterialOpaque (which I have also copied to my Game folder), and ... Stegoe I think (I'll check in a few hours). Shall I try with something more basic (Arial)?

avatar image Adam Davis STAFF Oct 29 '14 at 06:55 PM

Try turning off "Show Engine Options", then create a new text render actor and use the base information. Does this show up still? I have stumbled upon a potentially similar error in which, with show engine folders on other fonts do not render properly, I am going to keep trying to reproduce this on my end.

avatar image kjuik Oct 30 '14 at 07:15 PM

I suppose you mean "Show Engine Folders" (: I've created a new Text Renderer Actor with Engine folder hidden, using RoboDistanceField font. As basic as it gets. No luck. It displays nicely in editor, changes into 'square square square square' in the packaged build. The .exe's fron 'Binaries' folder in the project are working fine, though.

avatar image Adam Davis STAFF Oct 30 '14 at 07:24 PM

Ok so it is broken once packaged. What package options are you using? For instance, are you building for Windows? Android?

avatar image YuriNK Dec 21 '15 at 07:30 PM

Hello, I faced the same problem today. Solution: 1) copy DefaultTextMaterialTranslucent material and RobotoDistanceField font to the game folder; 2) modify material to make it use a new font asset lying in the game folder.

avatar image MADHOUSE Dec 02 '14 at 06:50 PM

What worked for me was to make sure that font and material files where copied from Engine folder to a folder under the Game folder, and then make sure to redirect the blueprint nodes to the new files, or it will try to access the wrong path and return null, this is what worked in my case!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi everyone,

We have not heard from you in quite some time. I am marking this thread as answered for tracking purposes. If you are still experiencing these issues, please comment with the requested information. Thank you!

more ▼

answered Nov 05 '14 at 05:19 PM

avatar image MADHOUSE Nov 08 '14 at 02:08 PM

Hi, Thanks for your replies! I appologize I haven't had time to follow up on this yet, but I will explore the suggestions in this thread and reply with my results very soon.

Regards

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question