Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Neither Set Actor Location or Teleport moves actor

I am currently working in the release build of 4.5. I have gravity gun like system in 4.2 and have ported the game over to 4.5. As I was testing to see if everything works set actor location seems to false not matter how the rock is set.

alt text

I have a parent class called pickUpable that handles all the interactions with the gravity gun mode of my weapon. The rock in the Image inherent from that class. alt text

Product Version: Not Selected
cantpickup.png (1.3 MB)
parentclass.png (313.2 kB)
more ▼

asked Oct 23 '14 at 12:36 AM in Bug Reports

avatar image

11 1 2 5

avatar image Ben Halliday STAFF Oct 23 '14 at 09:05 PM

Hi Endrophes,

Is your Actor being moved by this node at all? It looks like you have your Print String set to only print when Moved is set to True. So when you call New Location, is the Actor's location actually being set? According to your screenshot, it is.

If it isn't being moved, try refreshing the nodes. Select all the nodes in your graph and right-click, then select Refresh Nodes. Upgrading your project from much older versions can sometimes cause problems because the editor handles BPs differently, and sometimes a simple refresh can clean things up.

Let me know if that helps!

avatar image Endrophes Oct 24 '14 at 06:08 AM


I have tried your solution and nothing has changed, it dose not move a unit. I am sure the bottle neck is with set actor location. Is it possible that I have it setup wrong in some way?

avatar image Ben Halliday STAFF Oct 24 '14 at 05:29 PM

I set up a project to test this, and Set Actor Location is working for me. I also created the same project in 4.2 and then converted it to 4.5, and still did not encounter any problem with Set Actor Location. The way you have your BP set up should move your mesh when the function is called and then print the string you created below.

Based on the screenshot you provided, I can see that the print string is being called, which should only happen when the actor is successfully moved. How are you calling the function, and what vector value are you feeding it? Can you show me an image of where you're setting the vector value for New Position and where you're calling the function? Thanks!

avatar image Endrophes Oct 27 '14 at 03:34 PM

Sorry for the wait, I have weekly deadlines on my project that i have to meet. Here are the two places that I call set location. alt text

alt text

Your right i do print the string if it was true, in that case it should move. I switch the branch to false and it is not printing my string.

avatar image Ben Halliday STAFF Oct 27 '14 at 05:13 PM

That's basically what I have, which works. What are you using to set the New Position before you pass it to the New Location function?

avatar image Endrophes Oct 27 '14 at 06:51 PM

Am getting the players forward vector and multiply it by a set distance. Like so: alt text

The forward vector is used to set the position of the object am interacting with.

UPDATE: I have tried to set the actors transform manually. Still nothing, is it because I do not have a target set sense it is in the parent class? alt text

avatar image Ben Halliday STAFF Oct 27 '14 at 08:21 PM

Okay, it seems like that should work, if the Forward value is what you're feeding your New Location function in the pickUpable Blueprint. I'd like you to try replicating what I have exactly to see if it works in your project, if you don't mind. I have a very simple setup, which you can see in these images:

alt text

alt text

I'd like you to try that in your project, and if it does not work, please try it in a new First Person Blueprint template project. Thanks!

avatar image Nup Aug 23 '15 at 05:30 AM

Hi guys, not sure if this is the appropriate place to put this but I have built a very basic test for set actor location as I was experiencing similar issues. In 4.8 there seems to be a bug with it as it works as intended in 4.7 for me. I made a basic blueprint object with physics simulated and a keypress for testing the setactorlocation.

alt text

I hope this helps or that the issue causing this can be identified. I am using movecomponentto as a temporary fix but it isn't a ideal solution.

avatar image jtsmith Aug 23 '15 at 08:55 AM

@Nup I have answered your question. Go see if that works for you.

avatar image JoelGray Sep 10 '15 at 10:24 AM

Having the same issue here, the return value is reporting true that the object has teleported but nothing is happening. This has been tried with the 'teleport' and the 'SetActorLoction' nodes. This bug is persistent to 4.9. alt text

avatar image Ben Halliday STAFF Sep 10 '15 at 05:24 PM

Hi Joel,

I'm not having any trouble with this on my end in 4.9.0. Are you able to reproduce this in a new project? If so, please create a test project for me and upload it someplace like Google Drive or Dropbox, then get me a download link so I can take a look at your setup. Thanks!

avatar image PappySnail Dec 12 '15 at 04:35 AM

I had the same issue as this. In case anyone is having the same problem, Set Actor Location does not work if physics is enabled. I'm not sure if it is a bug or not.

avatar image Adam Davis STAFF Dec 15 '15 at 05:39 PM

Hi PappySnail,

What kind of mesh are you setting simulate physics on? I tested this on a static mesh asset and did not experience any errors.

avatar image merubiny Feb 15 '16 at 03:30 AM

I ran into a similar problem and managed to solve it. I'll post the solution here in case somebody encounters it again. In the Transform component of the details tab, there is a "Mobility" option. Set it to "Movable" and the problem should be resolved.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Endrophes,

We haven't heard back from you in a while, so I am marking this post as resolved for tracking purposes. If you get a chance to try the suggested Blueprint setup above and still have experience the issue with Set Actor Location, please let me know and we'll continue the investigation. Thanks!

more ▼

answered Nov 02 '14 at 07:35 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question