x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Material Attributes Broken in 4.5

After updating the engine, materials that were using the Materials Attributes pin did not displaying textures correctly. Downloaded the Matinee Fight Scene for 4.5 and the materials with Material Attributes enabled (floor/wall) do not work either. It worked fine in 4.4.3 and lower. Not sure if this is a problem with the installation on my end or if some change to the material editor causes this feature to no longer work properly?

Product Version: Not Selected
Tags:
more ▼

asked Oct 23 '14 at 08:03 PM in Bug Reports

avatar image

visoutre
128 16 18 268

avatar image visoutre Oct 24 '14 at 05:08 PM

Hopefully this screenshot clarifies the issue. Regular materials display the textures fine, but anything with material attributes pin like the wall are broken.

alt text

avatar image visoutre Oct 24 '14 at 05:11 PM

there is a way to make it work by using the "BreakMaterialAttributes" node with the regular pin, but this work around seems messy? Does anybody else encounter this issue?

avatar image Lovecraft_K ♦♦ STAFF Oct 24 '14 at 08:22 PM

Hey visoutre -

Are you still experiencing this bug in 4.5.1?

Thank You

Eric Ketchum

avatar image visoutre Oct 24 '14 at 08:58 PM

Yes the bug is in 4.5.1 as well.

avatar image visoutre Oct 24 '14 at 09:14 PM

Sorry for the confusion, tried using the Material Attributes pin on a newly created material and it does work after all, so this is not the problem.

Exploring the issue further it seems the two materials using the Material Attributes pin in the Matinee Fight Scene demo have a MatLayer_FeatureLevelSwitchc material function. When that is not connected the materials work fine. The material function has a comment "for Mobile" and inside the function it has an error "Missing Preview connection for function input 'PC' It's not a major issue for me anymore, but if there is a way to debug it the answer would be in the Matinee Fight Scene demo scene.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey visoutre -

I am not seeing the same results in opening my Matinee Fight Scene Sample. As far as the warning "Missing Preview Connection for function input 'PC'," this is a warning only that you have no way to preview the function in the Material Editor. The node itself would be passing the PC input from outside of the function through this input node, so this alone should not be causing you any issues.

alt text

alt text

Have you upgraded this sample from previous engine versions? If so try to download the latest version of the sample for the 4.5 engine and see if you experience the same problem.

Thank You

Eric Ketchum

more ▼

answered Oct 28 '14 at 03:56 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 734

avatar image visoutre Oct 29 '14 at 12:17 AM

I did redownload a new copy and the issue was there on my end, but it's okay since this doesn't affect my projects. Thanks for the help and patience.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question