x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Code is missing

Hi, i tried to attach sword from right hand socket.

But when i try to watching this link its make a different or some is missing to this link "http://www.youtube.com/watch?v=BqxLHGtl9tM"

Please can you help me. thanks.

Product Version: Not Selected
Tags:
more ▼

asked Oct 24 '14 at 02:08 PM in Blueprint Scripting

avatar image

Peude
41 18 29 37

avatar image S-ed Oct 24 '14 at 06:18 PM

Where exactly You're experiencing problem? Show what are You expecting to see and what are You actually see.

p.s.: You can copy exact time link in Youtube (right click -> Copy URL at current time)

avatar image Peude Oct 24 '14 at 06:47 PM

I just follow the instructor here at the youtube. but i think there are code change to 4.5.1 by creating blueprint in socket code.

Note: Starting tutorial at 2:20.

Thanks.

avatar image S-ed Oct 24 '14 at 08:38 PM

Oh. Now I've got Your problem.

There is no Attach Actor node in Level Blueprint menu.

alt text

I don't know it's bug or feature, but You can copy one from Actor Blueprint.

ut12.png (114.3 kB)
avatar image Doug E ♦♦ STAFF Oct 24 '14 at 07:57 PM

Hey Peude-

What is the problem you're having when following the tutorial? Are you getting an error message or are you unable to create the socket or attach to it? Providing as much information about what the problem is will help us solve it and come up with a solution sooner.

Cheers

Doug Wilson

avatar image S-ed Oct 24 '14 at 08:43 PM

I don't know the reason, but there are different sets of Nodes for Level and Actor Blueprints.

You still can freely copy them in between.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Peude and S-ed-

If you turn off context sensitivity in the right click menu you should see the "Attach Actor to Component" option in the drop down menu.

Cheers

Doug Wilson

more ▼

answered Oct 24 '14 at 08:54 PM

avatar image Peude Oct 27 '14 at 03:44 PM

I tried also that but its not show. I thinking its some but from code list. I can't follow your code because its every UE4 version its going changes :).

avatar image Doug E ♦♦ STAFF Oct 27 '14 at 05:39 PM

Hey Peude-

As S-ed suggested, go to Edit->Editor Preferences and then select Experimental under the General heading. In the experimental preferences there is a checkbox for "Use New Blueprint Menuing System." Unchecking this checkbox should fix context sensitivity issue.

avatar image Peude Oct 27 '14 at 05:48 PM

Its already un-check?! before As S-ed she/he requested.

alt text

menu.jpg (113.8 kB)
avatar image Doug E ♦♦ STAFF Oct 27 '14 at 07:24 PM

Just to clarify, when you uncheck Use New Blueprint Menuing System and uncheck Context Sensitive in the level blueprint, you are still not seeing the option for Attach Actor to Component, correct? Also, which version of the engine are you working in?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Nope. If New Blueprint Menuing System enabled. Working with disabled one. alt text

more ▼

answered Oct 25 '14 at 11:53 AM

avatar image

S-ed
1.4k 27 26 49

avatar image Doug E ♦♦ STAFF Oct 27 '14 at 01:22 PM

Hey S-ed-

So just to clarify, unchecking the box for "Use New Blueprint Menuing System" in the Experimental heading of Editor Preferences allowed the context sensitivity to function properly for you?

avatar image Peude Oct 27 '14 at 07:45 PM

Yes.UE4.5.1..I tried again with HeroTPP Skeleton now its show the same from Youtube. I think there some problem when using Mixamo Skeleton. But how come what its difference, its only a Mixamo character and also i encounter bug from my last Post "Bug can't drag FollowCamera under SpringArm".

Note: Same Maximo Character using! Link: https://answers.unrealengine.com/questions/120376/bug-cant-drag-followcamera-under-springarm.html

But its only character, and not editor or blueprint code?

avatar image Doug E ♦♦ STAFF Oct 27 '14 at 08:22 PM

Hey Peude-

In the Level Blueprint, if you go to Window-> Palette this will add the palette tab next to the event graph tab. In the "Find a Node" section, you can type in "Attach" or manually navigate to Library -> Utilities -> Transformation and find the Attach Actor to Component node there. Adding the node to the level blueprint should be independent of if you are using HeroTPP or a Mixamo character.

Cheers

Doug Wilson

avatar image Peude Oct 28 '14 at 03:43 AM

Sorry, Good day.. i tried again its show error. Please check the attachment files. Thanksalt text

Note: Two (2) attachment. 1. My Blueprint and My Skeleton 2. Youtube Example

avatar image Doug E ♦♦ STAFF Oct 28 '14 at 01:51 PM

Hey Peude-

When you create the "Attach Actor to Component" node, if you have the mesh selected in the content browser (in your case the BookLP) it should link it as the target automatically. Alternatively, you want the target to be the mesh you are attaching. In the case of the video he gave the socket the same name as the mesh he was using (messer) however in your case you would want to use BookLP when dragging off of the Target pin.

avatar image Peude Oct 28 '14 at 02:58 PM

Messer its only socket name and the another is sword name. But here at youtube. When you type the Attach Actor to Component the messer its also automatic show (check the photo). But in my chase its not show.

avatar image Doug E ♦♦ STAFF Oct 28 '14 at 03:16 PM

The reason it automatically shows in the video is because the mesh is selected in the scene outliner. If you have the mesh (BookLP) selected in the scene outliner then it will show up already connected to the target of the attach actor to component node.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question