x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

any C++ *EditorSourceCodeAccess working plugin for Linux?

Hi,

I am unable to use C++ with my projects in Unreal Editor on Linux. I tried SensibleEditorSourceCodeAccess plugin, as suggested in wiki, but it does not compile (outdated?). When I put it in Plugins/Developer I am unable to "make UE4Editor" at all.

Is there ANY maintained C++ editor plugin for Linux? Or a maintained template plugins so I can write my own?

Best Andrzej Skalski

Product Version: Not Selected
Tags:
more ▼

asked Oct 24 '14 at 05:50 PM in Linux

avatar image

askalski
6 2 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You can try iFire's QtCreatorSourceCodeAccess at https://github.com/fire/QtCreatorSourceCodeAccess/

more ▼

answered Oct 28 '14 at 02:36 PM

avatar image

amigo
1.1k 53 33 90

avatar image SalahAdDin Nov 05 '15 at 06:16 PM

These doesn't works for me, i'm triying now use CodeLite.

avatar image Yaakuro Nov 06 '15 at 01:09 AM

As I mentioned in the others posts. If you use 4.9.x and you compiled the editor successfully the codelite accessor should work. To make sure it works go the plugins menu in the UE4Editor and look if the plugin is activated. after that you have to select the source code accessor for you project. The default accessor is a nullaccessor so change that. Open the file Engine/Config/Linux/LinuxEngine.ini and add this (or modify the one which exists):

[/Script/SourceCodeAccess.SourceCodeAccessSettings] PreferredAccessor=CodeLiteSourceCodeAccessor

And/or make sure that you selected the accessor in the UE4Editor. Open the editor settings menu and go to the SourceCode section. There you can select the accessor.

avatar image SalahAdDin Nov 06 '15 at 05:11 PM

Thanks man!!! This works, cok tessekur ederim :D Ama, QtCreator calisma. I prefer use this because i couldn't do work QtCreatorl

Will be better put this in the docs, you now, for possible problems.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question