x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lightmap...Why u do this?

Ok, i have tried everything i could think of but my meshes still look ugly.

Why is this happening?

alt text

This is the default uvs unreal creates when i import the mesh as my uvs were worse

alt text

Product Version: Not Selected
Tags:
untitled-2.jpg (538.4 kB)
untitled-3.jpg (587.6 kB)
more ▼

asked Oct 25 '14 at 01:02 PM in Rendering

avatar image

LoN
70 9 13 22

avatar image TeamKingdom Oct 25 '14 at 01:08 PM

What part of your scene are you having a problem with? I'm assuming it's the top part of the wall that is also the lintel over the door frame? I can't tell where the mesh you show appears in the scene.

avatar image LoN Oct 25 '14 at 01:23 PM

All my walls are these pillars, i just scale them to have desirable size. but the thing is here: alt text

Look at all the uneven light the walls get at the points that they "connect"

untitled-4.jpg (557.3 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi LoN,

The issue you're seeing with your mesh and the seam can be worked around. It will require you to set your Lightmaps up properly so that the UVs are aligned on grid spaces for the lightmap resolution you are targeting.

If you take a look at this thread I've covered all the areas you can tweak to reduce the seams on your modular pieces.

If you have any questions feel free to ask! :)

Tim

more ▼

answered Nov 03 '14 at 06:15 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 101 878

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Try increasing your lightmap resolution.

more ▼

answered Oct 25 '14 at 01:07 PM

avatar image

Skuvnar
226 24 22 36

avatar image LoN Oct 25 '14 at 01:24 PM

My lightmap resolution is already at 128. And i need to make a 3 floor building, increasing it more would be overkill.

avatar image Skuvnar Oct 25 '14 at 01:29 PM

Ah, having looked at your 3rd screenshot it seems like you are scaling your meshes too much in one direction. The lightmap is not scaled with the mesh so the long side of the wall is still being give the same number of pixels for a light map as if it were a thin pillar.

If that makes any sense.

avatar image LoN Oct 25 '14 at 01:32 PM

So what should i do? There are a lot of walls that are smaller or bigger than the others...will i have to make all these walls separately by hand in max and import them in unreal? That would take a loooong time.

untitled-5.jpg (508.7 kB)
avatar image Skuvnar Oct 25 '14 at 01:38 PM

For shipping the project, most likely. But for early stages of development use bsp geometry or just accept you might have poor lighting for a time. If you create some modular meshes (ie. a doorway, a short wall, long wall etc.) it wouldn't take that long as you could still scale them somewhat in one direction.

avatar image LoN Oct 25 '14 at 01:48 PM

I've just added one pillar next to the other instead of scaling them and this is what i get: alt text

It seems for some reason that the walls become that way when there is not enough light from the pointlights.

avatar image Skuvnar Oct 25 '14 at 03:44 PM

This happens when you stick static meshes together like that. Unfortunately there's no real away around it other than creating single meshes for walls, having higher resolution light maps or using BSP. You could also try using setting your lighting build to 'production'.

avatar image LoN Oct 29 '14 at 12:40 PM

Found another way around it....materials with specific details.

avatar image Skuvnar Oct 29 '14 at 12:49 PM

you should mark the question as closed then.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It seems that i've found the answer to my question, no matter how good lightmaps you can make it will just never be enough. If you make a good material all the problems get solved, for some reason if i add a Roughness And Metalic node, everything gets fixed. Not sure if this is the right answer but for now this will do, check it out: alt text

untitled-7.jpg (714.6 kB)
more ▼

answered Oct 26 '14 at 04:29 PM

avatar image

LoN
70 9 13 22

avatar image Haflurgaflur Nov 03 '14 at 02:14 AM

The metallic and roughness material nodes are not fixing the problem. They are just hiding it. Lightmass is reading the values and causing light to bounce in your scene making it look nicer. I also recommend making a normal map (even a flat one) as this might actually hide the problem completely.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question