x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.5.1: Navmesh doesn't work with foliage rocks

I made a simple terrain level, put a large navmesh bounds on it, and then painted some trees and rocks using foliage (set to Block All in collision settings.)

Unfortunately, the navmesh doesn't build proper polygons around these rocks -- it's as if it sees the rocks in different places than they are.

I have tried re-building geometry, saving the level and quitting and re-starting, and a few other things to try to see if I could provoke it into working, but nothing makes it good.

Look especially at the crescent in the lower-center of this screen shot -- that's my player start location. The player can't walk very far...

nav mesh screenshot

I don't know if this also affects earlier engines, but it does affect 4.5.1.

Edit: As asked, here are the painting and instance settings (and the Landscape settings):

paint settings

alt text

Product Version: Not Selected
Tags:
more ▼

asked Oct 26 '14 at 01:09 AM in Bug Reports

avatar image

jwatte
1.3k 48 41 88

avatar image Adam Davis STAFF Oct 27 '14 at 05:11 PM

Hi jwatte,

What are the painting and instance settings you are using for your foliage, can you post a screenshot here for me of each? Thank you!

avatar image jwatte Oct 28 '14 at 02:02 AM

In addition to adding the painting/instance settings, I think the "ghost" rocks may have been real at one point, and then deleted by un-painting them (shift-paint.)

avatar image Adam Davis STAFF Oct 28 '14 at 03:12 PM

Hi jwatte,

After removing the rocks, did you rebuild paths?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi jwatte,

We have not heard from you in quite some time. I am marking this as answered for tracking purposes. If you are still experiencing this error, please respond with the requested information.

more ▼

answered Nov 03 '14 at 07:41 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question