x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

mspdb120.dll is missing error

Excuse me if my terminology is bad, I'm quite new to unreal.

I'm trying to compile the engine for a C++ project but each time I try I keep getting an error that says I'm missing mspdb120.dll

I've searched everywhere on the internets and all I could find was "Reinstall windows", which I'd rather not. Is there any other way to fix this? Is there a place where I can download the dll manually and install it manually?

I'm using windows 7 64bit and VS12.

Product Version: Not Selected
Tags:
more ▼

asked Oct 26 '14 at 05:18 PM in Using UE4

avatar image

sillydan
8 1 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi sillydan,

The file mspdb120.dll is part of Visual Studio 2013. If you perform a search for it in your Visual Studio installation location, you should find two versions of the file, one in ..\VC\bin and one in ..\VC\bin\amd64.

The image that you showed from the EpicGames Organization on GitHub seems to indicate that your Unreal Engine 4 account and your GitHub account are not correctly linked (or you are not logged into your GitHub account, which would be the easiest thing to check). Take a look at this wiki page and make sure you have correctly linked your UE4 and GitHub accounts (the link will take you to the appropriate section of the page for this step).

Tim

more ▼

answered Jan 16 '15 at 05:39 PM

avatar image sillydan Jan 18 '15 at 01:58 PM

I downloaded the sourcecode. All the dependencies.. Fixed all build errors and the mspdb120.dll is in the correct place.

I still get this error: alt text

capture.png (21.7 kB)
avatar image sillydan Jan 18 '15 at 02:53 PM

Nevermind... I fixed it by deleting the one in my x86_amd64 folder. Then it created the right version by itself

avatar image sillydan Jan 18 '15 at 03:08 PM

Nevermind the nevermind... I got the engine compiled and all... But I still get the mspdb120.dll is missing error... It comes up when I try to recompile any C++ project.

I've had this problem for quite a while now. It sucks :(

alt text

capture.png (218.4 kB)
avatar image Tim C ♦♦ STAFF Jan 19 '15 at 06:54 PM

Could you please download this file and place it on your desktop. Remove the .txt extension and run the file. It will create a new info.txt file on your desktop. If you could upload that here, it may give some clues to what is happening.

What version of Visual Studio 2013 are you using?

avatar image sillydan Jan 21 '15 at 12:31 AM

I'm using VS Express 2013 for Desktop on a 64bit windows 7 ultimate system

The batch file doesnt work?? It doesnt output anything on my end

avatar image sillydan Jan 21 '15 at 12:39 AM

Okay... For some reason it generated it in my System32 folder instead?... Probably because of administator rights or something

Anyways... Here it is: file

info.txt (5.0 kB)
avatar image sillydan Jan 26 '15 at 06:50 PM

Sorry for seeming pushy... But I'd like to have the ability to work on my game... Did the file help any?

avatar image Tim C ♦♦ STAFF Jan 26 '15 at 08:31 PM

I apologize for the delay. The information in the file you provided looks like it is ok. I have a few extra files showing in my version of the file, but that may be because I have the Professional version installed.

There is very little information available about mspdb120.dll. The only remedies I have been able to turn up were in relation to files used by older versions of Visual Studio, though they may still work with VS 2013.

  • Run vcvars64.bat located in ..\Microsoft Visual Studio 12.0\VC\bin\amd64. You might also try running vcvars32.bat located in ..\Microsoft Visual Studio 12.0\VC\bin just to make sure both versions of the file are correct.

  • Repair/re-install Visual Studio.

We also have had one UE4 user who saw this same error message several months ago who was able to resolve the issue by re-installing Windows. However, this isn't a step that I would recommend unless absolutely nothing else is helping.

If you try re-installing Visual Studio, have you considered upgrading to the Community version? This is essentially the Professional version, but free if you meet the restrictions for its use.

avatar image Tim C ♦♦ STAFF Feb 02 '15 at 10:58 PM

Hi sillydan,

I just wanted to check in and see if any of the suggestions I was able to find regarding mspdb120.dll were helpful for you. Are you still receiving the same error message?

avatar image sillydan Feb 04 '15 at 12:39 AM

Installing the community version fixed almost everything. I still can't compile the engine or any project for that matter without manually setting the VC++ Directories Everytime I create a new project. I can't compile code in-editor either, which sucks a bit... but that is solved by recompiling the project in visual studio. But I can code and build games now! I don't get the stupid "dll is missing" error!

Thanks for the support! You have been extremely helpful!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
more ▼

answered Oct 26 '14 at 10:50 PM

avatar image

Hodgeasaurus
158 15 18 25

avatar image sillydan Oct 27 '14 at 10:06 AM

The links your posted are broken. :(

avatar image Hodgeasaurus Oct 27 '14 at 11:18 AM

Ok, try accessing them directly from the GitHub page.

https://github.com/EpicGames/UnrealEngine/tree/4.5

You will need to log in to see this!

The required files are under Getting Up And Running.

avatar image sillydan Jan 11 '15 at 09:00 PM

Hi again. I still have this problem. So far I've been just using blueprints to fix my problems, but I seriously need the freedom of C++... I can't download anything from the links posted. All I get is 404's...

Also... This isn't really helping: alt text

capture.png (32.5 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question