x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

SWARM Cache Error

I supervise approximately 50 users in an educational lab environment. I have a couple users that get this error. All other users seem to build lighting fine. I suspect it's a problem with their level files or projects. I've seen other posts about this but I when I try to comment on those it won't post... Has anyone found a fix or workaround for this?

Intel Processors = Xeon Dual Quad Core 2.00GGHz Video card = NVIDIA GeForce GTX TITAN Black Driver = 9.18.13.4052 64GB RAM Windows 7

1:24:42 PM: Starting up SwarmAgent ... 1:24:42 PM: ... registering SwarmAgent with remoting service 1:24:42 PM: ... registering SwarmAgent network channels 1:24:43 PM: ... initializing SwarmAgent 1:24:43 PM: ......... certificate check has failed 1:24:43 PM: ...... initializing cache 1:24:43 PM: ......... using cache folder 'C:/Users/tharmon/AppData/Local/UnrealEngine/4.3/Saved/Swarm\SwarmCache' 1:24:43 PM: ......... recreating SwarmAgent cache staging area 1:24:43 PM: ...... initializing connection to SwarmCoordinator 1:24:43 PM: ......... using SwarmCoordinator on RENDER-01 1:24:45 PM: ......... SwarmCoordinator failed to be initialized 1:24:45 PM: ...... initializing local performance monitoring subsystem 1:24:47 PM: ... initialization successful, SwarmAgent now running 1:24:53 PM: [Interface:TryOpenConnection] Local connection established 1:24:53 PM: [Job] Accepted Job 44A141B8-4AB94822-B27F4A85-189B07D2 1:25:23 PM: [Interface:OpenChannel] Error: System.IO.IOException: The process cannot access the file 'C:\Users\tharmon\AppData\Local\UnrealEngine\4.3\Saved\Swarm\SwarmCache\AgentStagingArea\A6630D7233BF47B3BBCF76BB4350A2B5.290D943C4AE1EE26CFFC218C32EE9C7C.mtrlgz' because it is being used by another process. at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost) at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy) at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share) at NSwarm.FSwarmInterface.OpenChannel(String ChannelName, EChannelFlags ChannelFlags)

Product Version: Not Selected
Tags:
more ▼

asked Oct 27 '14 at 07:16 PM in Rendering

avatar image

hyperjams
6 2 4 5

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Hyperjams -

From looking at what you have above I would suggest going into the SwarmCache folder (listed above) and deleting the contents of the folder. Make sure that every file gets deleted (some of the files may be listed as read-only and may not want to delete). This should hopefully clear out the data and allow the Engine to reinitialize it.

Please let me know if that doesn't fix the issue -

Thank You

Eric Ketchum

more ▼

answered Oct 28 '14 at 05:23 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 256 733

avatar image hyperjams Oct 30 '14 at 09:07 PM

Deleting the cache doesn't help. Same issue.

avatar image Lovecraft_K ♦♦ STAFF Nov 07 '14 at 03:35 PM

Hey hyperjams -

Sorry for the delay getting back to you. Here is a breakdown to some common solutions to Swarm Agent Issues:

-Increase the Virtual Memory allocated to machine, can help with certain larger projects on lower RAM machines

-Copy all assets from one umap file to another.

-Copying the Swarm Cache Folder from one machine that is building lighting and placing it on a Machine which isn't building light

-Check Map and Project for unwanted or redundant lighting references.

-Rename any computers which have a CPU Workstation name beginning with a number or non-Latin Character.

Hopefully one of these will help you out -

Thank You

Eric Ketchum

avatar image hyperjams Nov 11 '14 at 12:54 AM

Hi Eric,

Thanks for the help on this. We tried each of these suggestions except for the redundant lighting references. I'm not sure exactly what that means? Where in the editor can I check for this?

avatar image Lovecraft_K ♦♦ STAFF Nov 11 '14 at 08:06 PM

This is a tough thing to check for, there is no exact method of identifying the lights that might be causing this problem. The only fool-proof way I know to do this is to systemically go in and delete and replace each light individually and try to rebuild after each one.

Eric Ketchum

avatar image hyperjams Nov 13 '14 at 02:30 PM

Update: the user was able to build lighting on a different machine (home computer), then bring that cache folder into the lab environment and replace the cache on that machine, then the lighting builds. After that first successful build, subsequent builds work fine.

Review: Approximately 100 users in an educational lab environment. Roaming profiles mean each user can sit at any machine at any time Software image is wiped clean and reinstalled every night which means these swarm cache folders are gone in the morning Only a few users have this problem building lighting, 90% of builds work fine. One user has figured out that he can build lighting on his home machine He then brings the cache into the school labs and lighting builds after that.

avatar image Lovecraft_K ♦♦ STAFF Nov 13 '14 at 03:11 PM

Hey hyperjams -

I am going to kink you over to this post as a user found a fairly good way to do what I was describing above and identifying errant items in a project. Thank you for your information though as we continue to investigate the Swarm related issues.

https://answers.unrealengine.com/questions/68053/lighting-build-failed-swarm-failed-to-kick-off.html

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question