x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

DefaultGameUserSettings.ini not functional anymore?

I brought my game project (BP only) over from 4.4.3 to 4.5.1 and now when I package it (haven't changed anything), all things that I setup in the DefaultGameUserSettings.ini aren't recognized anymore, again worked just fine with the previous version. Any ideas folks?

Content of the .ini file:

[/Script/Engine.GameUserSettings]

bUseVSync=True

ResolutionSizeX=1920

ResolutionSizeY=1080

bUseDesktopResolutionForFullscreen=False

FullscreenMode=0

Product Version: Not Selected
Tags:
more ▼

asked Oct 27 '14 at 08:35 PM in Using UE4

avatar image

The_Distiller
136 13 17 22

avatar image Doug E ♦♦ STAFF Oct 28 '14 at 03:24 PM

Hey The_Distiller-

When you say that they're not recognized are you receiving an error message when you try to package? Where are you running into problems and what exactly is happening when you do? The more information you can provide the easier it will be to solve whatever problem you're having.

Cheers

Doug Wilson

avatar image The_Distiller Oct 28 '14 at 03:43 PM

There is no error, but the commands of the .ini are apparently not executed anymore, since the packaged game doesn't start in fullscreen and at 1080p. Which it did when compiled with 4.4.3.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

6 answers: sort voted first

I figured out the problem painfully.

My unreal version: 4.8.3

Yesteday I tried Saved -> Config -> WindowsNoEditor -> GameUserSettings.ini and DefaultGameUserSettings.ini both but neither worked for me.

Finally today I found that, in DefaultGameUserSettings.ini:

 [/Script/Engine.GameUserSettings]
 bUseVSync=False
 ResolutionSizeX=640
 ResolutionSizeY=480
 LastUserConfirmedResolutionSizeX=640
 LastUserConfirmedResolutionSizeY=480
 WindowPosX=-1
 WindowPosY=-1
 FullscreenMode=2
 LastConfirmedFullscreenMode=2

The above ini failed. But if you add Version=5

 [/Script/Engine.GameUserSettings]
 bUseVSync=False
 ResolutionSizeX=640
 ResolutionSizeY=480
 LastUserConfirmedResolutionSizeX=640
 LastUserConfirmedResolutionSizeY=480
 WindowPosX=-1
 WindowPosY=-1
 FullscreenMode=2
 LastConfirmedFullscreenMode=2
 Version=5

It works. I really don't know what is the meaning of this Version=5 thing

more ▼

answered Sep 17 '15 at 09:48 AM

avatar image

DJI_PSY
30 1 1 1

avatar image vanzeipel Nov 09 '15 at 04:52 PM

Thanks, the Version=5 line was what fixed my packaged build default resolution issue. I created "DefaultGameUserSettings.ini" in my Config folder instead of modifying "GameUserSettings.ini" in Saved/Config.

avatar image haimat Nov 09 '15 at 08:49 PM

I wrote a short tutorial on this matter some time ago. Maybe it is of some help for you: https://impetus-games.com/blog/Persistent-Graphics-Settings-in-UE4

avatar image hdelattre Nov 30 '17 at 10:48 PM

From the UGameUserSettings documentation:

"Version: All settings will be wiped and set to default if the serialized version differs from UE_GAMEUSERSETTINGS_VERSION"

So if you don't have the version properly setup in a DefaultGameUserSettings.ini it will think they're out of date and erase them. Thanks for this fix!

avatar image Kokuyouseki Feb 05 '19 at 05:32 PM

Hmm, I guess it would be too much to ask Epic for a way to tell what version I should use inside the editor? Hell, would love to have a "default settings" part in the project settings so that I don't have to "guess" the contents. Lazy I know but since it either works or not sorta annoys me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I found a procedure that works:

  1. Start the cooked game and enter full screen mode manually via alt+enter, exit the game. (This will fill the former empty GameUserSettings.ini)

  2. Go to saved -> config -> WindowsNoEditor and open the GameUserSettings.ini

  3. Change the content to your preferred settings, for me it was activating vsync and set the resolution to 1080p.

more ▼

answered Nov 11 '14 at 01:50 PM

avatar image

The_Distiller
136 13 17 22

avatar image Eshank Jul 07 '15 at 06:05 AM

Hey I am following the same procedure but my GameUserSettings.ini does not fill

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Having the same issue. Before I could use DefaultGameUserSettings.ini or just change GameUserSettings in the WindowsNoEditor build folder to set start resolution and fullscreen on launch. No longer working.

more ▼

answered Oct 31 '14 at 01:04 PM

avatar image

THREEONEZERO
131 6 7 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

In the project folder, go to the Saved -> Config -> Windows folder and open the GameUserSettings.ini file. Copy the contents of the file and replace the contents of the Saved -> Config -> WindowsNoEditor -> GameUserSettings.ini file of the packaged game. Make any changes to this file and save it before launching the packaged game again.

Cheers

Doug Wilson

more ▼

answered Oct 31 '14 at 05:27 PM

avatar image The_Distiller Nov 09 '14 at 11:27 PM

When I do the exact steps listed above and launch the cooked game, the GameUserSettings.ini get's cleared, hence when I open it after launching and exiting the cooked game, it's empty.

avatar image Awesome_Junior_Miss Mar 10 '15 at 10:45 AM

Sorry for bumping here. I got same issue. It seems that UE4 doesn't save anything into config files under "Saved" folder anymore since version 4.6. My question link is here, that haven't been answered yet : [link text][1] [1]: http://answers.unrealengine.com/questions/185140/why-does-ue4-save-nothing-into-config-files-in-sav.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Another option would be to make a shortcut to the executable and add command line arguments alt text

It would be great to have the default resolution settings for the packaged game available in the Project settings in the editor.

I was surprised that the Editor settings for "Play in Standalone Game" didn't carry over to the packaged game, but even the "play in stand alone game" section doesn't have a fullscreen option. I had to add "-fullscreen" in Additional launch parameters to get the game to be fullscreen there.

It would be great to have a fullscreen option in the play in standalone game section in the editor. alt text

more ▼

answered May 03 '15 at 02:59 PM

avatar image

Savitus
11 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, after trial and error I found that DefaultGameUserSettings.ini does indeed still work but no longer in the saved folder. Instead you need to put it in:

 WindowsNoEditor/ProjectName/Config

This is what worked for me. I realise this question is quite old now, but I'm sure there are plenty of people who are still having this problem.

more ▼

answered Jun 07 '15 at 01:05 PM

avatar image

sometallgit
1 2

avatar image haimat Aug 07 '15 at 01:02 PM

That doesn't work for me in 4.8 -- I created that folder in the packaged project, added the DefaultGameUserSettings.ini file, but nothing is changed, those settings are not set when launching the game :-(

avatar image The_Distiller Aug 25 '15 at 09:53 PM

I just gave it another try in 4.8.3 and it works right away. You shouldn't create a folder, instead you have to execute the game once and the folder will be created automatically. After you opened the game once, make sure you overwrite the GameUserSettings.ini in the correct folder.

For this test I called the project "fullscreen_test".

So the correct path is: fullscreen_test -> fullscreen_test -> Saved -> Config -> WindowsNoEditor.

I attached my GameUserSettings.ini to this message.link text

avatar image haimat Aug 25 '15 at 09:56 PM

Thanks for the feedback!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question