x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Root Motion not being applied

When i go to play a montage with root motion applied to it, the animation is played all except the root moving. The root fails to move! Here is my montage setup. Is there anything special that i need to do with the character other then call montage play on the montage and setup the slot? alt text alt text Thank you so much for any help that you can give me. You are the best!!! If there is any information that I need to provide please feel free to ask.

-Russell

Product Version: Not Selected
Tags:
capture.png (382.4 kB)
capture.png (77.9 kB)
more ▼

asked Oct 28 '14 at 02:55 AM in Everything Else

avatar image

GuapoTaco101
55 14 13 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

One way I use to test Root Animation:

In the Anim Blueprint in the event graph place a "Event Blueprint Intialize Animation" fed into a "Montage Play" node.

In your Animation select your AnimMontage and make sure that root motion and translation are checked.

Lastly, Looking at your AnimMontage and set the animation to loop. You'll need to do this by selecting the small Root next to Preview and then select the long green Root bar under Create Default. This will set it up to loop. You'll also see an "X" next to the small Root bar to disable the loop.

Let me know if this works for you. If not I can help further.

Thank you!

Tim

more ▼

answered Oct 30 '14 at 09:53 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question