x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Support Ubuntu 14.10 / gcc 4.9.1

Howdy. I'm not familiar with Unreal's build tool or how it works, but it seems it isn't compatible with the latest Ubuntu. Two issues:

To start, (this may not an issue with UE4) CMake won't recognize ATI's fglrx drivers and can't find libGL.so in the filesystem. This causes GenerateProjectFiles.sh to crash silently(!). I fixed this by manually linking /usr/lib/libGL.so to /usr/lib/fglrx/libGL.so.1

Second, following this exactly, make ShaderCompileWorker UnrealLightmass UE4Editor won't work either, lots of

cc1plus: error: unrecognized command line option "-Wno-ignored-attributes" [-Werror]

cc1plus: error: unrecognized command line option "-Wno-logical-op-parentheses" [-Werror]

The tool starts with $ make ShaderCompileWorker UnrealLightmass UE4Editor

Engine/Build/BatchFiles/Linux/Build.sh ShaderCompileWorker Linux Development

Building ShaderCompileWorker......

Using gcc version '4.9.1' (string), 4 (major), 9 (minor), 1 (patch)

I have that gcc and clang 3.5 installed.

Product Version: Not Selected
Tags:
more ▼

asked Oct 28 '14 at 11:07 AM in Linux

avatar image

skim
0 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Dec 12 '14 at 12:44 AM by amigo for the following reason:

The question is answered, right answer was accepted


1 answer: sort voted first

It should not be using gcc but clang for compiling through UBT.

You have to determine if there's something causing this, perhaps a configuration change between 14.04 and 14.10. LinuxToolChain detects clang on the system and uses it, so if that's not working it would probably fall back to gcc.

more ▼

answered Oct 28 '14 at 01:11 PM

avatar image

amigo
1.1k 53 33 90

avatar image skim Oct 29 '14 at 07:02 AM

Thanks, somehow clang got uninstalled between the time I ran the project files installer script and got to the makefile stage -- probably happened when I pasted the whole dependancy list from the linux build wiki into apt-get install. Oops!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question