x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why do I have a noticable gap in my audio when it loops?

So, I made a really simple soundcue for fire. I made four, five second snippets of a fire. Hooked them up to a random node, then that random node to a looping node, and that node to the output. Everything works as expected, but the only thing that is a miss is that the transitions between the fire loop samples. I have a noticeable gap in the audio each time a new sample is triggered. FYI, they all loop seamlessly in Wwise and in Pro Tools. I am missing something obvious? I tried playing around with some of the parameters, but to no avail. Thanks in advance.

JoeR.

Product Version: Not Selected
Tags:
more ▼

asked Oct 29 '14 at 12:51 AM in Using UE4

avatar image

JoeRed82
11 1 2 3

avatar image JoeRed82 Oct 29 '14 at 12:55 AM

alt text

soundcuescreen.jpg (232.4 kB)
(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hello JoeRed82,

I set up a sound cue similar to what you are doing and understand what you are hearing. Firstly change your max concurrent play count to like 32 or something higher than 1. What you are hearing is the "Random" node waits for each sound node to finish playing before choosing another one to play. If your sounds slowly fade, or if they have extra space at the end this is what is happening.

I have set up another way for you to customize your sounds to get rid of the delay so there is always a sound playing being mixed in randomly with the others. This way you have a consistent loop with sounds you have in your cue always playing. This also gives you more control within your Random node to add more weights to sounds you would like to always have playing versus mixing in others as well (which I am assuming you are attempting to achieve with fire).

Random Sounds Using Mixer Node

alt text

I hope this helps!

Andrew Hurley

more ▼

answered Oct 29 '14 at 04:02 PM

avatar image JoeRed82 Oct 29 '14 at 11:38 PM

Thanks Andrew, appreciate the answer. I am going to try this out now. Looks promising. Will post back with the results.

avatar image AndrewHurley Oct 30 '14 at 01:07 PM

You are welcome!

avatar image spyro Aug 17 '15 at 02:47 PM

Hi Andrew,

I got essentially the same problem in 4.8.3, even with an extremely simple setups like this:

alt text

After each loop there is a noticable gap. If I play the sound from the content browser (loop is set to TRUE) it works as expected without a gap.

I uploaded the sound here: https://mega.nz/#!OdIjACyA!kZecfc9XJdvNrDmGZdSzNlhMHoEDLA0yTotsvpSAqUk

avatar image AndrewHurley Aug 17 '15 at 06:41 PM

Hey Spyro,

The documentation has the answer you are looking for within the Sound Cue reference.

Sound Cue Reference

https://docs.unrealengine.com/latest/INT/Engine/Audio/SoundCues/NodeReference/index.html#loopingnode

Cheers,

Andrew Hurley

avatar image spyro Aug 18 '15 at 01:39 PM

Ah, thank you.

Solution (use the checkbox in the waveplayer):

alt text

Maybe this could just be added in the tooltip for the looping node (BTW: Why isn't the excellent documentation linked from there?)

avatar image aamir.edge Mar 20 '18 at 10:59 AM

Hi , it sill doesn't works for me.There is still a gap when looping the audio. Any other solution?

avatar image androidodo Mar 28 '18 at 04:52 PM

Yeah, it doesn't work for me as well. I have enabled the "Looping" checkbox on the wav file, and on the sound cue. It still has gap.

avatar image AndrewHurley Aug 18 '15 at 02:07 PM

I can add a feature request to have this changed.

Edit: I have created a feature request, UE-20097, for the suggest tooltip change. Thank you for taking the time to write the report and make the request.

Cheers,

Andrew Hurley

avatar image Bushey Mar 28 '18 at 11:03 PM

Hello,

Did this issue get fixed, I'm encountering the same issue in 4.18

(comments are locked)
10|2000 characters needed characters left

Hello,

Did this issue get fixed, I'm encountering the same issue in 4.18

more ▼

answered Mar 28 '18 at 11:03 PM

avatar image

Bushey
54 3 6 14

(comments are locked)
10|2000 characters needed characters left

Same issue here :( ! Any alternative solutions ?

more ▼

answered May 13 '18 at 05:50 AM

avatar image

Lil_Storm_xXx
1 1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question