x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 insists XCode is not installed

Apologies, but this is my first post on this forum so please bear with me!

I have a fresh installation of UE 4.5.1 and Xcode 6.1 on Mac OS X 10.10.

I've created a vanilla project based on TappyChicken and attempted to launch it on my iPhone 4S device through the launch options in the editor.

Whilst my device is listed in the device manager, the only options I'm given when clicking the Launch drop down button are "iOS Support" which insists I don't have XCode installed?

Based off of this post: Why can't UE4 detect Xcode on my Mac? it would appear that the check for Xcode is pretty straight forward and I can confirm that Xcode is indeed located in /Applications/Xcode.app

I've come to a bit of a sudden halt here, so any help would be appreciated!

PS I've place my (developer) .mobileprovision file in: /Users/Shared/UnrealEngine/4.5/Engine/Build/IOS/ and renamed it to: UE4Game.mobileprovision and have the necessary developer certificates in my keychain.

Cheers!

Product Version: Not Selected
Tags:
more ▼

asked Oct 29 '14 at 11:27 AM in Installation & Setup

avatar image

Benji666
1 1 2 3

avatar image Ravlek STAFF Oct 30 '14 at 12:59 PM

I'm not sure what's going on with this one. If Xcode is in /Applications then it should find it. Let me see if I can reproduce this as I just recently updated to OS X 10.10.

-Pete

avatar image Benji666 Oct 30 '14 at 01:34 PM

Thanks Pete! If it's any help, I upgraded to 10.10 rather than a fresh installation - hopefully that wouldn't have upset anything?

avatar image marksatt-pitbull STAFF Oct 31 '14 at 11:18 AM

Have you opened Xcode & allowed it to install any necessary additional components? You'll need to do this again if you have updated from 10.9 to 10.10 as the update process erases the components Xcode installs.

avatar image Benji666 Oct 31 '14 at 01:08 PM

I'm pretty sure I did, maybe I didn't give it long enough (our network has been incredibly slow recently). I'm on leave until Monday now, so will have a look at it first thing Monday morning and get back to you. Thanks for the suggestion :)

avatar image marksatt-pitbull STAFF Oct 31 '14 at 01:19 PM

If you didn't when you first launch Xcode it will pop-up a little dialog asking for permission to install additional components. If it launches straight into the project selector then they are already installed.

avatar image Benji666 Oct 31 '14 at 01:28 PM

Cool. I'll double check this on Monday, I might even try a fresh installation. I'll see about properly clearing any trace of Xcode from my Mac and try again if I don't get the pop-up and UE4 still can't find Xcode.

avatar image marksatt-pitbull STAFF Oct 31 '14 at 01:36 PM

You could also check where xcode-select thinks the default Xcode installation resides. In Terminal.app: xcode-select -p

This should be: /Applications/Xcode.app/Contents/Developer

Removing Xcode should just be case of deleting the Xcode.app bundle, removing the other components is unnecessary & unwise. You can always forcibly reinstall the command-line tools from the downloadable installers (or apparently even xcode-select).

The last thing to check would be the Xcode permissions - maybe during the update the permissions or owner have changed so that UE4 can't access Xcode. Disk Utility.app can repair disk permissions.

avatar image Benji666 Oct 31 '14 at 01:48 PM

That's brilliant thanks! I'll give this all a try - it all sounds promising! Fingers crossed :)

avatar image Benji666 Nov 03 '14 at 02:00 PM

Ok; I've run xcode-select -p from the command line which is definitely reporting back: /Applications/Xcode.app/Contents/Developer.

Xcode has installed additional components. I've even manually downloaded the Xcode command-line utils for 10.10 from the Apple Developer portal.

I've also used the Disk Utility app to repair permissions of which there were some issues, but nothing in the output seemed to suggest they were Xcode related.

Am really stumped now, as I really thought it may have been a permissions issue.

Short of doing a complete wipe of my system and a fresh install of everything, I'm not sure what else to try?

Can I supply you with any log output?

Again, thanks for any help you can give me :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I had the same issue with a project i was porting from Windows to OSX. Reinstalling XCode or Unreal did not work, and a newly created template project would work fine. My solution ended up editing the .uproject text file and removing everything except the main fields at the top and the "Modules" section. Specifically i removed the plugins section and the one that was listing the target platforms, even if it included MacNoEditor. Everything went smooth after that.

more ▼

answered Jun 21 '15 at 08:26 AM

avatar image

anticto
23 2 3 5

avatar image TheMayor Aug 23 '18 at 05:12 AM

In case anybody else runs into this problem, with XCode 10 Beta, I had to place it in Applications and rename it just XCode and everything is working fine now.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We had the exact same issue while developing a project on Windows and Mac, but unfortunately editing the .uproject file like anticto suggested in the answer above didn't work for us. After a bit of trial and error we found out that the issue was that the DefaultEditorPerProjectUserSettings.ini config file got checked-in under source control and contained the following settings which apparently were the source of the issue:

 [/Script/SourceCodeAccess.SourceCodeAccessSettings]
 PreferredAccessor=VisualStudio2017

Deleting the file and purging the config cache in /Users/[user]/Library/Application Support/Epic/UnrealEngine/4.15/Saved did the trick for us.

more ▼

answered May 17 '17 at 05:22 PM

avatar image

minifloppy
35 2 3 8

avatar image ColdSteel48 Mar 09 '18 at 12:06 PM

That worked! Thank you!!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Assuming that you are an admin user & that you've tried reinstalling Xcode, I'm at a complete loss. You could try using Finder's Get Info > Permissions panel to ensure that your user account has access to the Xcode app & all its contents (or use chmod & chown from the Terminal if you are sufficiently familiar with them). Until/unless we somehow stumble upon a way of reproducing this I'm stumped.

more ▼

answered Nov 20 '14 at 12:03 PM

avatar image

marksatt-pitbull STAFF
1k 31 4 44

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question