x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

PIE Crashes on second play

I'm running 4.5, vehicle template (not the advanced one), Pawn.cs has been modified to use Logitech G27 Wheel (this really should be native...for us non-C++ coders). Build.cs edited to use G27 Wheel as well. Everything compiles and works fine...even plays great when I use PIE. The issue is, when I try to PIE a second time, the editor crashes. The log doesn't show anything really...it's truncated. Just cuts off: last few lines:

 [2014.10.29-16.22.47:283][  0]LogAIModule: Creating AISystem for world Example_Map
 [2014.10.29-16.22.47:284][  0]Cmd: MAP CHECKDEP
 [2014.10.29-16.22.47:284][  0]MapCheck: New page: Example_Map - Oct 29, 2014, 4:22:47 AM
 [2014.10.29-16.22.47:486][  0]MapCheck: Info Map check compl

I can restart the editor and play in editor again just fine, but EVERY time, the editor crashes on the second play.

Product Version: Not Selected
Tags:
more ▼

asked Oct 29 '14 at 04:36 PM in Bug Reports

avatar image

Tearl
63 3 6 10

avatar image Tim C ♦♦ STAFF Nov 03 '14 at 05:23 PM

Hi Tearl,

I have a few questions that will help me as I start to investigate this issue.

  • Do you see the same crash occurring in an un-modified vehicle template?

  • Are you using 4.5.0 or 4.5.1?

  • Are you using the binary version of the Engine installed by the Launcher, or did you build the Engine using source code?

  • Can you provide the code that you are using to get your Logitech G27 Wheel to work, or a link to where you found the code?

  • When the crash occurs, does the Crash Reporter tool appear? If so, can you copy the callstack into a text document and upload it here (also, please make sure you always send us any crash reports that appear).

  • Could you also copy your log into a text file and upload that as well?

Thanks,

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Tearl,

We have not heard from you for a while. Do you still need any assistance with this issue? I will be marking this issue as resolved for tracking purposes. If you still need any help, please let us know. Any new comments on this issue will re-open it.

Tim

more ▼

answered Dec 11 '14 at 10:05 PM

avatar image Tearl Dec 11 '14 at 10:11 PM

Tim, Hi, and thanks for the reply. This issue is not fixed.I have not worked on the project for a long time now and we're not sure when we'll get back to it. We will revisit our issues when we get back to the project. Hopefully there will be less issues when we update that particular project to a newer version.

avatar image Tim C ♦♦ STAFF Dec 23 '14 at 02:19 PM

Whenever you get back to working on your project, if you run into this again please let us know. I will set this post as resolved for now, but feel free to re-open it at any time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question