x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4Editor.exe crash on startup - below min spec GPU

Hi,

I just downloaded Unreal Engine 4 and have tried to open the editor but it immediately crashes wont even show the editor window at all just goes straight to error reporting, I am on windows 8.1 and have tried setting comparability mode on all the exe's to windows 8 and windows 7 as well as to all running as administrator but still no luck.

I have also tried launching from both the unreal launcher and directly from the exe as well, still the same problem occurs I have also verified the install and no problem was found.

Any help would be greatly appreciated.

Thanks

Product Version: Not Selected
Tags:
more ▼

asked Mar 19 '14 at 09:20 PM in Installation & Setup

avatar image

wolfy959
1 2 4 4

(comments are locked)
10|2000 characters needed characters left

16 answers: sort voted first

There was some outdated information deep in some of our documentation that we are updating now. Sorry about that for anyone that ran across them. The correct system requirements are the ones listed on the sign up, payment and FAQ pages.

SYSTEM REQUIREMENTS:

  • Windows 7 64-bit or Mac OS X 10.9.2 or later

  • Quad-core Intel or AMD processor, 2.5 GHz or faster

  • NVIDIA GeForce 470 GTX or AMD Radeon 6870 HD series card or higher

  • 8 GB RAM

For anyone getting this crash, please check that your system meets these requirements.

If this is the case you can contact us for a refund.

If your system meets these requirements and you still have this crash with an Nvidia card please try the steps in this post.

If neither of these solve your case please leave a comment so we can continue trying to help. If you haven't attached a dxdiag report please do so.

more ▼

answered Mar 20 '14 at 08:21 PM

avatar image

zeroprey0 STAFF
231 5 4 15

avatar image MERSHED TERTERS ♦♦ STAFF Mar 25 '14 at 11:28 PM

A QFE is now available which should fix the crash on startup. We'll be bundling this fix into a public patch later this week.

Just to reiterate - even though this crash is fixed, we don't guarantee that performance will be at an acceptable level if you're using a GPU below our recommended spec.

http://cdn.unrealengine.com/qfe/QFE-FromCL-2027741-Shelve-2031721.exe

(comments are locked)
10|2000 characters needed characters left

Hi,

My issue got solved here https://answers.unrealengine.com/questions/14856/ue4editor-cmdexe-crashed-after-launch-1.html

Editor re-compiled with patch is launching fine now.

more ▼

answered Mar 23 '14 at 03:45 PM

avatar image

GameKittens
71 2 3

avatar image senress STAFF Mar 24 '14 at 12:55 AM

That patch should solve this issue. Also we are hoping to get a QFE out on Monday for those who don't compile from source.

(comments are locked)
10|2000 characters needed characters left

Hi Wolfgang, what sort of error message are you receiving?

more ▼

answered Mar 19 '14 at 09:26 PM

avatar image

Nick Darnell ♦♦ STAFF
6k 77 36 151

avatar image wolfy959 Mar 19 '14 at 09:30 PM

Hi Nick,

Well it just says the process has crashed, there is no error number (I have attached an image). this is the only thing that is shown.alt text

error.png (32.9 kB)
avatar image Nick Darnell ♦♦ STAFF Mar 20 '14 at 12:19 PM

Hey Wolfgang,

Can you attach your CrashReportClient logs found here: C:\Program Files\Unreal Engine\4.0\Engine\Programs\CrashReportClient\Saved\Logs

Thanks! Nick (Epic Games)

avatar image wolfy959 Mar 20 '14 at 12:29 PM

Hi Nick,

Here is the "log file" hope it helps.

Thanks.

(comments are locked)
10|2000 characters needed characters left

I am having this same problem. Have you found a solution?

more ▼

answered Mar 20 '14 at 05:22 AM

avatar image

Matthew Slanchik
132 27 33 36

avatar image wolfy959 Mar 20 '14 at 10:47 AM

Hi VFX,

No I haven't as yet found a solution although I am thinking it might be due to windows 8.1, or it could be my graphics card being too old (DirectX10) but have tried adding the parameters '-d3d10' & '-dx10' still no luck. However if you check here link text it does say minimum of DirectX 10 and does not mention windows 8.1, but I noticed it is referring to something called 'rocket' I think this is an earlier build of the unreal engine 4, so maybe this page needs updating.

If you manage to fix the problem would you mind letting me know it would be appreciated.

(comments are locked)
10|2000 characters needed characters left

Your Graphic Card is updated?

more ▼

answered Mar 20 '14 at 12:02 PM

avatar image

EduCazev
146 3 3 6

avatar image wolfy959 Mar 20 '14 at 12:05 PM

yes i am using a HD3870 with amd driver version 13.1

(comments are locked)
10|2000 characters needed characters left

Hi Wolfgang, Would you mind sending us your engine log file too? It should be stored at:

C:\Users\\AppData\Local\UnrealEngine\4.0\Saved\Logs

Thanks, Ben

more ▼

answered Mar 20 '14 at 01:02 PM

avatar image

Ben Marsh STAFF
778 24 9 18

(comments are locked)
10|2000 characters needed characters left

Hi Ben,

Just an update I read through the crash report log i posted above and i downloaded the font files that it was showing as missing:

  • DroidSansFallback.ttf (not showing as missing but wouldn't open when clicked on)

  • DroidSansMono.ttf

  • Roboto-Black.ttf

All these fonts were easy and free to download they where placed into "../../../Engine/Content/Slate/Fonts/" i clicked on each one and installed just to make sure it worked and i replaced the DroidSansFallback font with a working one. this then reduced the crash report log down to just this "crash report new log".

In regards to the engine log file i couldn't find the exact log file in the directory you refereed to because there is no such directory, possibly because the program has yet to generate it from not starting properly. I do have the UnrealEngineLauncher log from the directory "AppData\Local\UnrealEngineLauncher\Saved\Logs" if that helps at all, from what I can see the only noticeable similarity is to do with the module manager having error "StaticallyLinkedModuleInitializers function is null".

Thanks josh.

more ▼

answered Mar 20 '14 at 01:33 PM

avatar image

wolfy959
1 2 4 4

avatar image Ben Marsh STAFF Mar 20 '14 at 01:50 PM

I'd forgotten about a bug fix which just missed our first release causing the logs to be saved in the wrong place. Could you check in C:\ProgramData\Epic\Engine\Saved\Logs?

Ben

avatar image wolfy959 Mar 20 '14 at 01:56 PM

Ahh right okay I have found this located in that folder UE4.log.

Josh

ue4.txt (5.5 kB)
avatar image wolfy959 Mar 20 '14 at 02:05 PM

Hi I just noticed something odd the unreal engine 4 is installed on to the C:// drive but in that log i just uploaded it mentions "D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.0\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11VertexBuffer.cpp:69 with error E_INVALIDARG".

I do have a D:// drive on my pc but there is no such folder/file tree called BuildFarm.

avatar image Ben Marsh STAFF Mar 20 '14 at 02:12 PM

That's nothing to worry about - we have a number of PCs at Epic to automate UE4 builds for us. That path is to a source file on the build machine that compiled the editor you're running.

I'll ask one of our rendering engineers to have a look at your crash log.

avatar image wolfy959 Mar 20 '14 at 02:32 PM

okay i understand, thanks for your time and help on this matter.

(comments are locked)
10|2000 characters needed characters left

I have got exactly this error lol !

more ▼

answered Mar 20 '14 at 02:30 PM

avatar image

GameKittens
71 2 3

avatar image wolfy959 Mar 20 '14 at 02:52 PM

Hi rt974,

What OS are you running? I have a feeling it might be the release itself which is the problem, did you recently download it?

avatar image GameKittens Mar 20 '14 at 03:20 PM

Im on windows 8, i downloaded the msi installer "Latest download" in the dashboard yesterday evening. I re-downloaded/installed it today.

Crash when pressing "Launch".

And i also tested building from source with vs 2013, compiled successfully in 1 hour. Then when i run the editor in debug or dev mode, it crash the same way with a lot of missing files. But the missing files do exist lol !

The funniest thing is that unity launched their version 5 today, epic day !

avatar image wolfy959 Mar 20 '14 at 03:33 PM

so the same situation as me then although haven't tried build the source was going to but glad Ive not started probably a waste of time, I hope an update or a fix is issued soon really eager to get using this software (not a fan of unity myself)

avatar image MERSHED TERTERS ♦♦ STAFF Mar 21 '14 at 09:12 PM

Can you post your system specs? We're trying to identify what might be triggered by below recommended GPU spec (the issue here), and what might be an entirely different problem. Also, would be great to see your logs at C:\ProgramData\Epic\Engine\Saved\Logs.

avatar image wolfy959 Mar 21 '14 at 11:15 PM

Hi Leslie,

Just wanted to say thanks to Brian for his help I didn't realise I only had 500mb GPU. Just got a new AMD R9 270 and everything is working perfectly, I have attached my DxDiag as you asked and the Log File.

dxdiag.txt (90.2 kB)
ue4_new.txt (26.2 kB)
avatar image zeroprey0 STAFF Mar 22 '14 at 03:12 AM

Good to hear!

(comments are locked)
10|2000 characters needed characters left

Hello! I have the same problem. I installed the engine (binary version), launched it from Unreal Engine Launcher and created new empty project. Opened it and the engine crashed with the same message like on the screenshot above. I tried to relaunch it, selected earlier created project and opened it, but no fair - same crash again. My OS is Windows 7 64-bit. I haven't Visual Studio 2013 installed. My GPU is nVidia GeForce GTX 760 and pre-latest drivers. Attached the logs below.

ue4.txt (23.7 kB)
more ▼

answered Mar 20 '14 at 05:27 PM

avatar image

SergeyEvseev
1 1 1

(comments are locked)
10|2000 characters needed characters left

Would you guys mind trying running with -d3debug in the command line, and then posting the updated log? It will give us more info to help track this down.

more ▼

answered Mar 20 '14 at 06:07 PM

avatar image

RCaloca STAFF
258 4 3 5

avatar image SergeyEvseev Mar 20 '14 at 06:18 PM

Which file should we launch with command line flag -d3debug? UE4Editor.exe? If answer is yes, then I launched it with this flag and message box appeared with text "DX11 feature level 10.0 is required to run the engine". And what log should be changed?

avatar image wolfy959 Mar 20 '14 at 06:20 PM

Here is the updated UE4 log file hope this is the log file you are referring too.

ue41.txt (5.6 kB)
avatar image zeroprey0 STAFF Mar 20 '14 at 07:45 PM

None of the video card adapters listed in your log meet the system requirements of 1GB of dedicated video memory. This will result in the crash you see. Your AMD card has 512MB it looks like. Is that correct?

avatar image SergeyEvseev Mar 20 '14 at 06:28 PM

wolfgang959, what should I do to get same log with command line argument being filled with -d3debug? In my UE4.log file "command line" line is empty. What executable should I run with the flag?

avatar image wolfy959 Mar 20 '14 at 06:33 PM

In the win64 folder where UE4Editor and UE4Editor-Cmd is open a command prompt (shift + right click -> open command window here) in the cmd window type:

UE4Editor-Cmd.exe - d3debug

That will generate the correct file your after. It seem that your able to get a little further than I can with running this program my log is not as extensive as your previous one.

avatar image SergeyEvseev Mar 20 '14 at 06:40 PM

Huh, for me it shows the same message box that "DX11 feature level 10.0 is required to run the engine" and nothing else at all. Accordingly to that UE4.log file is very short. BTW, excuse me for my bad english, I'm not a native.

ue4.txt (1.5 kB)
avatar image wolfy959 Mar 20 '14 at 06:49 PM

Hi Sergey, I don't seem to be getting that same error as you about the DirectX11, In my DxDiag it shows as my computer having DirectX 11 but my GPU is only DirectX 10. I can only assume the error your getting is referring to this:

"Using feature levels, you can develop an application for Direct3D 9, Microsoft Direct3D 10, or Direct3D 11, and then run it on 9, 10 or 11 hardware (with some exceptions of course, new 11 features will not run on an existing 9 card for example)" (http://msdn.microsoft.com/en-us/library/windows/desktop/ff476876(v=vs.85).aspx)

avatar image SergeyEvseev Mar 20 '14 at 06:41 PM

By the way, thank you and excuse me for my bad english. I'm not a native.

(comments are locked)
10|2000 characters needed characters left

,Can folks with this crash please run dxdiag and attach the report.

To do so:

  • Press Windows key+R on your keyboard. This brings up the run box.

  • Type cmd, enter. This brings up the command prompt..

  • In the command prompt window type dxdiag, enter.

  • It may ask you to check for certified drivers. You can say no.

  • DxDiag will come up. Once the progress bar finishes click "Save All Information" button. This will store the info to a text file. It would be helpful if you could rename the file DxDiag_YourUserName.txt because attachments for some reason are getting mixed up.

This report gives us info about your system hardware and configuration. Some of these crash logs have video cards with less than 1 GB dedicated memory that is the minimum system requirement. I don't think all do though so it would be helpful to confirm.

Thanks

more ▼

answered Mar 20 '14 at 07:10 PM

avatar image

zeroprey0 STAFF
231 5 4 15

avatar image SergeyEvseev Mar 20 '14 at 07:45 PM

Here's my one.

avatar image SXX Mar 20 '14 at 07:54 PM

You don't have Windows 7 Service Pack 1 installed and this might cause your problem.

avatar image SergeyEvseev Mar 26 '14 at 11:20 PM

Oh my God! I downloaded Content Examples and the engine works now like a charm. Earlier I wasn't able to download it, because my system drive C: didn't have free space (I'm using another drive for work with lot of free space). It's a shame that I am not able to choose a folder for downloading content!

(comments are locked)
10|2000 characters needed characters left

I was having this issue last night, where it would crash the instant the editor loaded. It turned out my laptop was trying to run it through the integrated Intel HD graphics chip (64mb), rather than through the NVidia GeForce card(4gb)...... my laptop should automatically decide which one to use, but I had to force it to use my GeForce card for it to work.

See my post for the fix

It won't be the case for everybody, but it's worth a look for people having issues launching the editor.

more ▼

answered Mar 20 '14 at 07:17 PM

avatar image

OnePunchPete
176 8 9 224

(comments are locked)
10|2000 characters needed characters left

It's mine link text

dxdiag_dino.txt (34.9 kB)
more ▼

answered Mar 21 '14 at 02:02 AM

avatar image

Dino
1 1 3 3

avatar image zeroprey0 STAFF Mar 21 '14 at 03:14 AM

Have you tried the steps explained here? Do they help?

Could you attach your CrashReportClient log and engine log with the _Username renaming?

avatar image Dino Mar 21 '14 at 05:25 AM

It did't help cuz i just got only one video card nvdia 550ti and here is my log files link text

avatar image MERSHED TERTERS ♦♦ STAFF Mar 21 '14 at 10:59 PM

Hi Dino, is the launcher crashing on load or the editor itself? If it's the editor, can you also attach your editor logs? Can be found at C:\ProgramData\Epic\Engine\Saved\Logs. Thanks for your patience!

avatar image Dino Mar 25 '14 at 05:41 AM

link text

avatar image MrIncredibleN7 Mar 22 '14 at 04:16 AM

Brian, the solution that you link to fixed it for me. The launcher was selecting my integrated graphics card and not my high performance NVIDIA.

Thanks!

(comments are locked)
10|2000 characters needed characters left

I dont understand why this is locked to graphics cards above 1 GB.

I can run udk and dx10 games without problems.

There is a 2D demo in ue4, if someone needs to make a simple 2D game or low poly mobile game he still needs an nvidia gtx 780.

You make an affordable plan and give access to source code while this would cost a lot in the past, but you expect everybody to have the last graphics cards on the market.

If you wont unlock this my last hope is to subscribe to the new unity 5 plan they launched 2 days ago.

more ▼

answered Mar 22 '14 at 04:12 AM

avatar image

GameKittens
71 2 3

avatar image MERSHED TERTERS ♦♦ STAFF Mar 22 '14 at 05:10 PM

1 GB of VRAM is recommended to make sure everyone has a good experience in UE4 - from 2D games to our highest end sample. We're investigating crashes in this specific case where GPUs are below our recommended spec. Our internal tests of 512 MB card haven't resulted in crashes, nor did we expect this for the public.

Can you attach your engine logs after this crash (found at C:\ProgramData\Epic\Engine\Saved\Logs) and your dxdiag?

Thanks for your patience, and we do apologize that you haven't been able to dig into UE4 quite yet.

avatar image rozhok Mar 22 '14 at 06:49 PM

May I ask you to create some patch to run UE4 on slow gpu's?:) Here's report, the main problem I believe is

 LogD3D11RHI:Error: Direct3DDevice->CreateShaderResourceView(Texture2D->GetResource(), &SRVDesc, (ID3D11ShaderResourceView**)ShaderResourceView.GetInitReference()) failed 
      at D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.0\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Texture.cpp:1118 
      with error E_OUTOFMEMORY
avatar image MERSHED TERTERS ♦♦ STAFF Mar 25 '14 at 11:45 PM

Absolutely :). Try out the following: http://cdn.unrealengine.com/qfe/QFE-FromCL-2027741-Shelve-2031721.exe

We can't guarantee good performance, but you should at least not crash on launch.

avatar image rozhok Mar 26 '14 at 09:43 AM

Unfortunately, this fix doesn't work for me since I experience different error than rt974 (see above) :(

avatar image rozhok Mar 22 '14 at 06:52 PM

Here's my dxiag & crash log

link text link text

dxdiag.txt (38.0 kB)
(comments are locked)
10|2000 characters needed characters left

Hey guys, just downloaded launcher and tried to run editor - same problem. Seems that my videocard doesn't meet requirements, I have Intel HD 3000, but I've successfully ran compiled game from friend of my in low/high graphics level. Do I have a chances to run editor?

Thanks

more ▼

answered Mar 22 '14 at 11:24 AM

avatar image

rozhok
1 1 1

avatar image wolfy959 Mar 22 '14 at 02:24 PM

Hi Rozhok,

Well with Intel HD 3000 graphics things work a little differently although it uses your system RAM it only has 64mb of dedicated memory, the Unreal Engine require 1GB of GPU memory. Please take a look here at this thread. It might be a case of getting a newer GPU like I did to run this, what is your current GPU? Also have you tried setting the editor to run specifically with your GPU?

avatar image rozhok Mar 22 '14 at 03:06 PM

My GPU is Intel HD 3000 :) Unfortunately, I don't have option to change card. But my system has 16Gb or RAM and dxdiag shows that 1.5Gb is available for videocard. Well, that's all fine, but if I able to run game built on UE4, why I'm unable to run editor?

avatar image Nick Darnell ♦♦ STAFF Mar 22 '14 at 03:22 PM

Hi Rozhok,

I'm not sure if that GPU will run the editor fine or not. The short answer for why a game may work but the editor may not is because the editor has to do a lot more work.

The longer explanation is the games are cooked, lighting is baked, and optimized and configured not to do anything but run the game. The editor has to run un-optimized, nothing is cooked or baked because everything is changeable. It has to keep a lot more assets in memory than a normal game would, and it has to render all of the tools UI which we also run on the GPU.

Cheers, Nick (Epic Games)

avatar image rozhok Mar 22 '14 at 04:24 PM

Well, I'm ok if editor will work slowly, because I'm mostly into programming instead of level-design, etc. It's very sad, duh.

avatar image rozhok Mar 22 '14 at 06:53 PM

Is there option to run editor in DX9/10 modes?

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question