x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cant Duplicate (Ctrl w)/Copy Paste any node in Materials Editor

When I create a node (any node) and try to Ctrl+w or copy paste, nothing seems to happen. I do not get a copy of that node but when I Ctrl+z, the display in the lower right corner say "undo: Material Editor: Paste". I am using a PC. Any help would be greatly appreciated.

Using Unreal Engine 4.4.3

Product Version: Not Selected
Tags:
more ▼

asked Oct 31 '14 at 04:09 AM in Using UE4

avatar image

brad1100
5 1 2 4

avatar image AndrewHurley Nov 03 '14 at 07:49 PM

Hey brad1100,

I have had this happen to me as well, and it was because I was not completely inside of the Material Editor itself. Make sure your active panel is the Material Editor and the last click was on the node you wish to copy.

Try this and if you are still experiencing your issue please let us know and we will investigate further!

Thanks,

Andrew Hurley

avatar image brad1100 Nov 05 '14 at 09:07 PM

Sorry for late reply (working and finishing CS degree). So I tried that with no luck. Here is what I did: 1) Clicked on Material Editor Tab (also tried clicking on grid) 2) Clicked on the node 3) Clicked Ctrl+w (screen flashed but no new node was created) 4) Clicked Ctrl+z (displayed "Undo: Material Editor: Paste") 5) Clicked Ctrl+c (while node was highlighted) 6) Clicked Ctrl+v (nothing happened, not even a screen flash)

Any other suggestions would be well appreciated. Tried on two versions: 4.4.3 & 4.5.1

avatar image IronTaxi Jul 19 '15 at 01:16 PM

Having a very similar issue. Started in BLueprint editor in 4.7 couldnt copy/paste but now in main editor window as well .

I should be very specific.. I can copy/paste but the result is an empty object with the copied mesh no attached.

avatar image AndrewHurley Jul 20 '15 at 03:26 PM

Hey IronTaxi,

Your issue seems to be related, but I need some further information and clarification as to where exactly you are copying and pasting to and from?

If you could provide me with some simple steps to reproduce the issue you are experiencing in a new blank project we can begin finding the appropriate solution.

Thanks,

Andrew Hurley

avatar image DLROKen Sep 11 '18 at 10:35 AM

Mine works fine in old versions of the Engine, but all of a sudden it doesn't work in 4.20...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It works for me on a variety of versions of ue4. And it should work.

You could go to "Advanced settings > editor preferences > Keyboard shortcuts > Common Commands" and see if the controls are set properly, if not press "Reset to defaults" or edit them manually.

Keep in mind, the copy can skip a bit to the right when "Ctrl + w" is pressed, or when you "Paste" it might be close from where your last mouseclick was.

more ▼

answered Nov 01 '14 at 02:16 AM

avatar image

Luos
9.3k 286 65 330

avatar image brad1100 Nov 05 '14 at 08:34 PM

Tried that (unchecked and rechecked boxes) still no luck.

avatar image Luos Nov 05 '14 at 10:47 PM

Hmm.. I know its a bit "out there" but.. a reinstall maybe?

avatar image brad1100 Nov 10 '14 at 11:20 PM

tried that, did not work :(

avatar image AndrewHurley Nov 07 '14 at 04:11 PM

Are you using a source build from GitHub or are you running the engine from binary i.e. the Launcher?

avatar image brad1100 Nov 10 '14 at 11:21 PM

I am running the engine from binary.

avatar image AndrewHurley Nov 11 '14 at 04:08 PM

Would you mind sending a copy of your dxdiag?

Also are you working on a laptop or a desktop machine?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question