x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lightmap Schaddow Bleeding

Hi there.

I know this has been discussed a lot and I read many threads in here and all over the www but I couldn`t find anything that was helping me solve my problem. Btw, I never worked with Unreal before Unreal 4.0!

So now.

I have a static mesh, build in maya 15 on a windows machine, that I want to use a in a scene within UE 4.5.1. My problem with this is, the lightmap just isn`t gonna give me the result I`m looking for. Even though I managed to minimize the occurrence of shadow bleeding, there ist still some noise I just can`t get rid of. Here is what I tried so far:

  • the static mesh is part of a modular workflow, so I modeled exactly on the grid

  • I am using centimeters as a unit in maya

  • I set maya`s grid options to match UE4 (length and width 1000 / grid line every 100 / subdivisions every 100) so I have 1 grid line for each centimeter.

  • I set up the UV grid to match the intended lightmap resolution (1 devided by 128 = 0,0078125 = 128x128 UV grid tiles) so each grid tile represents 1 pixel of the lightmap.

  • I layed out the texture and seperate lightmap UVs in maya manually, according to the advice in WorldOfLevelDesign`s lightmap video series.

  • I tried with automapping

  • I tried with UE4 generatet lightmap UVs

  • I tried spacings of 2-5 pixels between each UV shell.

  • I tried snapping the UV shells to the UV grid

  • I tried different lights within UE4

  • I tried lightmap resolutions from 64 to 1024

Is it pissible, that my static mesh is to thin to recieve proper lightmap informations?

  • I thought it`s worth trying, so I scaled the UV shells of the thin part, but without success.

Btw, I turned off AO just to make sure not to have it fool me into thinking it was the lightmap, when it really was the AO. but that didn`t help either.

It took me forever to try everything back and forth, read articles, watch videos and so on, but nothing really solve it for me which is really frustrating. When I consider that there are many modular pieces for a big and complex scene waiting to be imported, i can only pray this isn`t gonna be an issue to that extend for each and every mesh!

Is there something I am overlooking? Somthing else i can do to solve this? Or is the only way to try and hide it with the texture map or maybe even have it cast dynamic shaddows??

alt text

alt text

Product Version: Not Selected
Tags:
lightmap3.jpg (19.3 kB)
lightmap9.jpg (54.9 kB)
more ▼

asked Nov 02 '14 at 11:50 AM in Using UE4

avatar image

DAkAR
103 10 16 131

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Ok, so I played with deffrent settings some more and I cam up with an almost perfekt result. I had maya autogenerate the lightmap UVs, then I cut every single uv edge and had them layed out using mayas 64 spacing preset. In unreal however I had to raise the lightmaps res to 256 for this result, but since this object will be placed hundreds of times in the my level, i really don`t want the lightmap res so high. not everyone has 8gb video memory just to have lightmaps load fast enough.

alt text

lightmap11.jpg (58.9 kB)
more ▼

answered Nov 02 '14 at 01:01 PM

avatar image

DAkAR
103 10 16 131

avatar image DAkAR Nov 04 '14 at 04:53 PM

Hi again,

why is this flagged as "resolved" when really it not ? I mean, I came up with a clean result, but I can`t use a 256 lightmap res on a small model for hundrets of copies throughout the level, or can I ?

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question