x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Feature Request] bDontLoadBlueprintOutsideEditor=false by default

Hi,

This is not technically a bug but i think it should be corrected nonetheless.

I opened (and closed) this thread:

https://answers.unrealengine.com/questions/127139/packaged-game-crashes.html

because i got systematic crashes with a packaged game (which worked fine in the editor) when using declaration such as:

 static ConstructorHelpers::FObjectFinder<UBlueprint> BP_d4Object(TEXT("Blueprint'/Game/dice/D4_Dice_BP.D4_Dice_BP'"));
     BP_d4 = (UClass*)BP_d4Object.Object->GeneratedClass;

Checking the DefaultEditor.ini, i saw this variable with a interesting name, set to true:

 bDontLoadBlueprintOutsideEditor=true

I tried to set it to false:

 bDontLoadBlueprintOutsideEditor=false

and bingo, my packaged game worked smooth and fine.

So this is no bug, but i think it would be nice to have it set to false by default when creating a new c++ project.

Thanks

Cedric

Product Version: Not Selected
Tags:
more ▼

asked Nov 02 '14 at 04:50 PM in Everything Else

avatar image

uced
870 75 93 363

avatar image hyperdr1ve Nov 13 '14 at 12:03 AM

What's the reasoning behind having this defaulted to true? I came here because my packaged game was also crashing.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It's true by default because Blueprints are not needed outside the editor.

It looks like you're attempting to access the Blueprint generated class through the Blueprint itself. Rather, you should just reference the class directly.

For Blueprint'/Game/dice/D4_Dice_BP.D4_Dice_BP'

The class reference is Class'/Game/dice/D4_Dice_BP.D4_Dice_BP_C'

 static ConstructorHelpers::FObjectFinder<UClass> bpClassFinder(TEXT("Class'/Game/dice/D4_Dice_BP.D4_Dice_BP_C'"));
 if (bpClassFinder.Object)
 {
     UClass* bpClass = bpClassFinder.Object;
 }

more ▼

answered Nov 13 '14 at 02:33 AM

avatar image

MulleDK19
2.7k 161 274 254

avatar image uced Nov 13 '14 at 06:54 AM

Thanks MulleDK19, that's gold to my newbie eyes !

This feature request can obviously be cancelled.

Or maybe replaced: could we then have an item "copy class reference" just below "copy reference" + the documentation alongside ?

The "copy reference" method is documented all around and that's very misleading for beginners (or maybe i missed something ?).

BTW this also answers my other post on the correct way to use BP in code, which i mention here in case anyone reads this:

https://answers.unrealengine.com/questions/130256/whats-the-correct-way-to-load-blueprints-for-packa.html

Thanks

avatar image Stormsson Mar 22 '18 at 10:08 PM

thank you man

avatar image darkgaze Sep 04 '18 at 09:22 AM

Note the "_C" at the end. It's not the name of the class, is a naming convention for the class of a blueprint. Don't forget that!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question