x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.5 Compiler errors on team's machine with same game source

Stemming from this post by my colleague: https://answers.unrealengine.com/questions/95133/problems-updating-project-to-44.html

We've just upgraded to 4.5 and experiencing similar issues from the previous post that seem to be originating from our custom Slate code. The game source, all files and settings are the same as on my machine but my colleague seems to be getting compiler errors which are stemming from the Slate code I have created.

We are both using the same game engine version from GitHub.

I have attached the compiler errors in a text file. We have had this issue for a while now and we're only able to work around this by commenting out the slate code for my colleague to work. I am unable to find the reason for the compiler errors. Any help is much appreciated.

I am able to share privately the game code if required.

https://dl.dropboxusercontent.com/u/25400185/QUBE2/Error/Compiler%20Error.doc

Thanks, Jon

Product Version: Not Selected
Tags:
more ▼

asked Nov 03 '14 at 12:18 PM in Bug Reports

avatar image

ZeJudge
59 4 7 16

avatar image Doug E ♦♦ STAFF Nov 06 '14 at 03:32 PM

Hey ZeJudge-

Was Matt's suggestion from the other thread to set GameViewportClientClassName in the project's DefaultEngine.ini to GameViewportClient able to help at all before? Also, is it possible for you to send your coworker a precompiled version of the project to open on his machine?

Cheers

Doug Wilson

avatar image ZeJudge Nov 06 '14 at 05:29 PM

Hi Doug,

Thanks for the response.

We've tried reverting GameViewportClientClassName back to the default but this had no affect.

Sending a precompiled version of the project is something that we used to do but it has turned out to be quite a large project so ends up taking a long time to upload/download and store. This is something that we can keep on doing but we were looking for a solution without doing this so workflow becomes faster for us.

Thanks, Jon

avatar image DaveHall17 Nov 12 '14 at 11:17 AM

Hi Doug we tried this fix this time after installing the engine via source , but we still got these error messages .

Error 2 error C1083: Cannot open include file: 'SQUBEPauseMenu.h': No such file or directory E:\UnrealProjects\ToxicGames\QUBE_SVNVersion\Source\QUBE\Private\Engine\QUBEHUD.cpp 7 1 QUBE Error 3 error : Failed to produce item: E:\UnrealProjects\ToxicGames\QUBE_SVNVersion\Binaries\Win64\UE4Editor-QUBE.dll E:\UnrealProjects\ToxicGames\QUBE_SVNVersion\Intermediate\ProjectFiles\ERROR QUBE Error 4 error MSB3073: The command "C:\Users\Dave\Documents\GitHub\UnrealEngine\UnrealEngine-4.5\UnrealEngine-4.5\Engine\Build\BatchFiles\Rebuild.bat QUBEEditor Win64 Development "E:\UnrealProjects\ToxicGames\QUBE_SVNVersion\QUBE.uproject"" exited with code 2. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets 43 5 QUBE

avatar image DaveHall17 Nov 12 '14 at 12:09 PM

I am still unable to build the project in Visual Studio , but I am able to open the project in the editor . I was not able to do this when using 4.4 installed via the Unreal Engine launcher , but I am using engine 4.5 installed via source . Everything appears to work OK in the editor , but I am unable to make package a build .

avatar image Doug E ♦♦ STAFF Nov 12 '14 at 04:16 PM

Hey DaveHall17-

What solution configuration are you working in? When attempting to compile the project are you running in debug mode or creating an actual build to run? The C1083 error you are receiving may be resolved by ensuring that Windows SDK is installed. Also check that the necessary dependencies have been downloaded and extracted.

Cheers

Doug Wilson

avatar image DaveHall17 Nov 12 '14 at 04:45 PM

Hi Doug .

I have been compiling in Visual Studio using Development editor Win 64 . I have not been using Windows SDK so will look into it .

Thanks

avatar image DaveHall17 Nov 13 '14 at 06:14 PM

I tried to re compile with the Windows SDK installed , but unfortunately I get the same error as before .

avatar image Doug E ♦♦ STAFF Nov 14 '14 at 03:16 PM

As a test are you able to build the project if you include the entire file path to 'SQUBEPauseMenu.h'? Another possible solution would be to create a new file and copy the contents of SQUBEPauseMenu, then save the new file with the same name.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hey ZeJudge and DaveHall17-

I apologize for the delayed response however after looking into this issue it appears to be a problem caused by Visual Studios. You can visit their forums at https://social.msdn.microsoft.com/forums/vstudio/en-us/home?category=visualstudio%2cvslanguages%2cvstfs%2cnetdevelopment%2cvsarch . Again I apologize we cannot be of further help and wish you luck in your project.

Doug Wilson

more ▼

answered Dec 05 '14 at 05:10 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Private Include Paths In Build CS

Dear ZeJudge,

First of all, hii!!!

Have you tried rearranging your source folder structure

so that you have this

Source/YourProjectName/YourSlate/ put all your special Slate files here

then in your build cs:

   PrivateIncludePaths.AddRange(new string[] { 
             "YourProjectName/YourSlate"
         });

I have had many problems compiling .h files for non UCLASS classes, I experienced them the most with my custom UI system that I made which is all pure C++ classes. The UBT gets highly confused by that somehow, buuut, if you use private include paths the UBT becomes very happy!

That's what has worked for me in every case where I could not get .h files to compile in the right order / find each other.

:)

Rama

more ▼

answered Nov 14 '14 at 05:19 PM

avatar image

Rama
10.7k 446 346 1090

avatar image Doug E ♦♦ STAFF Nov 25 '14 at 06:14 PM

Hey DaveHall17-

Were you able to test Rama's solution to see if that works for you?

avatar image DaveHall17 Nov 27 '14 at 03:43 PM

Unfortunately it did not work .

The error log for when I tried to re compile is in the link below .

https://www.dropbox.com/s/610r3s9xq707otb/4.5CompilleError_Nov17.rtf?dl=0

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The issue is fixed now . Thanks for everyone's help .

more ▼

answered Dec 10 '14 at 01:16 PM

avatar image

DaveHall17
161 13 18 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question