x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particle system - only 1st emitter when low framerate

Hi,

My particle system only uses the 1st emitter when the framerate is low. Is there any way to bypass that? Any help much appreciated.

Product Version: Not Selected
Tags:
more ▼

asked Nov 04 '14 at 02:57 AM in Rendering

avatar image

Madvoyer
101 15 18 25

avatar image Lovecraft_K ♦♦ STAFF Nov 07 '14 at 03:59 PM

Hey Madvoyer -

Can you give me some additional information about the particle system setup that you have and at what framerate you are first experiencing this issue at?

Thank You

Eric Ketchum

avatar image Madvoyer Nov 09 '14 at 06:01 PM

Result on medium setting (framerate around 20-25 FPS) http://gyazo.com/5448128e552b9530b4996221713b20cb

Result on epic setting (framerate around 10 FPS) http://gyazo.com/5d96d985431269bf7fc6493dbe21d103

My main concern is that particles will not render fine on matinee if I crank up the settings. I haven"t tried yet, but I'd like to know how well particles render in matinee.

I am using the latest version (4.5.1) and here is a screenshot of my particle system.

alt text

particlesystem.jpg (181.7 kB)
avatar image Madvoyer Nov 09 '14 at 06:05 PM

Basically when on epic (and only on epic when I have a low framerate), I do not get emission from the 2nd and 3rd emitters.

Thanks for any insight you could have with this :)

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

This is likely due to the CPU being used to emit the particles, when you reach a certain cap level the engine will no longer output any particles from the emitter.

To get around this limitation you will want to move the computation of the particles over to the GPU, as it can handle many times the number of particles being emitted compared to the CPU.

A good example (and explanation) can be found in the following video by Zak here:

https://www.youtube.com/watch?v=DcesEW380lc&index=5&list=PLZlv_N0_O1gYDLyB3LVfjYIcbBe8NqR8t

Also if you haven't already, I highly recommend watching the entire series he put together, it goes over everything you need to know about particles:

https://www.youtube.com/playlist?list=PLZlv_N0_O1gYDLyB3LVfjYIcbBe8NqR8t

Hope that helps! :)

more ▼

answered Nov 09 '14 at 07:40 PM

avatar image

DotCam
3.1k 74 34 147

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question