x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Material Editor Lag

I've read as many similar posts about this on here as possible and I don't think I fit into the same issue as I read it was a hardware issue..

I have a quad 3.0g, 8g ram and a GTX770. The editor and samples all run fine. Great, actually.

When I first create a material and bring in 1-2 textures, it lags insanely to the point where my mouse is next to unresponsive and ticks across the screen. If I hit the save button at the upper left, it corrects itself and runs perfectly smooth.

When I make a change to any parameters, the editor goes back into crazy lag as it starts to compile shaders. Even when I have as little as a single diffuse, normal and 2 constants for rough/metal, it compiles upwards of 140 shaders (worst case was 1004) and takes 1-2 minutes to complete. During this compile time I am lagging so badly that it's best to just not touch my computer. Once the compile is completed, it seems to once again correct itself and be 100% perfectly responsive and smooth.

I don't think my specs are bad and I've tried turning off the real-time previews, but nothing seems to help the issue. It's making it next to impossible to fluidly iterate through my material settings to get a good look without wasting almost 95% of the time just staring at the "Compiling Shaders" box. I'd venture to guess that it's slowing down my production time by about 323,448.314%.

Is this just me or is this basically how the material editor runs in general for everybody?

Product Version: Not Selected
Tags:
more ▼

asked Nov 06 '14 at 06:54 AM in Using UE4

avatar image

Hitpawz
551 22 29 45

avatar image AndrewHurley Nov 07 '14 at 03:50 PM

Hello Hitpawz,

This is odd that you are experiencing this issue with the set-up you provided. Whenever you make changes and apply the material, it will compile the shaders as needed. Although with a very simple material set-up as you described, it should not be taking that long to compile, or giving you such trouble.

First try updating your graphics driver to the latest version to see if this helps resolve your issue.

Could you also provide me with your dxdiag so I can further investigate as well?

Thanks,

Andrew Hurley

avatar image Hitpawz Nov 07 '14 at 07:23 PM

I just updated to the 11/4 drivers from NVidia and the issue is a bit better, but still somewhat persists. Compile times seem better but my mouse is still lagging while it's doing it.

http://www.ratsarmy.com/Hitpawz_DxDiag.txt

avatar image AndrewHurley Nov 10 '14 at 02:14 PM

Hey Hitpawz,

Looking at your dxdiag I noticed your BIOS has not been updated since 2008. If this is the most recent version of your BIOS available then that is fine, but this could be causing your computer not to perform as efficiently as possible. Try finding an update to your BIOS and see if this does not help improve your performance.

avatar image AndrewHurley Nov 11 '14 at 04:40 PM

I also noticed you are only using 4 CPU's under you processor, which is a fairly low amount for the recommended specs.

avatar image Hitpawz Nov 12 '14 at 03:28 AM

I was under the assumption my system specs fit within "recommended specs" due to the following statement:

Here's what we recommend to get started developing with UE4 right now.

Desktop PC or Mac Windows 7 64-bit or Mac OS X 10.9.2 or later Quad-core Intel or AMD processor, 2.5 GHz or faster NVIDIA GeForce 470 GTX or AMD Radeon 6870 HD series card or higher 8 GB RAM

Are these actually listing the "Minimum System Requirements"? Does it actually require a hex-core +?

avatar image AndrewHurley Nov 12 '14 at 04:39 PM

Yes these are essentially the recommended minimum, but the engine can run on lower end machines as well. Just not extremely well which is why we give these specs to the users as the recommended.

I asked another member of the team about your specs and you should be within the good range of running the engine so it actually is not your set-up. The issue must be occurring elsewhere in the editor.

On that note, try editing the your "Engine Scalability Settings" to see if this reduces the lag you are experiencing. Use the image below as reference as to where to edit these settings.

Engine Scalability Settings

alt text

Sometimes using the "Auto" button works well on how to gauge/find optimal settings for your computer.

Thank you,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Oh sweet, I'm still new to the editor and didn't actually see those settings. Everything seems to run a lot smoother just dropping AA on that actually. I think I'm good now and can call this resolved. Thank you for taking the time.

more ▼

answered Nov 12 '14 at 05:34 PM

avatar image

Hitpawz
551 22 29 45

avatar image AndrewHurley Nov 12 '14 at 06:10 PM

You are quite welcome! Let us know if you need anything else

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question