x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Perspective view black in all viewmodes (in all levels )

Hi,

I moved my question here from bug report. My complete project went black, and I can't really find a solution. The viewport is completely black, and doesn't show anything (not even the grid). If I package the same thing happens.

The only way I can see anything is to use the orthographic views, in the perspective view all viewmodes went black.

I didn't change anything before this problem occured, I believe it happened when I put the editor in the background. I rebuild the lighting, restarted the editor and restarted my PC. New video drivers were installed yesterday or the day before.

Does anyone know what to do? Thanks!

EDIT: My project works again. I didn't do anything at all to repair it, it just started like it should again. My guess is it was a bug, so maybe this can be reported?

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Nov 06 '14 at 04:02 PM in Everything Else

avatar image

BdeJong
47 8 15 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi BdeJong,

Glad to hear you are up and running again. There have been some issue related to Nvidia drivers. If you experience this issue again, please report it on this thread at which point I'll ask you for some additional information about your system in order to be able to submit an official bug report.

Thanks!

more ▼

answered Nov 07 '14 at 10:33 PM

avatar image OldSchoolPvP Nov 18 '14 at 10:07 PM

I have the same problem.When i open level everything is dark but when i copy all brushes in new level i can see them any solution. ?

avatar image Steve Hardister ♦♦ STAFF Nov 18 '14 at 10:29 PM

Hi OldSchoolPvp,

In order to help us troubleshoot your issue, please provide your DXDIAG: (Windows Start Button>(search “dxdiag”)>Launch dxdiag>select “Save all information”>attach text file to your post.)

Also if you are using an Nvidia GPU, please make sure you are running the latest drivers 10/25/2015

avatar image OldSchoolPvP Nov 18 '14 at 10:53 PM

link text Here it is ty for your help. I read this post about 5-6 hours ago tryed to update the drivers but i still had the problem.

dxdiag.txt (81.3 kB)
avatar image Steve Hardister ♦♦ STAFF Nov 19 '14 at 07:29 PM

Looking at your dxdiag, your system's Card name is: "Intel(R) HD Graphics 4000" which is below the recommended GPU specs located here: https://www.unrealengine.com/faq

You may still be able to use the engine, but there have been a few issues related to that specific card.

See Also this post: https://answers.unrealengine.com/questions/43460/unreal-editor-4-on-intel-hd-4000-graphics-1.html

avatar image OldSchoolPvP Nov 19 '14 at 09:43 PM

I have GEFORCE 740 + Intel Graphics.It seems Unreal is only reading my integral graphic card. Can you help me how to activate my geforce 740m card ( i alredy installed latest dravers on it )

avatar image Steve Hardister ♦♦ STAFF Nov 19 '14 at 10:19 PM

Right click on your desktop to and select your Nvidia Control Panel, then Select "Manage 3D Settings" > Program Settings > Add > Unreal Engine as shown here: alt text

settings.png (135.4 kB)
avatar image OldSchoolPvP Nov 19 '14 at 11:33 PM

Nothing happened still the same problem. I even disabled the integral card but i still have the problem :(. I will try to reinstall my win tommorow and let you know if my problem is solved. Sry for bad english and ty again for your help XD.

screenshot_1.png (208.3 kB)
screenshot_2.png (146.0 kB)
screenshot_3.png (350.8 kB)
avatar image Steve Hardister ♦♦ STAFF Nov 20 '14 at 02:21 PM

Hi OldSchoolPvP,

Thanks for providing screenshots of the issue. Now that you've added Unreal Engine with your Nvidia control panel, can you send another DXDiag while you have the editor running. This will show us if your Nvidia card is actually running while the editor is open. (This is something easy you can do before trying to reinstall Windows.)

avatar image OldSchoolPvP Nov 20 '14 at 04:54 PM

Lucky i just managed to make bootable usb but didnt format my pc XD. Maybe im the problem coz i just saw that with light i can see the object but its strange that i cant see it without lights. link text

dxdiag.txt (81.5 kB)
screenshot_1.png (423.9 kB)
screenshot_2.png (146.6 kB)
avatar image Steve Hardister ♦♦ STAFF Nov 20 '14 at 07:21 PM

Yes, you must have a light present to see anything in your level. It hadn't occurred to me that you did not have a light present. So, make sure you always have a light source in your level and if you continue to have problems, you can post on this thread.

Thanks

avatar image OldSchoolPvP Nov 25 '14 at 03:06 PM

Than why in this case there is no light and i can still see the objects but when i save it and open it again i cant see the elements.

screenshot_2.png (278.5 kB)
screenshot_1.png (442.8 kB)
avatar image Steve Hardister ♦♦ STAFF Nov 25 '14 at 06:19 PM

If you start a new level without any lights your view port will default to unlit mode as shown here:

alt text

unlit.png (108.5 kB)
avatar image sabridi Apr 14 '17 at 05:08 PM

just go to viewport---> viewmode---> unlit. problem solved :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I don't have the option to add Unreal Engine to my Nvidia 3d settings. My GPU is a GTX 1050 Ti

I also just had my perspective window go black, even though I can see my work in the other views.. Thanks for any help!

more ▼

answered Aug 29 '17 at 12:16 PM

avatar image

Claud.Krog
1

avatar image BlockGabe May 12 '19 at 08:23 PM

i also have a 1050ti and i have the same problem

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey,

I know it been a long time, but already I have this problem... On all the maps of my project, the perspective view is black, exept the sun... At first my computer was working slowly. So I restarted it, and that bug appear..

Help me please ;(

Thanks!

more ▼

answered Mar 24 '18 at 09:37 PM

avatar image

NilsooPS
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question