x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Renaming MyCharacter causes Default Property warnings and errors

1) I create a new C++ top down project(may happen on others I haven't checked).

2) Build project and start editor

3) Rename or move "MyCharacter" blueprint.

4) Save/Compile and close and reopen editor

5) get the following error:

Default Property warnings and errors: Error: CDO Constructor: Failed to find Class'/Game/Blueprints/MyCharacter.MyCharacter_C

I also tried changing this line in the GameMode.cpp file to reflect the change but I still get the error. static ConstructorHelpers::FClassFinder PlayerPawnBPClass(TEXT("/Game/Blueprints/MyCharacter"));

I have searched for other references but I failed to find any.

Product Version: Not Selected
Tags:
more ▼

asked Nov 07 '14 at 06:03 PM in Bug Reports

avatar image

TM317
76 9 12 18

avatar image kishoreven Feb 21 '15 at 08:46 PM

Did you find a work around for this or is this issue fixed? I am actually getting that error trying to run my packaged game. I renamed my character blueprint and while I am able to run the game in PIE, i am unable to package it out and run it.

avatar image Doug E ♦♦ STAFF Feb 23 '15 at 03:47 PM

Hey kishoreven-

Are you receiving the same "Default Property" error when opening the project/packaged game? If so you can try changing the name of the character blueprint back to the original name and then repackage the project. If the message you are getting when trying to open the packaged game is different then it would be best to start a new post with details about your specific problem. This helps with both tracking as well as searching for separate issues in the future.

Cheers

Doug Wilson

avatar image zaha Mar 10 '15 at 09:50 PM

This happened to me as well today. Renamed a Character Blueprint, now I'm always getting this error. Is there any fix yet?

avatar image Doug E ♦♦ STAFF Mar 11 '15 at 07:22 PM

Hey zaha-

Are you getting the error in the editor as TM317 reported or when trying to play a packaged game as kishoreven reported? Have you tried renaming the blueprint back to the original name then generate project files by right clicking on the .uproject icon in the project folder or repackage the project?

avatar image zaha Mar 11 '15 at 08:29 PM

Hi Doug! Thanks for getting back.

I eventually fixed the error message.The problem was, I copied a reference from the Unreal Ed to my PlayerCharacter Blueprint and used it in code to set my DefaultPawnClass in the GameMode. I get Blueprint'/Game/Blueprints/PlayerShip.PlayerShip' when copying it in the editor context menu, but this produced the error. As I later found out, the correct way to address it is static ConstructorHelpers::FClassFinder PlayerPawnBPClass(TEXT("Pawn'/Game/Blueprints/PlayerShip.PlayerShip_C'"));

Not sure if this is really a bug or if I misunderstood something here. Why does "Copy Reference" give me a string that does not work in this case? (still new to UE 4 :) )

[EDIT] Oh and to answer your question: I got the error as TM317 reported when starting the editor.

Cheers zaha

avatar image Doug E ♦♦ STAFF Mar 12 '15 at 02:57 PM

Using copy reference will copy the file path to the asset (in this case the blueprint) to your clipboard. As you pointed out, using the pawn rather than the pawn's blueprint is necessary.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey TM317-

Thanks for reporting this bug. I was able to reproduce this message and have submitted it to our internal tracking system (UE-5184) for further investigation.

Cheers

Doug Wilson

more ▼

answered Nov 07 '14 at 06:56 PM

avatar image twxyz Jan 15 '16 at 09:15 PM

More than 1 year later, it still happens.

avatar image skyphyr Jul 22 '17 at 10:50 PM

Got repro in 4.16, too.

avatar image Doug E ♦♦ STAFF Jul 24 '17 at 12:26 PM

Hey skyphyr-

Can you provide the steps that caused this to occur for you? The steps in the original reported issue (https://issues.unrealengine.com/issue/UE-5184) do not cause the warning to appear for me in 4.16.2.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question