x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Get Not Rendered Actors?

Hello!

Here is the question. I am planning to have a forest where trees have a chance to become creepy if the player is not looking at them. It is unfortunately not a first person game but a third person. So what I need is a way that I can check, certain actors are not rendered in the viewport/game screen. For example, the tree is far away and behind the player.

Is there any way to do this via blueprint?


If the question is not simple to answer, I would like to go on with Mister Rama's "get rendered actors" blueprint library node.

It looks awesome but I have a problem with it :(

First of all let me show you my blueprint, simple at best.

alt text

This is a simple blueprint that searches for a Test Actor I have selected in my map. The moment I start the game, the test actor is not on the viewport screen, so, when I check if the array contains the item, I get "True", as it is "get NOT rendered" node. And when I get my camera towards the test actor, I get "Found". Everything is fine, until I get my screen away from the test actor, which is not rendered anymore. I still get "Found", no matter what I do.

I tried to clean the array too before the 2 seconds delay, for a fresh render checking, but it's no use.

Problem seems to be that, the render check is not reseting itself, and/or completely ignoring "Min Recent Time".

Another example would be this blueprint;

alt text

At this one, I search for the candle blueprint. And no matter what I do, the blueprint is always considered "NOT rendered". There is no tranculency on materials. Its just a low poly candle.

There is a high chance I am doing this all terribly wrong. Is there anyway anyone can help?

Thank you all for your time and reading!

Product Version: Not Selected
Tags:
capture.png (225.1 kB)
capture2.png (199.4 kB)
more ▼

asked Nov 07 '14 at 06:24 PM in Rendering

avatar image

Achilleon
787 38 34 70

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question