x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Gnereating UV set in Static mesh editor

It seems that the ability to generate unique UV set has been removed from the editor, is there a way to re-enable it or did i break something?

Thanks guys.

Product Version: Not Selected
Tags:
more ▼

asked Nov 08 '14 at 12:25 AM in Rendering

avatar image

GBrodeur
35 6 11 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi GBrodeur,

I'm assuming you're using the latest engine version 4.5.x since you're not seeing the it in it's previous location under the menu bar > window > Generate UVs.

It has now been placed under the details panel when you open the mesh in the mesh viewer/editor > LOD0 > Build Settings >

Here you can choose the LM resolution and make sure you have Generate Lightmap UVs checked before you hit apply.

After this you will need to find Lightmap Coordinate Index and make sure that it is set to 1 for the newly created lightmap.

Thanks!

Tim

more ▼

answered Nov 10 '14 at 04:40 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image GBrodeur Nov 12 '14 at 10:09 AM

I get crashes now every time i use the feature.

MachineId:E7617F9F4EF22510C1DBD18014AFE959 EpicAccountId:3e9d59b27d80498d8e49d45f192c6281

Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.5\Engine\Source\Runtime\Core\Public\Containers\Array.h] [Line: 536] Array index out of bounds: 0 from an array of size 0

KERNELBASE + 37901 bytes UE4Editor_Core + 3174852 bytes UE4Editor_Core + 1677512 bytes UE4Editor_Core + 1566866 bytes UE4Editor_MeshUtilities + 207765 bytes UE4Editor_MeshUtilities + 143459 bytes UE4Editor_Engine + 8364051 bytes UE4Editor_Engine + 8365276 bytes UE4Editor_Engine + 8345177 bytes UE4Editor_Engine + 8538284 bytes UE4Editor_CoreUObject + 1064249 bytes UE4Editor_StaticMeshEditor + 229630 bytes UE4Editor_StaticMeshEditor + 456419 bytes UE4Editor_StaticMeshEditor + 315439 bytes UE4Editor_Slate + 2103098 bytes UE4Editor_Slate + 2285477 bytes UE4Editor_Slate + 822092 bytes UE4Editor_Slate + 756518 bytes UE4Editor_Core + 2506393 bytes UE4Editor_Core + 2450091 bytes UE4Editor_Core + 2510873 bytes UE4Editor_Core + 2438466 bytes user32 + 105425 bytes user32 + 104666 bytes UE4Editor_Core + 3157718 bytes UE4Editor!FEngineLoop::Tick() + 3106 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launchengineloop.cpp:2111] UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launch.cpp:133] UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:125] UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:201] UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

avatar image Tim Hobson ♦♦ STAFF Nov 12 '14 at 10:06 PM

This sounds like a bug I've reported with the generated LMs settings already with ticket UE-3102.

Can you do me a favor and provide the following:

  • Zip the crash folder that is created in this location: X: \ Users \ [ Your Computer Name ] \ AppData \ Local \ Microsoft \ Windows \ WER \ ReportQueue \

  • In your Unreal Projects folder (usually in documents) can you include the crash log and dmp from "Saved \ Logs."

This information will be relevant for me to attach to the bug report above.

Now for a little workaround and testing something to make sure we have the same issue:

Can you post a screen shot of your settings you're using in the Mesh Editor details panel where I indicated to change the build settings for the LM?

Thank you!

Tim

avatar image GBrodeur Nov 19 '14 at 04:33 AM

sorry for the late reply link text

crash.zip (690.9 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question