x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Cooking on linux

Hi, I am trying to build the starter 3d person c++ project on linux. Compiling the engine (4.5 branch) all worked out, but when I try to run the UAT script as described at https://wiki.unrealengine.com/Cooking_On_Linux as follows from the root of UnrealEngine

 Engine/Build/BatchFiles/RunUAT.sh  BuildCookRun -nocompile -nop4 -project="/root/projectdeckchair/ProjectDeckChair.uproject" -cook -compressed -allmaps -stage -archive -a    rchivedirectory="/root/" -package -LinuxNoEditor -clientconfig=Development -ue4exe=UE4Editor -clean -pak -targetplatform=Linux -utf8output

I get the following error, it looks like it is trying to find my game in the engine binaries folder..

 [2014.11.08-16.27.47:963][  0]LogModuleManager:Warning: ModuleManager: Unable to load module 'ProjectDeckChair' because the file '/root/UnrealEngine/Engine/Binaries/Linux/' was not found.   
 [2014.11.08-16.27.47:968][  0]The game module 'ProjectDeckChair' could not be found. Please ensure that this module exists and that it is compiled.

Does anyone know what exactly is going wrong?

Product Version: Not Selected
Tags:
more ▼

asked Nov 08 '14 at 05:07 PM in Linux

avatar image

ImNotAKompjoetr
8 3 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Jan 22 '15 at 04:00 PM by amigo for the following reason:

The question is answered, right answer was accepted


2 answers: sort voted first

The process in epic/master branch would be that you put your project (myProjectFolder) into the UE4 top folder, beside Engine/, Templates/ and Samples/ folders.

Then run ./GenerateProjectFIles.sh and it should add your project to the Makefile.

After that you will have target(s) for your project (verify by just typing: "make " with a space after it, press key then yes when prompted to display all possibilities. You should see your project's targets listed.

From there you: make myprojecttarget

If it doesn't find your project you might need to edit the file UE4Games.uprojectdirs and add your project to the bottom of the list, like so: myProjectFolder/ or whatever is the path where the .uproject file is located.

more ▼

answered Nov 09 '14 at 11:07 PM

avatar image

amigo
1.1k 53 33 90

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Before going anywhere further, please try putting your project folder inside engine's top level folder. We've noticed that building c++ projects works when that's done.

Also, it is possible that something got broken with cooking meanwhile. When I wrote the Wiki page, it was in my 4.4-linux branch and I haven't had a chance to revisit cooking in 4.5+. If I find a few moments I'll give it a try this weekend again on a newer branch.

Lastly, there's no reason to give UE4 elevated privileges in Linux, nor in general you should never run as a root user all the time.

more ▼

answered Nov 08 '14 at 06:55 PM

avatar image

amigo
1.1k 53 33 90

avatar image ImNotAKompjoetr Nov 08 '14 at 06:58 PM

Thanks, for the reply, I'll try putting the project in the UE folder first thing tomorrow! as for the root thing, I know it's not right, but I was being lazy.

avatar image ImNotAKompjoetr Nov 09 '14 at 11:10 AM

Putting the project in the engine's root folder did nothing, still have the same error.

avatar image amigo Nov 09 '14 at 01:36 PM

Did you generate project files again, though (sorry, I should've mentioned that earlier)?

If you are building a c++ project it needs to compile your custom code and the easiest way it does that is by putting the project into the engine root folder then letting the engine find your code and add it to the makefile.

avatar image ImNotAKompjoetr Nov 09 '14 at 05:42 PM

When I generate the project files again with my project files in the main engine folder I get the following error UnrealBuildTool Exception: ERROR: Not expecting project Engine/Intermediate/ProjectFiles/UE4.mk to already have a target rules of with configuration name Game (ProjectDeckChairTarget) while trying to add: UE4GameTarget

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question