x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

While creating a new C++ project Unreal Engine gets stuck "Binding IntelliSense Data (100%)

Version is 4.5.1, I have tried other versions and get the same result. MS Visual studio 2013 pro is installed and was installed prior to UE4. Blueprint template works fine

Product Version: Not Selected
Tags:
more ▼

asked Nov 11 '14 at 05:25 AM in Bug Reports

avatar image

MoneyTime
3 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello MoneyTime,

If you turn off IntelliSense in Visual Studio, that should allow you to skip that step entirely.

Regards,

Jonathan

more ▼

answered Nov 11 '14 at 04:49 PM

avatar image MoneyTime Nov 11 '14 at 06:33 PM

Hi Jonathan,

I have tried the solution above and am still unable to create the new project using the unreal project browser. The application still freezes on Binding IntelliSense Data (100%)

avatar image Jonathan Dorman STAFF Nov 11 '14 at 10:12 PM

So when it gets to "Binding IntelliSense Data (100% )", it simply never finishes? That's either a problem with VisualStudio or with the Engine. If it's VisualStudio, we might be able to find the problem if you do the following:

Download this attached file and delete the .txt extension. Run the batch file and it will create an info file that can tell us more about your visual studio installation.

Are you using the Launcher or GitHub version of the editor? Neither one should have this issue, but if you've had this same problem in multiple versions, then that means it's unlikely to be a problem with your specific engine installation.

avatar image MoneyTime Nov 12 '14 at 03:59 AM

Hi Jonathan,

Thank you for getting back. To provide additional information: "Binding IntelliSense Data (100%)" never finishes only way to unfreeze the program is to kill the unreal builder in the task manager. I have also attempted to use multi versions of the engine and get the same result. I am using the Launcher version of the editor. I have also uninstalled both VS 2013 Pro and Unreal (completely deleting the program files etc) and jthen reinstalled first VS 2013 then Unreal, same result.

Here are the results of the batch:

link text

info.txt (1.8 kB)
avatar image MoneyTime Nov 12 '14 at 12:52 PM

Hi Jonathan,

I wanted to provide you with an update. I was able to get the project to work by doing the following steps. The Batch file originally showed some errors which I fixed but this did not fully fix the problem.

Here are the steps:

Most of this rooted from 2 problems, A failed uninstall of express while a pro was installed, errors in the path env

To fix all the problems I

  1. Re installed express

  2. Removed express

  3. Removed vs pro

  4. Deleted the program folder

  5. Deleted registry items related to vs express and pro

  6. Deleted path references

  7. Re installed pro after a fresh restart

This cleaned up my VS problem

I then reviewed the path and noticed that 2 entries had quotes which is incorrect. The quotes were removed , Unreal reinstalled, and then restarted the computer. After that the launcher is able to generate c++ files

Thanks again for looking into this and providing some direction

avatar image Jonathan Dorman STAFF Nov 12 '14 at 02:38 PM

Glad to help. Thanks for letting me know that the problem was due to an incomplete uninstall of Express - that could help other users in the future.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question