x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Physics Asset: Change 'Floor Gap' (Greyed Out)

I need to reduce the floor gap. It's greyed out. It doesn't say how to activate the option other than that it 'requires restart of PHaT'. There's no option to restart PHaT that I can see so assume it would restart after changing, but there's no way to change it.

Documentation says nothing on this nor does google on either activating the setting or restarting PHaT. I restarted UE4, figured that'd do it if nothing else but no.

It's ludicrous and exasperating that I have to make a question to find how to change a setting and wait for a response before I can continue.

Product Version: Not Selected
Tags:
more ▼

asked Nov 11 '14 at 11:56 PM in Using UE4

avatar image

Vaei
596 28 24 52

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Vaei,

This is a value that is not currently exposed as editable in the editor, it's automatically calculated. Are you experiencing an issue where your asset is below the floor?

more ▼

answered Nov 20 '14 at 09:45 PM

avatar image

TJ V ♦♦ STAFF
41k 1009 183 494

avatar image Vaei Nov 20 '14 at 09:55 PM

No, I need it to be closer to the floor so I can preview it without the character falling as anytime I'd activate the ragdoll they'll be grounded.

avatar image TJ V ♦♦ STAFF Nov 21 '14 at 02:26 PM

So you want to keep the character from falling? As a workaround, you could set the upper-most bounds/head to Kinematic and it will lock in place or you could set the Gravity to 0.

avatar image Vaei Nov 21 '14 at 10:00 PM

I don't think that'll help. My game is on a flat plane, I want them to fall over when they die but since they're never in the air it's not a good representation of what it'll look like if they're grounded when it activates.

avatar image TJ V ♦♦ STAFF Nov 24 '14 at 05:02 PM

In that case, I would test the asset in the level by placing the Physics Asset where you need it, make changes in the PhAT editor, save, and then simulate play in the editor.

avatar image ShimShade Apr 16 '15 at 06:15 PM

FWIW I was having the opposite problem where my mesh was below the floor and a simple edit to "FloorGap" in BaseEditorUserSettings.ini did the trick. How is this value auto calculated exactly?

avatar image berhardjtdonny Jan 22 '17 at 06:06 PM

Thanks for that! My character kept spawning through the ground. Why is this setting greyed out ? The Ini ( BaseEditorPerProjectUserSettings.ini ) is in the Engine/Config directory of the editor. The line to change is FloorGap=

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I know this is old, but for people still looking for answers coming from google etc.: Add a new body (temporary collision box), and drag it to near the bottom of your mesh, a little higher than where you'd want the floor to be. Save your PhysAsset and restart the engine.

The floor changes depending on the lowest collision box in the PhysAsset. There will be a gap between that collision body and the floor, so just use trial and error to get it to the height you need.

This is a long winded work around because you have to restart the engine each time, but it works. Hope this helps somebody.

more ▼

answered Feb 01 '17 at 01:56 PM

avatar image

Nearan
11 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question