x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Closed] GenerateProjectFiles.sh fail on Debian

Hi, I'm trying to build the UE on Debian 7.7, but I have a little problem when I call GenerateProjectFiles :

root@PC-Tavon:/home/tavon/Project/UnrealEngine# ./GenerateProjectFiles.sh
Github build
Checking / downloading the latest archives
Started downloading Optional.zip
Traceback (most recent call last):
File "Build/BatchFiles/Linux/GetAssets.py", line 123, in
exit(download_assets(repo))
File "Build/BatchFiles/Linux/GetAssets.py", line 99, in download_assets)
with open(asset_path, "wb") as f:
IOError: [Errno 2] No such file or directory: u'/root/Downloads/4.5.0-release-Optional.zip'
Could not check/download binary dependencies !

All the dependencies are installed, the OAUTH_TOKEN is set and i'm in sudo. I'm a newbie to unix but I think I did it well :/

Thanks, Tavon.

Product Version: Not Selected
Tags:
more ▼

asked Nov 12 '14 at 09:01 AM in Linux

avatar image

Tavon
3 2 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Dec 12 '14 at 01:51 PM by amigo for the following reason:

The question is answered, right answer was accepted


2 answers: sort voted first

You should never run as a root user like this, especially if you are newbie to unix, and even if you aren't. :) UE4 Editor does not require elevated privileges, nor a root user account, to run.

Your error suggests that there's no folder /root/Downloads/ which is probably expected as root user is not meant to run in a desktop environment. It appears that you've su-ed to root user to run GenerateProjectFiles.sh.

Just run the script as yourself (tavon) and it should find the Downloads folder in your home folder and work as intended.

You can double-check if you have the Downloads/ folder by executing the command: ls ~tavon/ (you should see Downloads in the list among other files and folders in your home folder).

more ▼

answered Nov 12 '14 at 01:38 PM

avatar image

amigo
1.1k 52 32 90

avatar image Tavon Nov 12 '14 at 05:13 PM

Thanks for the quick answer ! However, I tried to clone and launch the sh with my account, but the error survived. I checked all the homes, there's no download folder..

avatar image amigo Nov 12 '14 at 05:40 PM

You are running some desktop environment, right? There should be a Downloads folder on all Debian based systems (I run Ubuntu). If there isn't one then create it... :)

avatar image Tavon Nov 12 '14 at 06:13 PM

Well thanks, I just had to mkdir a Downloads folder and it worked ! I just have one final problem, I dont find the makefile that is mentionned on the wiki, and i can't just make UE4Editor

avatar image amigo Nov 12 '14 at 06:22 PM

GenerateProjectFiles should create it in the main folder, so if it doesn't there must have been an error somewhere during its execution. Check for any errors in .log files in Engine/Build/BatchFiles/Linux/

avatar image Tavon Nov 12 '14 at 08:07 PM

My BuildThirdParty.log has some errors, I suppose I forget some apt get.. http://pastebin.com/dngNV3kY

avatar image amigo Nov 12 '14 at 11:11 PM

Looks like there's an issue with Qt4, so you have to make sure all necessary dependencies are satisfied for it.

avatar image Tavon Nov 15 '14 at 01:26 AM

I don't know, I downloaded every package that I could find with a link with Qt4, ans the error is still there, I don't really know what to do..

avatar image thecr3w Mar 14 '15 at 01:12 PM

I am having exactly the same problem after switching from fedora to debian (wheezy/sid). It seems QT4 is simply broken. QT5 is not better. Therefore, I can understand that UE developers do not want to search solutions for this bug called qt.... sadly, we are stuck with this problem...

avatar image amigo Mar 15 '15 at 03:11 PM

Hi thecr3w,

This is a really old AH post, surely you are not using UE4.5 anymore?

All of us in Linux who are using Qt4 and Qt5 have no problems with it, and alternatively you can try GTK 2 or 3 instead, but this seems to be something specific to your setup.

As mentioned above check the build log for clues, otherwise please try Ubuntu 14.04 LTS, since that is a base standard for UE4 and absolutely works.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

See this SO link http://stackoverflow.com/questions/8995399/error-qapplication-no-such-file-or-directory for some clues. Also, if that fails, you can remove Qt4 since you already have GTK2/3. You really need just one of those and not all of them.

more ▼

answered Nov 15 '14 at 01:36 AM

avatar image

amigo
1.1k 52 32 90

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question