x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

'Generate UV's failed' error

Hello. I am getting. Generate UVs failed. Couldn't convert to a D3DXMesh. HELP. The model has been made in sketchup and used in unity pro. And then i imported from unity to unreal engine 4 and when rebuilding lightning i got a error about UVs found internet that to fix it i need to generate UVs but i am getting error. If someone can please fix this model for me. Or tell me how to fix it. I am begginer in UNREAL ENGINE 4. Model link: CLICK ME MEDIAFIRE

Product Version: Not Selected
Tags:
more ▼

asked Nov 12 '14 at 11:18 AM in Rendering

avatar image

Herobrine112211
1 2 3

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

So I was able to reproduce what you are talking about, but it seems you have way too many individual components on your command center. You need to break things apart that are meant to be represented as their own mesh. For example your satelite, the computer screen, and the machine components inside of your house need to be on their own seperate 0 to 1 UV space.

Because everything is being pushed on one lightmap, it cannot effectively generate an effecient UV for your static mesh so it continues to default to 0. Try dividing your mesh up by type, like the house structure, the satelite, the computer monitor, and the internal parts to get the correct results.

Here is some helpful documentation on how to optimize your models so when importing them into the engine, they are clean.

Static Mesh Creation Pipeline: https://docs.unrealengine.com/latest/INT/Engine/Content/FBX/StaticMeshes/index.html

Lightmaps and Unwrapping: https://docs.unrealengine.com/latest/INT/Engine/Content/Types/StaticMeshes/LightmapUnwrapping/index.html

Thanks,

Andrew Hurley

more ▼

answered Nov 17 '14 at 09:32 PM

avatar image Herobrine112211 Nov 19 '14 at 12:04 PM

I have a car that i would like to import but it have the same problem and i cant cut the car in a half what would i do then?

avatar image AndrewHurley Nov 20 '14 at 02:25 PM

You need to split the car up into different categories when Unwrapping your model, but you can still import them by combining the mesh. For example your wheels should probably have their own UV's.

avatar image Herobrine112211 Nov 20 '14 at 04:14 PM

Could you find someone to unwrap uvs for the command center. I tried to fix it but i dont understand a crap and it has too much stuff.

(comments are locked)
10|2000 characters needed characters left

Hello Herobrine112211,

So the only files we are compatible with for static meshes are .FBX and .OBJ file types. If you are using SketchUp to export your mesh, there is an option to export it as a .FBX file. Keep in mind that if you are scaling in centimeter in SketchUp then it should work fine because it transfers over to the engine properly.

Here is some documentation on how to work with .FBX files once you have them exported:

https://docs.unrealengine.com/latest/INT/Engine/Content/FBX/ImportOptions/index.html

Hope this resolves your issue.

Thanks,

Andrew Hurley

more ▼

answered Nov 12 '14 at 07:49 PM

avatar image Herobrine112211 Nov 12 '14 at 08:00 PM

I did use .FBX file with texture files. Sketchup model was exported from tutorial video from youtube. It worked in unity without problem. Soo what should i do? i dont know how to resize objects in sketchup i only know how to make models there.

avatar image AndrewHurley Nov 12 '14 at 08:16 PM

The mesh itself, not the texture file, needs to be either a .OBJ or a .FBX file. For not do not worry about the scaling. Just see if the static mesh imports as intended.

avatar image Herobrine112211 Nov 13 '14 at 06:52 AM

Everything is ok. Tested by exporting using blender. I don't know. Could you please fix it? it have meshes. Please.

avatar image AndrewHurley Nov 13 '14 at 04:11 PM

What version of the engine are you working in? I tested this issue in 4.5.1, but this could be version specific.

One of my colleagues pointed out that two of your texture image file are not a power of two. i.e. 256x163

avatar image Herobrine112211 Nov 13 '14 at 04:26 PM

I use 4.4.0. I will upgrade to 4.5.1 if i need to.

avatar image AndrewHurley Nov 13 '14 at 06:06 PM

If you have an active account try updating your version to either 4.4.3 which was the last hotfix pushed for the 4.4 version of the engine, or you can go ahead and move to 4.5.1 and see if either of these solve your issue.

I was able to import your mesh and your textures with no trouble in my version of the engine, so this might be the cause.

avatar image Herobrine112211 Nov 14 '14 at 07:48 PM

Nope. I updated and still the same problem. I really need this model. Same problem with other people sketchup made models. And i noticed in 4.5.1 there is no generate uvs button in windows tab anymore where can i find it?.

avatar image AndrewHurley Nov 14 '14 at 10:19 PM

The location of the "Generate UV's" can be found here.

alt text

avatar image Herobrine112211 Nov 15 '14 at 07:49 PM

I posted a new comment. Check it.

avatar image Herobrine112211 Nov 15 '14 at 10:57 AM

Still getting the same problem: wrapping uvs. Here is the object in game:MODEL

And here is the object uvs: MODEL 2

untitled.jpg (628.5 kB)
untitled.jpg (468.0 kB)
avatar image AndrewHurley Nov 16 '14 at 01:37 AM

Yes, notice how your objects UV's are overlapping? You need to unwrap your model so none of those faces are overlapping one another.

Or you can "Generate UVs" and set the" Lightmap Coordinate Index" to 1.

avatar image Herobrine112211 Nov 16 '14 at 11:56 AM

How do i unwrap them in unreal engine 4 and it dosen't let me set lightmap coordinate index to 1.

avatar image AndrewHurley Nov 16 '14 at 09:56 PM

Refer to the image I posted to see exactly where in the details panel to set the "Coordinate Index" as well as "Generate UVs."

avatar image Herobrine112211 Nov 17 '14 at 08:14 PM

Yes. I set generate uvs. Then save. And then i want to set that coordinate index to 1. BUT IT DOSEN'T LET ME. It automaticly reset the number to 0 in coordinate index.

avatar image Herobrine112211 Nov 19 '14 at 10:02 AM

Please. I want to make a game and my project is sucesfull on kickstarter. I need to make this game next year. How do i fix it if it dosent let me to change from 0 to 1. or what to use to create models but NOT blender. I dont know how to use it. Please.What would you recommend me to use or how to fix it.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question