x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Stop navmesh from building automatically

Getting a little annoyed at the performance hit from a navigation rebuild every time I tweak my landscape. I can't seem to stop the navmesh from rebuilding constantly. How do I do this?

Product Version: Not Selected
Tags:
more ▼

asked Nov 13 '14 at 03:54 PM in Using UE4

avatar image

Skuvnar
221 24 21 36

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Skuvnar,

To do this, go to Edit > Editor Preferences > Miscellaneous and disable 'Update Navigation Automatically'.

Cheers,

TJ

more ▼

answered Nov 13 '14 at 04:56 PM

avatar image

TJ V ♦♦ STAFF
41.1k 1009 183 493

avatar image Skuvnar Nov 13 '14 at 05:48 PM

Perfect, cheers mate.

avatar image Almo2001 Aug 25 '15 at 07:25 PM

There are two "miscellaneous" sections. You want the one under Level Editor.

avatar image endbored Dec 25 '16 at 05:53 PM

Could this be a bug in latest version?

when i launch my project, i have the option already unchecked, but it keeps on building navigation automatically. when i then go to settings and check and uncheck the box once, it stops building automatically, but only for this editor session.

next time i open project it does this again and so on.

avatar image TJ V ♦♦ STAFF Dec 27 '16 at 08:11 PM

Hi endbored,

I just tested this in 4.14.1 but I couldn't reproduce the issue you described. When I reopen the project the navmesh is still unbuilt unless I build it manually.

Are you also seeing this in a new project or is it only confined to your project?

avatar image Quackenbush Jan 30 '17 at 09:05 PM

I also want to add to this, our Nav Meshes, as of 4.14.1 are automatically rebuilding even if we set them to not rebuild automatically.

If we create a new map and apply a large nav mesh with some static meshes breaking it up, it will STILL rebuild the nav mesh when you load the level.

This causes our developers to have to click cancel on saving many levels because it thinks they were modified because the nav mesh is rebuilding without our input across the levels. The aggregate amount of time lost to having all our devs clicking cancel on many levels multiple times per day is substantial.

avatar image TJ V ♦♦ STAFF Feb 02 '17 at 06:46 PM

Hey Quackenbush,

This seems to be contained to ongoing projects, that's whey we haven't been able to get a repro. However; I think this was found internally and was very recently fixed. Could you try the 4.15 Preview 3 and see if the issue is fixed for you there?

I see you also have a UDN account. The CL for that fix is 3250282.

Let me know if that fixes the issue for you.

avatar image Quackenbush Feb 15 '17 at 11:31 PM

Hey TJ,

Thanks for the response and it is good to hear that a resolution may have been found.

We will test as soon as possible.

-Nick Quackenbush

avatar image Markus Maximus Sep 06 '17 at 01:45 PM

I just encountered this in 4.17.1. Should I create another bug report?

avatar image TJ V ♦♦ STAFF Sep 06 '17 at 04:02 PM

Hi Markus,

Yes please. Even though the bug maybe similar, the cause could be different since this exact issue was fixed back in 4.15. Just create a new report in the Bug section and reference this post. Also include repro steps and a test project if it's required to reproduce the bug.

Thanks, TJ

avatar image Markus Maximus Sep 16 '17 at 10:28 AM

I tried this in an empty project, 4.17, and sure enough the toggle works as intended.

Perhaps it is a per project thing. Since our project has been migrated from 4.6 onward to 4.17, it is possible that some things may have failed to update properly, which may include the Navmesh bounds and modifier volumes playing nice with Landscape editing.

We had to delete the Navmesh bounds volume in our original level as the shortest solution. Apart from that, the painting and sculpting works fine now, albeit with a much reduced delay when you release the mouse instead of the 2 second one. I tend to blame the AMD RX 480 for this issue, but I am not quite sure.

I will continue testing further and create a new issue when I can reproduce it more than two times.

UPDATE: I replaced the deleted Navmesh bounds volume with a new one, let the navigation build normally and now I can sculpt on the landscape without having it rebuild continuously. I think this problem has been solved for us.

You can suggest this as a solution to the people migrating their levels between versions. I think it will save them a lot of time with this simple trick. Of course, if they have loads of carefully placed Navmesh volumes, it will take some time, but this is much better than waiting a few seconds (or minutes) every time you paint or sculpt.

avatar image Frozenfire Jan 22 '17 at 09:35 AM

it's happening on my side as well. It's rebuilding everything it restarts. I believe it's confined only in our project in my case

avatar image Wallenstein Mar 03 '17 at 07:56 PM

Yes it happens to me too, I use 4.14 still and can't comment on 4.15 but I can confirm that this annoying bug exists. I reported that some months ago but was told that "we can not reproduce it"

avatar image liXiang Oct 30 '17 at 02:37 AM

It do not work! when i open the map ,it still rebuild nav every every time. the version 4.17

avatar image Frozenfire Dec 11 '17 at 08:27 AM

This bug seems to be fixed in 4.15 but is now back in 4.17

Any new bug tracker on this or workaround?

avatar image jackey7 Mar 15 '18 at 01:10 PM

Problem still existed, 4.18.2

avatar image JRV1 Mar 11 '19 at 04:43 PM

I get this from time to time as well on 4.20.3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question