x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Windows Kits errors preventing build

Just a couple of days ago I was able to build for 4.4 and 4.5 successfully, but now I get over 100 errors regarding Windows Kits which prevents me from building. I haven't changed anything, so I don't know why it suddenly has stopped working. I think it's more likely it has to do with VS or the environment somehow, rather than UE4 itself, as it started to happen with both 4.4 and 4.5 at the same time, but I don't know what could possibly be wrong, so I'm hoping someone with more experience in VS here has a potential solution. Until then, I'm locked out of my project.

I have tried both versions 4.4.3 and 4.5.1, with configurations for development_editor (x64), development (x64) and shipping (win32), and I get the same thing for them all. Double clicking an .uproject and letting it rebuild from there gives the same error.

my C:\Program Files (x86)\Windows Kits\8.1 is 555mb and has plenty of files in it.

Using the pre-compiled engine versions and Visual Studio Ultimate 2013.

Here's the full error from VS:

https://gist.github.com/kimsch/65db27f43c5ff2d1e84b

Product Version: Not Selected
Tags:
more ▼

asked Nov 15 '14 at 12:40 PM in Everything Else

avatar image

Acriax
166 13 16 28

avatar image Acriax Nov 15 '14 at 02:59 PM

Tried installing version 4.6.0 preview and creating a new project. Still the same thing.

avatar image Acriax Nov 16 '14 at 04:23 PM

Also tried downloading windows kits 8.1 anew and performing a repair of visual studio, but to no success.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Alright! After trying just about everything, I finally found the solution. If anyone else encounters this problem, this is what I did:

I simply had to copy the files in Windows Kits/8.0/Include into Windows Kits/8.1/Include, replacing all the conflicting files. I'm sure this is very not-recommended, but atleast now it works, and I can tell no difference otherwise, so I'm happy.

more ▼

answered Nov 21 '14 at 04:41 PM

avatar image

Acriax
166 13 16 28

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The Unreal Engine does not support windows types somehow. You can wrapp your #include windows.h, or something similar you may have, with

  #include "AllowWindowsPlatformTypes.h"
   #include "yourwindowstypes.h"
   #include "HideWindowsPlatformTypes.h"

Please try this and reply if I am wrong.

more ▼

answered Nov 16 '14 at 12:37 PM

avatar image

Maxxomatik
73 7 8 11

avatar image Acriax Nov 16 '14 at 04:22 PM

Thanks, but I'm not aware that I'm including windows.h anywhere. This issue happens with a completely blank project.

avatar image Maxxomatik Nov 16 '14 at 05:29 PM

My WindowsKits/8.1 folder has 444MB, I renamed the WindowsKits folder and tried to build the first person template C++ Verion with visual studio. Plenty of errors poped. So it is needed by the engine. My best guess is: Your WindowsKits version8.1 (which was missing in my try) is corrupted in any way. I would rename the WindowsKits folder and run the visual studio repair again and look if the folder is restored. reinstall all dependencies.

avatar image Acriax Nov 16 '14 at 08:02 PM

I renamed the 8.1 folder and ran the VS repair as you said. The new 8.1 folder was only 80mb in size, and when I tried to compile, it said it was missing windows.h, which it was trying to include in the engine code in a file called MinWindows.h.

So I merged the 80mb large 8.1 folder into the 555mb large one, and put that back, but now I'm back at square one with the old error.

Would you mind posting your user and system PATH variable? The only thing I can think of is that some program has changed it, and now it can't find windows kits correctly because of that.

avatar image Maxxomatik Nov 16 '14 at 09:49 PM

Paths work fine for me when i let the editor refresh the sln file. To do so open the uproject file with your editor. Click File -> Refresh Visual Studio Project. I do this always when I pull the latest version of the project from the Repository. That makes sure that your paths are correct.

What variables do you mean? user and system path? where to find?

avatar image Acriax Nov 17 '14 at 01:50 PM

I deleted the .sln, .sdf and .suo files, and rightclicked the .uproject and chose Generate Visual Studio project files (can't access the editor as it tells me it's out of date and wants to recompile (which doesn't work)), however, it didn't help.

Nevermind about the path, I realized it's probably not a problem with the paths. If I move the 8.1 folder I get a different error saying that it cannot find the include windows.h, so it would seem that it does find the windows kits files for me, but... well, I don't know. I don't understand how it could read the files wrong and come up with all those syntax errors. It's almost like if one is x64 and the other is x86. But both VS and windows kits are under Program Files (x86), and it has worked before so I don't know why it would change.

avatar image Diozne May 19 '19 at 10:28 PM

these includes works to me :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question