x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

It's possible to exclude an object from Distance Field AO ?

I have an object that is moving too fast on the scene and is causing artifacts because of distance field ambient occlusion slow updates

Is there a way to exclude it from DFAO?

Product Version: Not Selected
Tags:
more ▼

asked Nov 15 '14 at 03:17 PM in Rendering

avatar image

gustavorios2
218 18 26 36

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

There is no checkbox to remove an object from using DFAO unless it's just not supported.

However, there may be a slight workaround that could help if you want to give it a try.

You can open the mesh in question up in the Mesh editor. In the Details panel to the right locate the setting for Distance Field Resolution Scale and set it to 0 and hit apply. There may be a slight amount of AO generated (At least from my tests) but this could help.

You can visualize the difference and how much affect it has on the Distance Fields by going to the viewport and selecting Show > Visualize > Mesh Distance Fields. This will show you the resolution of the meshes in the scene that are using DFAO. You should not really see your mesh isn't really generating any Distance Fields.

Give this a shot and let me know how it goes.

Thank you!

Tim

more ▼

answered Nov 21 '14 at 10:51 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 103 879

avatar image gustavorios2 Nov 21 '14 at 11:05 PM

that worked for me! thanks

avatar image WixZ Apr 24 '17 at 02:50 PM

You can now also go into the mesh properties and under lighting you can uncheck "effect distance field lighting" which will also block the mesh from affecting distance fields.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question