x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Is there a config option to enable higher resolution for retina displays?

I just downloaded the latest Unreal engine and launched it up on my Macbook Pro 15" retina.

The launcher and the editor aren't retina ready. And this is a huge bummer. It looks terribly pixelated and I am constantly distracted by it.

Is there a config option to enable higher resolution. Do I need to build it with some specific flags?

Product Version: Not Selected
Tags:
more ▼

asked Mar 20 '14 at 05:13 PM in Using UE4

avatar image

va
121 2 2 4

avatar image devel.bmad May 16 '14 at 04:36 PM

Same HW configuration, same issue. In any case, it would probably help being able to scale down the fonts and UI in general once HDPI is supported, on default setting e.g. the material editor is barely usable even when maximized, since most of the labels are cropped (see screenshot) and everything looks bulky and blocky. 15 inches are not much for this kind of application, but other similar editors (e.g. blender) fit this display size better.

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Va,

Not yet - high DPI support is something we want to add to Slate (the UI framework) and it is fairly high on the list but we haven't had a chance to implement yet.

UPDATE - 10/12/2016

As of 4.14, we've add a commandline parameter to enable a High DPI / DPI Aware mode, you'll need to pass

 -enablehighdpi

to the editor when you start it. There are some known issues that still need to be resolved with some UI. If you want to try it out in 4.14, give it a go and as always report any problems you encounter with any of the editor UIs when in this mode.

more ▼

answered Mar 20 '14 at 05:19 PM

avatar image

Nick Darnell ♦♦ STAFF
6k 77 37 151

avatar image ASPCartman Sep 25 '14 at 09:30 AM

Any updates?

avatar image IsaiahJTurner Oct 07 '14 at 09:16 PM

This is really needed.

avatar image devel.bmad Oct 07 '14 at 10:28 PM

Yes, at least for the UI if not for the game itself (which would probably struggle performance wise on almost any mac)

avatar image AVATSAEV Mar 03 '15 at 07:23 AM

I'm sorry, but could you please implement it already, this is really important.

avatar image slawo Apr 17 '15 at 09:50 AM

It's been a year since this message was posted. Any news?

avatar image Stephen Ellis ♦♦ STAFF May 27 '15 at 06:18 PM

Hi everyone,

We haven't been able to tackle this yet, but it is still something we are committed to. It will require a concentrated effort of engineers across different teams, and we probably won't be able to get to it until after the 4.9 release. We're tracking this as UEPLAT-352.

Cheers

avatar image sinay Jun 24 '15 at 10:29 PM

Wow still no HDPI UI in 2015...

avatar image badrat Sep 16 '15 at 10:21 PM

haha what a joke! the editor looks like it's running in DOSBox on any mac since 2012.

avatar image slawo Oct 03 '15 at 08:11 AM

@StephenEllis This is unfortunately the kind of issue which gets harder to solve with time as more and more features are implemented with the assumption of a fixed pixel ratio. I think Epic (just like Unity) will not be able to solve this now.

avatar image SevenDays Oct 24 '15 at 06:29 PM

Any updates? 4.9.2 has been already released

avatar image Ben Halliday STAFF Oct 27 '15 at 04:27 PM

No update at this time. We will post here if we see any changes to the ticket.

avatar image mlostekk Mar 17 '16 at 07:01 PM

any updates?

avatar image Matt.Williams Mar 24 '16 at 08:06 PM

Hi mlostekk,

There hasn't been a lot of movement on UEPLAT-352 as it's a large undertaking. Our engineers will need to block out a large chunk of time to do this and it hasn't become a high enough priority to dedicate that time yet.

-Matt W.

avatar image mlostekk May 27 '16 at 12:48 PM

what a pitty :(

avatar image Friesendeich Aug 08 '16 at 01:40 PM
  1. Years later ... still no retina support?

It is easy for me: No Retina UI support for Mac user = no Unreal support from me!

I was on the way today to switch from Unity to Unreal, but with this eye cancer causing pixel-UI - NOPE NOPE NOPE NOPE.

Sorry no sorry and bye. :/

avatar image sinay Aug 08 '16 at 02:18 PM

With UE5 soon around the corner I guess there's no point in updating it now. I hope the next UIX is being reworked for the ground-up and as modulable as possible. Well it's obligatory for VR/AR and mobile/devices anyway so...

avatar image Matt.Williams Aug 09 '16 at 09:57 PM

Figured I would chime in since we've had some activity. The status on UEPLAT-352 has moved to "In Progress" and has received a higher priority (Pri-1, which is the highest "Non-Blocker" priority). This is not expected to make it into 4.13, but will show up in a future release.

Unfortunately UEPLAT Jira entries are not eligible for the public jira. If you're curious about any progress, feel free to ask here.

-Matt W.

avatar image mylogon Oct 09 '16 at 05:53 PM

Hey. Would be cool to get an update on this. I'm glad to see that it's a Pri-1 item as this is something that has actually put me off using Unreal recently as prolonged use actually causes me discomfort. Hopefully you're making good progress! 'God speed'.

avatar image Matt.Williams Oct 12 '16 at 02:08 PM

This has been marked as fixed for 4.14.

avatar image Nick Darnell ♦♦ STAFF Oct 12 '16 at 02:11 PM

It has been experimentally fixed for 4.14. It is not enabled by default, users must opt into it by passing -enablehighdpi, there still remains issues that need to be resolved.

avatar image Evgeny39 Oct 12 '16 at 06:07 PM

How to use this command line parameter on mac?

avatar image Matt.Williams Oct 14 '16 at 02:53 PM

You need to run the editor with Terminal on a Mac. There are quite a few guides online for how to use Terminal.

avatar image Hamitho Nov 10 '16 at 09:41 AM

Will you implement a proper UI option to enable / disable this in the editor for the release version of 4.14 or will we need to stick to the command line parameters? On Mac it's not a very comfortable way to run an app over the terminal since there are no shortcuts.

avatar image Matt.Williams Nov 10 '16 at 10:27 PM

Hi Hamitho,

Since it is still experimental, we are leaving it as a terminal argument for the time being.

You may be able to create something similar to a windows shortcut with an argument though. See these two links:

http://blog.alizweb.com/post/44716451471/windows-like-app-shortcut-w-command-line http://www.jesseweb.com/coding/automator/create-windows-like-shortcuts-with-parameters/

-Matt W.

avatar image Hamitho Nov 11 '16 at 11:17 AM

Thanks for the link. However I can't get this to work. Typing /Users/Shared/UnrealEngine/4.14/Engine/Binaries/Mac/UE4Editor.app/Contents/MacOS/UE4Editor -enablehighdpi either in Automator or Terminal just opens the Unreal Editor as usual, I don't see any difference. Is there something else that needs to be set?

avatar image Matt.Williams Nov 11 '16 at 03:38 PM

In Automator, you need to save it...like it says in both of those tutorials. It creates an "application" with all the arguments that you want. You can even add a project to the launch sequence.

This eliminates the need to run terminal.

avatar image Hamitho Nov 16 '16 at 02:53 PM

Got this. Still doesn't change the fact, that I do not see any difference in the editor. No retina support noticeable on my end.

avatar image RRe36 Nov 16 '16 at 05:56 PM

Well, it works perfectly on Windows

avatar image rranon Nov 17 '16 at 10:57 AM

I confirm this, on Mac it opened the project chooser / creator and I saw no difference at all with regular UE 4.14.

avatar image Matt.Williams Nov 17 '16 at 04:11 PM

Can you try launching a project directly? See the guide here: https://docs.unrealengine.com/latest/INT/GettingStarted/RunningUnrealEngine/

You'll need to click on MacOS at the top and then go to "Launch Editor from Command Line"

avatar image Matt.Williams Nov 17 '16 at 08:42 PM

Hi Everybody,

Talked with one of our engineers who indicated that the argument doesn't work on Mac, but instead you'll need to modify the Info.plist file inside of the UE4Editor app package contents.

For some reason, this won't work unless you rename the UE4Editor app and then name it back.

  1. Locate the UE4Editor app found in \Users\Shared\UnrealEngine\4.14\Engine\Binaries\Mac

  2. Right/Two Finger Click on the app and select "Show Package Contents

  3. Click on Contents and then open Info.plist

  4. Depending on whether it opens in Xcode or not, you'll need to set "High Resolution Capable" to YES/True.

  5. Go back to the UE4Editor app and rename it

  6. Launch it, then close it

  7. Rename it back to UE4Editor

For some reason the Info.plist changes won't take affect without renaming the app.

-Matt W.

PS - I'd like to say again that this is EXPERIMENTAL and is not guaranteed to run correctly.

avatar image Hamitho Nov 20 '16 at 03:18 PM

Thanks to your guide I got it working on Mac, thanks a lot! Quite a difference, makes working a lot easier, even if it needs more fine tuning in the future (icons, line positions when connecting nodes etc.). However, I like it, thumbs up!

avatar image AJ_Graphix Nov 22 '16 at 10:46 PM

Hey, Matt, I'm wondering if there's a way to make the Epic Games Launcher point to the modified UE4Editor.exe? Or is that not possible? Thanks!

~Adam

avatar image Matt.Williams Nov 23 '16 at 08:42 PM

Hey AJ,

You rename it something different and then rename it back to UE4Editor.exe. The launcher should still point to the same place.

I assume you're referring to my most recent comment.

-Matt W.

avatar image AJ_Graphix Nov 24 '16 at 02:56 PM

Thanks so much, Matt, for your reply! I'd love to be able to do this, but I'm on Windows, not Mac. Currently I've only added the -enablehighdpi argument to a shortcut that points to the UE4Editor.exe, however, to truly modify the exe so the Launcher will point to it, I'd have to open it in Visual Studio 2015? Is there a simple way to do that, as I'm not a programmer and I don't want to accidentally mess things up in the file. Thanks!

avatar image zeehlxdv1 May 09 '17 at 12:21 AM

Wow - this is a god-send on macbook... Now to figure out how to make this the default in the source.

avatar image AJ_Graphix Nov 17 '16 at 04:55 PM

For anyone on Windows wondering how to enable High DPI:

You need to find the UE4Editor.exe file, make a shortcut to it, and add the -enablehighdpi argument after the quotes, like so: "C:\Unreal Engine\Epic Games\4.14\Engine\Binaries\Win64\UE4Editor.exe" -enablehighdpi

EDIT: Then launch the Editor by clicking directly on the shortcut you created.

(Your installation might be in C:\Program Files\Epic Games)

My first observations: I am very impressed! Beautiful sharpness and clarity with proper viewable size of text. Additionally, text in the menu drop-downs are not cut off as with the former widget reflector hack. So this is great!

There are a few quirks to be worked out still, as the wires in Blueprint nodes do not respect your mouse's position when dragging. Also, you still cannot launch your mobile preview in portrait mode. That currently only works at native resolution with NO dpi scaling in Windows, unfortunately. However, I am super excited to see this new feature being implemented! Great work, Epic!

~Adam

avatar image slaj Nov 30 '16 at 06:32 PM

Wow, finally this looks acceptable!

Frankly I do not understand how this option (enablehighdpi) does not have the HIGHEST priority on the Epic's features list and roadmap?! Could anyone explain or give me me a hint of other feature that is more important than "Totally broken and not-readable UI due to low DPI"?

Thanks :)

avatar image Matt.Williams Dec 01 '16 at 04:07 PM

Hi slaj,

When evaluating the priority and time-table of a certain bug or feature request, there are a lot of factors that go into it. Some of them are:

  1. What percentage of users is this likely to affect?

  2. How many man-hours will it take to make this a usable feature/fix?

  3. How many other systems could this break?

With this feature, the answers are:

  1. Very low percentage (users with 4k or retina displays only...which is not a lot)

  2. A lot, see next answer for why

  3. Every other tool in the editor. Must be tested and debugged across the entire engine.

Some of our other considerations can be found here: https://headcrash.industries/stories/why-your-idea-might-not-make-it-into-ue4/

-Matt W.

avatar image AJ_Graphix Dec 01 '16 at 08:43 PM

Good points, Matt; and is perfectly understandable. Needless to say, I am glad that HighDPI support is now being worked on, as it's made my life so much easier. Epic has also been very gracious to implement other bug fixes for mobile developers that would have been deemed "low priority", and yet they still did it... and for that I am very grateful. :-)

BTW, would you be able to direct me to make the Launcher point to a HighDPI enabled Editor on Windows? Currently I'm just using a modified shortcut to the UE4Editor.exe, which works, but I miss seeing the launcher updates, etc. :-)

Thanks! ~Adam

avatar image Matt.Williams Dec 02 '16 at 03:07 PM

Hey Adam,

There is a feature request in for this(UE-28185), but for the time being...shortcuts are the way to go.

-Matt W.

avatar image AJ_Graphix Dec 02 '16 at 06:52 PM

Ah, okay... thanks so much for letting me know!

Have a great day, Matt.

-Adam

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Today "-enablehighdpi" stopped working. I restarted an editor and everything all of a sudden became very small. I rebooted my PC - no changes, everything is too small. Interesting thing is that project selection window when you start the engine is correct (high dpi), but inside editor - all small. Rebooted few times - no changes. Windows scaling settings for UE4Editor.exe are disabled.

more ▼

answered Jul 03 '17 at 07:49 PM

avatar image

Flash7
844 9 17 30

avatar image AJ_Graphix Jul 03 '17 at 08:45 PM

I'm not sure why that would be, but you should make sure inside the shortcut to UE4Editor.exe the flag is still set: "C:\Program Files\Epic Games\UE_4.16\Engine\Binaries\Win64\UE4Editor.exe" -enablehighdpi

And also make sure in the compatibility tab that "Disable display scaling on high DPI settings" is NOT selected.

You will likely need to reset the flag for each new engine update you do (ie. 4.15 to 4.16), but not for hotfixes (ie. 4.16.0 to 4.16.1). I hope that helps!

-Adam

avatar image Flash7 Jul 03 '17 at 09:13 PM

shortcut

shortcut_compat

avatar image AJ_Graphix Jul 03 '17 at 11:38 PM

Thanks for posting that. Everything's working fine for me in 4.16.1 with the following settings. Are you using a Engine version other than 4.16.1?

alt text

avatar image Flash7 Jul 04 '17 at 12:14 AM

Actually, it is funny. I opened another project and it is fine. But scaling has issues only on my main project. Engine 4.16.2

avatar image ivanrosadev Jul 23 '17 at 10:42 AM

More than 3 years later and same problem. I guess I forget that Epic Games is not as big as other companies like Autodesk or Adobe which already have great high dpi support.

What a disappointment.

avatar image Flash7 Jul 23 '17 at 02:46 PM

I guess programmers in Epic are still using low res monitors...

avatar image Matt.Williams Jul 24 '17 at 05:48 PM

Hey Flash7,

Can you make a new thread about the small icons? It'd be good to report that as a unique bug as it only appears to be happening in the one project.

-Matt W.

avatar image Flash7 Jul 24 '17 at 05:57 PM

Actually, I fixed it by deleting all cached and intermediate files. After that editor started working fine again.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question