x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is Visual Studio using so much memory?

Probably not directly related to UE4 - but I find I have to keep killing "Package Server" processes and / or restarting visual studio because it's eating up all my RAM and eventually causing system instability.

Anyone know how to solve this? It's Visual Studio 2013 Ultimate, I have 16GB of RAM and usually UE4 editor and VS open. I've tried with and without Visual Assist plugin enabled.

alt text

Product Version: Not Selected
Tags:
captureok.jpg (146.4 kB)
more ▼

asked Nov 17 '14 at 06:23 PM in C++ Programming

avatar image

cgrebeld
497 25 16 33

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

https://forums.unrealengine.com/showthread.php?55056-Visual-Studio-2013-Express-vcpkgsrv-exe-going-crazy

To quote:

"This is actually a problem with your intellisense settings. If you close those processes they just reopen.

Go to "Tools->Options->Text Editor->C/C++->Auto Tune Max Cached Translation Units" Set it to false

Now under the same place set "Max Cached Translation Units" to 2 since that's the lowest possible value.

That will limit VS to only launching 2 of those processes at a time instead of like 7 of them or something. Your horrible performance issues should now go away since all your RAM will stop being eaten up by intellisense. "

more ▼

answered May 23 '15 at 02:33 PM

avatar image

theonecalledtom
1.3k 60 66 270

avatar image theonecalledtom May 23 '15 at 05:06 PM

Also - if you are finding that your devenv.exe memory use balloons during symbol load (mine just hit nearly 4GB, typical is around 1GB while debugging), try deleting your breakpoints. Sometimes they seem to get corrupt. This has probably happened twice to me in the last five years but each time I wasted a load of time figuring out the problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

A few things: Make sure you have the latest update, should be CTP 4 if I remember right, there's lots of performance improvements especially with large code bases like UE4. In my experience the high memory usage is due to Intellisense parsing the code. I've somewhat mitigated it by disabling Intellisense and installing Visual Assist, which I've found to be more robust and responsive anyway. I note you mention you've tested with and without VAX but are you disabling Intellisense when you turn VAX on?

more ▼

answered Nov 17 '14 at 06:38 PM

avatar image

twiddle
1.5k 55 36 73

avatar image cgrebeld Nov 18 '14 at 06:43 PM

Thanks that was the problem exactly! I didn't realize you had to disable Intellisense when VAX was installed.

VAX is really worth every penny, from my experience Intellisense is all but unusable with UE4.

avatar image twiddle Nov 18 '14 at 06:46 PM

Well, you don't have to disable it, VAX can use information from it and extend it if you leave it on.

The intention behind Update 4 for VS was performance improvements with large code bases like UE4 - you can look at a post in the C++ section on the forums for more information. It definitely helps if you're on a machine that can't install VAX, or for people unable to justify the expense of it.

avatar image kamrann Apr 05 '15 at 06:37 PM

I have the same issue with multiple instances of the Visual C++ Package Server, each taking up around half a gig of memory. The number of instances starts out at one and just grows with the length of my programming session. I haven't had this issue with other projects done in Visual Studio (I'm using the latest community edition, I don't have Visual Assist and Intellisense is enabled) so my suspicion is it may be a problem with the unreal build system.

Can anyone confirm if they also have this issue? Is it a bug, or expected?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question