x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Landscape material not height blended correctly

I've read a massive amount of conversations regarding the landscape material blending, but I still can't figure out what is the cause of blackness. I have tried it by making zero layer grass texture AlphaBlended (example screenshot) and as HeightBlended. Both are displayed wrong, but HeightBlend had less artifacting as it rendered the zero layer at least but had black splots where layers connected (very popular error on other people's issues)

From some of the comments I've heard that it's because there's a ZERO blend value on the terrain but for me painting everything over with zero layer material didn't solve it at all.

I have noticed that if I delete my second layer (the rocky road part) it will render and blend zero (grass) and first (dirt) layers correctly. I also read that UE 4.5 didn't support very many textures, so I had heightmap put in to normal map A channel to remove some textures, but that had no effect. I updated to 4.6 preview to see if it fixes it, but that also didn't affect it in anyway (though I believe 4.6 was updated with bigger texture support)

I'm not sure where the issue is and it could very well be extremely tiny...

Screenshot of how it looks in editor: alt text

Screenshot of the simple material tree: alt text

Product Version: Not Selected
Tags:
more ▼

asked Nov 18 '14 at 08:18 AM in Using UE4

avatar image

Detocroix
12 4 6 8

avatar image Adam Davis STAFF Nov 18 '14 at 06:36 PM

Hi Detocroix,

Try covering the entire landscape section with one of your layers until all black is gone, then begin adding layers. Please let me know if this works for you.

avatar image Detocroix Nov 18 '14 at 07:08 PM

Hello Adam,

Here is a gif showing what is happening when I cover the terrain with layer 0, then paint in layer 1 (still working) and then paint in layer 2 (and layer 0 disappears). Then paint away layer 2 and it fixes itself.

The gif is fairly big and bad quality, but shows pretty well what I did. I'm using 4.6 preview on the gif, but same happened on 4.5 version.

http://i.imgur.com/lvN8bCn.gifv (.gifv wasn't supported as image link, so it's just link now)

avatar image Adam Davis STAFF Nov 18 '14 at 09:27 PM

Hi Detocroix,

Ok so as soon as you started adding a second layer is when the landscape blackened. What happens if you use vectors instead of textures. For instance, instead of your textures, apply a const 3 vector for each of your layers and see if you get the same thing.

avatar image Detocroix Nov 19 '14 at 07:30 AM

Hello Adam,

Yes, the same thing happens. Of course the layer blend is still the same (with values as seen in the second screenshot of the question)

alt text

avatar image Adam Davis STAFF Nov 19 '14 at 03:36 PM

Have you been able to see this in a clean project with no additional content? I attempted to reproduce this but thus far have been unsuccessful.

avatar image Detocroix Nov 19 '14 at 04:13 PM

I just made a new and empty project, but I still get the same issue.

Here is a screenshot of a fresh project with same setup and problem, dxdiag.txt if needed, and zipped project folder:

link text

link text

alt text

avatar image Adam Davis STAFF Nov 19 '14 at 04:54 PM

The black square in this image, was it black initially? If so then this is expected behavior as the material has no data to start with (your setup does not have an initial material value to be initialized when the material first appears, only materials to be painted on in layers). Does this black paint appear before you get started or is it only appearing after you have already been painting?

avatar image Detocroix Nov 19 '14 at 05:05 PM

Everything was blue initially (first layer). Then I painted everything again with blue (just in case, was suggested earlier), then I painted pink stripe through both top squares. It still worked at this point (top right corner), then I drew green stripe through left squares. The bottom left still works (only has blue at bottom, green over it), BUT the square which contains blue base, green and pink over it, loses the blue base.

If I now went back and painted away either pink or green from the square, it would work again.

edit: By initially I mean first time after the new material has finished rendering shaders.

avatar image Adam Davis STAFF Nov 19 '14 at 05:29 PM

Ok I have good news. This is a known issue that does occur at times. Having said that, there is a workaround. Take one of your other layers and crank the tool strength up to maximum. Paint over your entire landscape with it. Then try painting on that. The black squares will continue to appear but paint over them until the whole landscape is one solid color. Then try painting on top of that. Please let me know if after following these steps the black splotches still appear.

avatar image Detocroix Nov 19 '14 at 06:13 PM

I don't quite understand what you are suggesting. I tried painting whole terrain with different layer (than layer 0) and then painting over it but layer 0 broke whenever I drew more than one height layer over it.

IF however I followed your suggestion (as I understood it) I was able to fix the terrain issue when I went against the Landscape material guide. The Landscape guide ( link text ) suggests setup is to use LB_AlphaBlend, but infact if you use LB_HeightBlend (const height 1.0) the layers draw (mostly) correctly. If you use LB_HeightBlend with const height 0.0 you will get black splots. If you use LB_AlphaBlend like the tutorial tells you to, the lowest layer will stop rendering completely when drawing multiple layers.

This is the final setup that worked: alt text

avatar image Adam Davis STAFF Nov 20 '14 at 03:23 PM

I want to try one more thing. Try the second setup in the middle of that material guide (under the lable "Using Landscape Layer Weight Nodes"), using the landscape weight blended layers instead of the single layer blend node. Do you get the same error when using this other style?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Detocroix,

We have not heard from you in quite some time. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

more ▼

answered Dec 01 '14 at 09:13 PM

avatar image jrapczak Feb 20 '15 at 04:09 AM

I am having this same problem. Is there a fix for this issue yet? Very annoying...

avatar image Adam Davis STAFF Feb 20 '15 at 03:05 PM

Hi jrapczak,

Can you show me your material setup? Additionally what specifically is occurring when you paint? Additionally, what version of the editor are you using?

avatar image Reactant Jul 06 '15 at 01:46 PM

Does anyone have a solid fix for this yet? I've tried everything I've read online and its still got holes

avatar image Adam Davis STAFF Jul 06 '15 at 08:34 PM

Hi Reactant,

What steps are you taking to reproduce this on your end? Any information that would allow me to recreate this effect could go a long way towards getting a bug report in and a fix implemented.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question