x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Problem on Embedding Video Media Texture when publishing project

Hi all, I created a media texture from a .wmv file located on the Content/Movies directory. My video/animated texture is applied to a material in the diffuse/emissive channel and everything works fine. But when I publish the project and move the published directory to another computer the video disappears.

I saw that the problem is that the animated texture always point to the working project directory (project/content/movies/), it has been embedded inside the published assets ( gamename/content/movies/ ) but the media texture is still pointing to the project file.

Is it a bug or is there a way to make my .wmv file to be embedded in the project? Thank you

alt text

alt text

Product Version: Not Selected
Tags:
more ▼

asked Nov 18 '14 at 04:28 PM in Packaging & Deployment

avatar image

antoniobosi
6 2 3 4

avatar image bzundel Dec 09 '14 at 04:30 PM

We are having the same problem with movie textures. When playing from the editor in any format, the texture works fine. It also works fine when playing a game build on the same machine. However, when you give that EXE to another developer, the textures no longer work. Hopefully Epic fixes this soon. This feature is a big part of what we are currently doing for a client.

avatar image wontonanimalchin Aug 28 '16 at 06:44 PM

hi there, its now 2016, UE 4.12,... so a long time after the first problems occured! Is there allready a solution to it? I tried about anything but, besides the editor, it doesnt work!

hope there is light at the end of the tunnel :)

best regards robert

avatar image quality Dec 09 '14 at 05:45 PM

I'm having this issue as well. It seems like the build process is not replacing the paths of media player actors so that they actually point to the build directory contents folder. Like has already been said the movies get packaged in the build but the path doesn't get correctly changed. This is extremely annoying. I'm looking for a solution right now and will update if I find one.

avatar image AndrewHurley Dec 09 '14 at 05:47 PM

Hey antoniobosi and bzundel,

We are sorry to hear you are experiencing an issue with this feature.

The Media Framework is not quite production ready yet and is still in the experimental stages. Some features may not work as expected, however we are currently working hard to resolve those issues as well as add addition features and support. Because this is such a new feature, I would not suggest making this a very important part of your projects yet as it is still in the works and under development.

Look in the upcoming hotfixes and releases for updates on this feature.

Media Framework Documentation

https://docs.unrealengine.com/latest/INT/Engine/MediaFramework/index.html

Thank you,

Andrew H.

avatar image wontonanimalchin Aug 28 '16 at 06:44 PM

hi there, its now 2016, UE 4.12,... so a long time after the first problems occured! Is there allready a solution to it? I tried about anything but, besides the editor, it doesnt work!

hope there is light at the end of the tunnel :)

best regards robert

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I've found the answer to this problem ...well Jamie discovered so I will just quote him here:

First thing copy your movie file to the content\movies folder in your project. Import the file in UE4.. this will create Media Player Asset in the editor..

Open up the new Asset and in the File or URL section reset the URL/file. Next click on the 'File or URL' again and add the file you want to play..

Notice that the paths change completely from absolute to relative path.

this will now package correctly and play from any location.

more ▼

answered Jan 13 '16 at 05:42 PM

avatar image

Robbie222
181 6 52 20

avatar image [PB]Aphexx Jun 20 '16 at 06:10 PM

haha guys...please put this info bit into the documentation. it took me a whole day until i found this solution..and it works! thanks for sharing the solution Robbie222!

avatar image The_Shane Jun 25 '16 at 11:48 PM

I got the path updated to relative, but packaged videos are still a black texture. Has this worked for anyone else?

EDIT: I just tried streaming the file from my website, and that isn't working, either. No luck with Shipping, Development, or Debugging packages. File was originally 1920x1080, but I've tried it with 1918x1078 (lol) to no avail as well. .wmv file

EDIT2: Works fine in 4.11.2, but not 4.12.3

avatar image imsarah Jun 29 '16 at 04:10 AM

doesn't work for me either in 4.12.3

avatar image imsarah Jul 08 '16 at 06:02 AM
avatar image VSZ Sep 14 '16 at 03:38 PM

@Robbie222 Thank you for sharing this answer! Even in 4.13 I had to use your clever trick to get packaged movies to play. Thank you so much for sharing this!

avatar image Robbie222 Sep 14 '16 at 03:44 PM

Glad I could help :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It appears that the problem is with relative vs absolute paths. In 4.5 you cannot set a relative path to your movie file within the media Player. Basically this means you are out of luck. In 4.6 you can set a relative path and the movie file works correctly when built.

more ▼

answered Dec 09 '14 at 06:15 PM

avatar image

quality
79 3 5 9

avatar image AndrewHurley Dec 09 '14 at 06:51 PM

Thank you for the investigatory update. We always appreciate users trying to troubleshoot and find solutions to their issue. I will keep the version change-over in mind, and notify any other users who are having a similar issue about the change.

In that case the official answer for this question would be to update to version 4.6 to be able to package your movie files.

Thanks again,

Andrew Hurley

avatar image 3dids Feb 09 '15 at 02:40 PM

Hi Andrew. Do you know if 4.7 will have some fixes regarding the media plugin? Like having the media sound wave to load correctly after restarting unreal, and also having the media sound wave able to be packaged?

The thing is I have implemented a lot of features : synchronize sound and image in movies, playing mp4 and various codec, playing from a webcam, from capture cards like (http://www.datapath.co.uk/products/video-capture-cards/capture-card-features), optimize lot of stuffs to be able to playback 4k videos at a reasonable frame rate.

All of it works well in the editor as well as in packaged games, except the sound. I cannot make it work in a package.

Thanks, Bryan

avatar image Tim_Moodbuilders Jan 15 '15 at 10:21 AM

For me, UE4 shuts down when trying to make relative paths.

When I go into the media player settings I take the option to load the video 'from memory' needs to be on in order to get a relative path that works in a packaged game?

  1. UE4 tells me the video texture needs to be placed in the content>movies directory

  2. The movies folder does not exist when creating a blank first person project

  3. A media and mediatexture folder does exist

  4. When I import my video file from the media or mediatexture folder (in content folder of UE4 project), UE4 shuts down when I activate 'load from memory'

  5. Running UE4 as administrator does not change this

  6. When I create a movies folder in the content folder and import the media file from there, it does not crash and will let me activate the 'load from memory' option. However the movies file is not exported when I package + UE4 shuts down when I try to open the projectfile in editor after packaging.

What am I doing wrong?

avatar image AndrewHurley Jan 15 '15 at 04:07 PM

Hello Tim_MoodWorks,

So I ran some tests with the Media Player asset and was able to reproduce most of what you were saying. I will give you a small list of my steps as well so we can compare what each of us did.

Steps to Reproduce

  1. Create a new Blueprint First Person Project without Starter Content in 4.6.1

  2. Save the Project and Close the Editor.

  3. Go into the Project's Content Folder and Create a new Folder called 'Movies.'

  4. Move/Copy the .WMV movie file inside of the 'Movies' folder.

  5. Re-open the Project and Import the movie file from the 'Movies' folder just created.

  6. This will automatically create a 'Media Player Asset'

  7. Double click the 'Media Player Asset' and check the 'Auto-Play' and 'Looping' boxes.

  8. In the Content Browser, right-click the 'Media Player Asset' and choose the 'Create Media Texture'

  9. Right click on the 'Media Texture' and choose 'Create Material'

  10. Connect the texture sample to the 'Diffuse Color' input and 'Save All'

  11. Now package your product for Windows.

  12. Attempt to launch the Game via the Packaged product.

  13. Observe the how the game attempts to load, but closes the window shortly after launch.

  14. Project will also not open.

If you have any further information about this issue that would be very helpful. We always appreciate these reports because it helps us improve our current features and makes other users aware of the issue.

Thanks again,

Andrew Hurley

avatar image Tim_Moodbuilders Feb 09 '15 at 01:49 PM

Hi Andrew, thanks for the effort!

I tried multiple different ways to get in working.

  1. When I load the media player asset (your step 6-7), and set it do 'load from memory' ,no auto-play and no loop.

  2. UE4 crashes if I use the save 'floppy' icon, but it does not crash when I use the 'save all' option at the top taskbar menu.

  3. After this I add a control (letter p) to play and stop the media texture in-game.

  4. Package project

  5. When loading, the project does start and open, but texture is black and nothing is playing

  6. 'From memory' link is not working I guess?

Is it possible to make a workaround for this? My current project requires me to package multiple video's, and it is quite a big problem (I guess for more people / any video file you want to use)

Thanks! Tim

PS: there is no way to load the video file location after making the package? via blueprint for instance

avatar image AndrewHurley Feb 09 '15 at 02:47 PM

Hey again Tim,

No problem. I am going to run one more test using four separate variations to see if this issue is related specifically to a certain stream mode. It was reported that videos with the resolution of 1920x1080 on Windows, renders black in a packaged product.

Let me know if the video you tested with was at this resolution. This could be part of your issue. I will check mine as well and report back here with what I uncover after testing. I appreciate your patience with as I am trying to gather all the appropriate information for the bug report so the fix can be found and implemented efficiently.

Thanks,

Andrew Hurley

avatar image Tim_Moodbuilders Feb 09 '15 at 03:31 PM

They videos I am using have been provided to me, they are part of a lighting projection design. They are windows media player files of different non-standard sizes, 800x800 / 400x800, 23fps

I added one such video for you to download via wetransfer: http://we.tl/E1Th2evqYD

avatar image AndrewHurley Feb 09 '15 at 09:19 PM

Hey Tim_MoodWorks,

So after a good few hours of testing I narrowed down the issue to being related to the 'From Memory' as you suggested.

If you are applying the movie via media texture material using the 'Default Lit' mode, you will want to rebuild your lighting for the changes to take affect. The workaround I suggest would be to keep the streaming mode to 'From URL'.

I created a bug report for this issue and will keep this post marked as unresolved for tracking purposes if anyone else is experiencing a similar issue. We always appreciate users taking the time to report bugs or issues found as it helps us improve upon the users experience with the Engine.

Regards,

Andrew Hurley

avatar image Tim_Moodbuilders Feb 10 '15 at 09:03 AM

Hi Andrew,

Thanks for the feedback! It's quite a big thing, hope it can get resolved in UE4.7! It actually makes all media texture uses in UE4 impossible (as usually your goal will be to be able to play it on other PC's)

So I think the only way to succesfully get media textures to work in a packaged game on a different computer is to place the corresponding media files in the exact same directory name as the PC the game was packaged on?

My current scene is fully dynamic, so is a light rebuild needed then?

avatar image 3dids Feb 10 '15 at 04:09 PM

Hi Tim_MoodWorks,

That's right. I have the same issue. Movies have to be in the same absolute directory on all machines. And they have to be dragged in the editor, because relative paths are buggy.

Sounds extracted from movies also have a lot of bugs.

avatar image supersane Feb 12 '15 at 07:06 PM

Will this be resolved in 4.7? Have many 1920 by 1080 videos I plan on using.

avatar image Pyronious May 26 '15 at 06:45 PM

Can we get an update on this issue? Thanks!

avatar image AndrewHurley May 27 '15 at 02:06 PM

Hey Pyronious,

This issue is currently in progress for testing and a fix will be upcoming. As for a time-frame I cannot say as I do not know what the fix requires, but we appreciate your patience while we get one implemented.

Cheers,

Andrew Hurley

avatar image AndrewHurley Jul 10 '15 at 06:49 PM

Just replied to the forum post, and hopefully we can get you to a working point.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey supersane,

We are working hard to have this fixed as soon as possible. Currently this is not on the roadmap to be fixed by final 4.7, but this is a priority to have fixed in the future.

Thanks,

Andrew Hurley

more ▼

answered Feb 13 '15 at 04:55 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question