x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Import error building UE4 source

I am building UE4 version 4.5 from source. I have cloned the repository, switched to the 4.5 branch, merged the required two zips.

I am using VS2013 ultimate on Windows 7 to build the source, DirectX 2010 runtime is installed.

Unfortunately during building the following error pops up:

2> G:\UnrealEngine\UnrealEngine\Engine\Source\Runtime\Core\Private\Misc\Database.cpp(324): error C4772: #import referenced a type from a missing type library; '__missing_type__' used as a placeholder

Then about a hundred lines follow with errors that undoubtedly spring from this problem. I have gone ahead and taken a look at the offending line in Database.cpp:

#import "System\ADO\msado15.dll" rename("EOF", "ADOEOF") //lint !e322

above this line is the following comment:

// Using import allows making use of smart pointers easily. Please post to the list if a workaround such as // using %COMMONFILES% works to hide the localization issues and non default program file folders. //#import "C:\Program files\Common Files\System\Ado\msado15.dll" rename("EOF", "ADOEOF")

To try and resolve the program here are the steps that I have taken:

  1. I have gone to **C:\Program files\Common Files\System\Ado** to ensure that msado15.dll is present in the folder.

  2. I have added **C:\Program files\Common Files** to my PATH so the importer can find it.

  3. After step 2 still caused errors in the building process, I have replaced the offending line with the full path from the comment. This however did not work either.

I am not sure what to try next, I hope anyone can shed some light on this problem.

EDIT: Added a full log of the build process until I cancel it after the error: Build Log

Product Version: Not Selected
Tags:
errorlog.txt (34.9 kB)
more ▼

asked Nov 19 '14 at 09:50 PM in Installation & Setup

avatar image

Nimthora
3 2 4

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Which configuration are you trying to build the engine in, Development Editor, Debug Editor, something else? Your second error would seem to indicate your Visual Studio installation is broken, do you or did you have any previous versions of VS installed? In any case, what I'd do is completely uninstall VS 2013, make sure I've got the latest Win7 service pack installed, install VS 2013 again, and finally install VS 2013 Update 4.

more ▼

answered Nov 25 '14 at 07:02 AM

avatar image

enlight_2014
574 30 14 37

avatar image Nimthora Nov 27 '14 at 03:50 AM

I am building the Development Editor. So, I uninstalled VS 2013 ultimate and all the old development libraries for it. Downloaded VS 2013 express. After install I got some errors relating to me not having a certain windows patch KB2664825 for Microsoft SQL server. Unfortunately, I was unable to install that patch.

Anyways, figured I'd have a go at building regardless. Turns out it actually succeeded, and I am now running the UE4.6 editor successfully as far as I've seen. I hope I won't get a nasty surprise along the line. Will try to compile a dedicated server tomorrow with this.

Thank you for your help.

(comments are locked)
10|2000 characters needed characters left

Hey Nimthora-

Try using this link: https://github.com/EpicGames/UnrealEngine/releases/tag/4.5.0-release to download the zip files for the source code and required files. After unzipping them to the folder you want to save them in, make sure to run the GenerateProjectFiles.bat file then open the UE4.sln and build the engine. When that finishes you should be able to run the engine from Engine->Binaries->Win64.

Cheers

Doug Wilson

more ▼

answered Nov 19 '14 at 09:58 PM

avatar image Nimthora Nov 20 '14 at 01:59 AM

Hi, thank you for responding so soon. I have downloaded the files you linked, and followed the instructions. Unfortunately, the same error pops up upon building the source.

avatar image Doug E ♦♦ STAFF Nov 20 '14 at 02:48 PM

Do you get the same error if you try to build any other version of the engine? There were a number of fixes that went into 4.5.1 so you may want to try that version as well.

avatar image Nimthora Nov 21 '14 at 12:37 AM

I couldn't find any hint to a fix in this area on the 4.5.1 release notes, so I went full out and installed the 4.6 preview. However the build still gives the same error message. I should also note at this point that for both version 4.5 and 4.6 after the initial error in my top-level question another error occurs on fully building the source, namely:

1>G:\UnrealEngine-4.6.0-preview\Engine\Plugins\Developer\VisualStudioSourceCodeAccess\Source\VisualStudioSourceCodeAccess\Private\VisualStudioSourceCodeAccessor.cpp(32): fatal error C1084: Cannot read type library file: '80cc9f66-e7d8-4ddd-85b6-d9e6cd0e93e2': Error loading type library/DLL.

I have attached the full build notes. Build Log 2.6

log2.6.txt (109.4 kB)
avatar image Doug E ♦♦ STAFF Nov 21 '14 at 03:43 PM

Hey Nimthora-

I would try updating to the latest DirectX if you haven't already. Also, could you provide a copy of your DXDiag? We have not had any reports of other users having this problem and it would help identify what is unique about your system that may be causing the problem.

avatar image Nimthora Nov 21 '14 at 05:03 PM

I am running windows 7 with directX 11, which seems to be the latest version. Here is my dxdiag: DxDiag

dxdiag.txt (31.5 kB)
avatar image Nimthora Nov 25 '14 at 06:26 AM

Still having this problem. :(

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question