x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Promoted branch - bug and crash reports

I decided to try the 'promoted' branch and got some bugs to report.

1) When packaging the game, or when compiling in VS2013 in "Development" (not "Development Editor") configuration, the following error occurs:

 [2014.11.16-22.54.44:711][ 46]MainFrameActions: Empacotamento (Windows (64 bits)): UnrealBuildTool: ERROR: All source files in module "Core" must include the same precompiled header first.  Currently "D:\UnrealEngine\Engine\Source\Runtime\Core\Public\Core.h" is included by most of the source files.  The following source files are not including "D:\UnrealEngine\Engine\Source\Runtime\Core\Public\Core.h" as their first include:
 
 [2014.11.16-22.54.44:711][ 46]MainFrameActions: Empacotamento (Windows (64 bits)): UnrealBuildTool: 
 
 [2014.11.16-22.54.44:712][ 46]MainFrameActions: Empacotamento (Windows (64 bits)): UnrealBuildTool: D:\UnrealEngine\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformContext.cpp (including D:\UnrealEngine\Engine\Source\Runtime\Core\Private\CorePrivatePCH.h)
 
 [2014.11.16-22.54.44:712][ 46]MainFrameActions: Empacotamento (Windows (64 bits)): UnrealBuildTool: D:\UnrealEngine\Engine\Source\Runtime\Core\Private\HAL\MallocCrash.cpp (including D:\UnrealEngine\Engine\Source\Runtime\Core\Private\CorePrivatePCH.h)

...and other cpp files, attached the log (see line 878).

2) Crash when you open the dropdown menu to change editor language.

3) As of today's update, the editor crashes when starting up. The log doesn't says anything meaningful I believe. I have attached the dump and log. Also, reading the value of the variable UWidgetBlueprint* WidgetBlueprint in FReply CompileWidgetBlueprint() (the penultimate function in the call stack), apparently it was trying to compile a specific widget blueprint, which I have also attached in that zip.

Btw: bugs 1 and 2 were on yesterday's version; bug 3 happened after today's update (latest commit was "Rebuilt binaries for promoted changelist 2364633")

Product Version: Not Selected
Tags:
bug1.zip (20.2 kB)
bug3.zip (40.3 kB)
more ▼

asked Nov 19 '14 at 10:37 PM in Bug Reports

avatar image

Ixiguis
1.1k 57 59 252

avatar image Ixiguis Nov 20 '14 at 05:28 PM

Well, found a workaround for bug #3. In FReply CompileWidgetBlueprint(), I replaced if (GIsEditor) with if (GIsEditor && GEditor), apparently GEditor was NULL or invalid when that crash happened. Porbably a workaround though, not the real fix.

Bugs #1 and #2 seem to have already been fixed in the latest code (running the Master branch now).

avatar image Tim C ♦♦ STAFF Nov 21 '14 at 04:39 PM

Hi Ixiguis,

I did a clean build of the Promoted branch from a couple days ago (based on changelist 2364633), and was unable to see any of the errors you mentioned. Were you using a specific template when you tested this?

Tim

avatar image Ixiguis Nov 21 '14 at 04:49 PM

I'm using ShooterGame, but is too heavily modified by now.

Note my other comment, bugs 1 and 2 have already been fixed.

Regarding #3, did you not get the crash with the attached widget blueprint?

avatar image Ixiguis Nov 21 '14 at 07:27 PM

PS. The attached widget bp might not load at start for you because it's not in use by anything; you might have to reference it in something that is loaded at start, maybe a custom player controller.

avatar image Tim C ♦♦ STAFF Nov 21 '14 at 10:57 PM

I brought the Widget Blueprint that you provided into the project and referenced it in a custom PlayerController that the project was then set to used. I was able to open and close the project several times without seeing a crash.

Are you able to see the same issues in a new project from one of the templates in the promoted branch? I understand that some of them appear to have been corrected in the Master branch, but if I can reproduce the issues in Promoted we can verify that they have been properly corrected.

avatar image Ixiguis Nov 22 '14 at 12:53 AM

Hmm yeah, I tried what you did too (new project with that widget bp), and I didn't get a crash either. So it could be a combination of several factors that's causing it.

Tomorrow I'll compile the engine in debug mode and see if I'm able to track down the issue, or at least provide you a full dump file.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Ok, so I tried the latest master branch (up to Nov. 23), and all 3 bugs are gone! (Actually the change I proposed in the first comment was integrated here)

One other bug I always forget to report (has been around for a long while). The material Material'/Engine/EditorShapes/Materials/M_ShapeMaster.M_ShapeMaster' has missing textures. Maybe they weren't added to the prerequisites package. The missing textures are the following:

/Engine/EditorShapes/Textures/T_ShapeNormal.T_ShapeNormal /Engine/EditorShapes/Textures/T_ShapeDiffuse.T_ShapeDiffuse

more ▼

answered Nov 24 '14 at 06:27 PM

avatar image

Ixiguis
1.1k 57 59 252

avatar image Tim C ♦♦ STAFF Nov 24 '14 at 10:15 PM

I am glad to hear that it seems like the issues that you mentioned have been resolved.

For the other existing bug that you mentioned, would you be able to create a new post for that one since it appears to be unrelated to the other issues in this thread? Myself or one of the other members of the support team will look into that one as well.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question