x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

FMemoryWriter does not support data larger than 2GB

Hi guys im having problems packaging my project. I have cooked my content for windows and it keeps saying it failed. I then packaged my project for windows on development settings and that also failed. What am i doing wrong?

Are there steps to packaging because i tried cooking first then packaging. can someone tell me what is wrong with my packaging. I have uploaded pictures of the failed settings

there seems to be a problem with TPF. It says "failed while setting focus to the disabled TSF document manager" and also RunUAT.bat ERROR: automationTool was unable to run successfulalt text.

Product Version: Not Selected
Tags:
cooking.jpg (521.8 kB)
packaging.jpg (617.5 kB)
packaging2.jpg (574.2 kB)
packaging3.jpg (485.9 kB)
packaging4.jpg (573.0 kB)
more ▼

asked Nov 20 '14 at 01:40 AM in Packaging & Deployment

avatar image

StefanTheArchitect
5 2 3 4

avatar image [Epic] Gribbs ♦♦ STAFF Nov 20 '14 at 06:36 PM

Howdy StefanTheArchitect,

Thank you for reporting this issue. Would you be able to include your DXdiag and your project log files so that I may further investigate this issue?

Any additional information would be greatly appreciated.

Thanks and have a great day!

avatar image StefanTheArchitect Nov 21 '14 at 12:57 AM

Hi Sean thanks for the reply,

I have been able to package the default programs but not the one i just created.

I dont know if its because of the blueprints Ive created or lighting issue. Ive been able to package my project during its early stages but now it keeps failing.

Here are the files you were looking for

link text link text

thanks

dxdiag.txt (33.4 kB)
cook.txt (131.8 kB)
avatar image StefanTheArchitect Nov 21 '14 at 01:05 AM
uat_log.txt (175.4 kB)
avatar image 1681166xp Jul 08 '15 at 10:05 AM

Hi

just wondering...you talking about spliting it to resolve the problem...but why migrating everything to a new map helps??

avatar image wittlief ♦♦ STAFF Jul 08 '15 at 07:17 PM

Hi 1681166xp,

I can't see where that is suggested, can you elaborate? If it's mentioned in the tutorial you will need to ask the creator to explain.

avatar image 1681166xp Jul 09 '15 at 05:42 AM

I'm sorry my bad...after migrating into a new project all lightmaps resolution was set back to default, thats why it worked again...the problem was all the time the lighmaps - the data was just too big overall.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

Hi mate, Looks like it's having a problem cooking because the package is too big.

 FMemoryWriter does not support data larger than 2GB. Archive name: H:/grad project/MyProject/Content/Maps/Building_And_Land_And_Road1.umap.

This is problematic for many reasons, you don't need to cut anything out but I would suggest splitting it up into different levels.
The persistent level can contain any number of levels, all these levels will be loaded when you load the persistent level in the editor. Perhaps this tutorial will help. https://www.youtube.com/watch?v=YIKa3riX_MI

more ▼

answered Nov 21 '14 at 07:48 PM

avatar image

MrFred STAFF
523 10 3 18

avatar image StefanTheArchitect Nov 21 '14 at 11:28 PM

Thanks a lot for the help! It always bothered me why it wouldn't cook.

avatar image JHope1488 Nov 18 '15 at 03:58 PM

I have this same problem but it isnt helped by splitting up the level. I'm working towards an ArchViz live walkthrough for a client. The game plays fine in the editor window. I'm really just after that as a .exe. I'm encountering this error :link text

I have fully unwrapped every model with Light Uvs Maximum lights UVs are 2048. The geometry spans roughly 40K square feet. I'm dealing with roughly 300 lights, which is a bit excessive but its the clients request.

Any advice would be greatly appreciated.

unreal_error.txt (6.0 kB)
avatar image Samantha Sutton ♦♦ STAFF Nov 19 '15 at 10:30 PM

Hey BigFudge1488,

Can you tell me exactly what you've done to split up your level? Have you tried streaming levels together so that it takes the load off of the umap file?

Looking forward to hearing back from you, thanks!

avatar image AgentGhost Nov 11 '17 at 09:33 AM

Hi all , I'm working on an Arch Viz Project ( 2BHK Apartment ) and I was getting the same 2GB limit error, So I split my entire level into 5 sub levels,and I have given Always load as the streaming method. but still I'm not able to cook/package the file.But If I delete the build data from the file it will work. Please help me out to solve the error ASAP. Thank You

avatar image TeeHokken Nov 15 '17 at 07:50 AM

Hi,

I'm dealing with the same problem. Could you solve it?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, I also have the same problem...does anyone know how to solve it?

more ▼

answered Dec 25 '17 at 05:14 PM

avatar image

Matei
1 1 3 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I am using the lighting scenarios feature and it seems that I can not split the lighting data... any Ideas? So a similar problem...

Thanks, Ryan

more ▼

answered Jan 19 '18 at 03:31 AM

avatar image

rdashkevicz
41 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

In case anyone else was getting this error and can't resolve it, try deleting the map build data. It worked for me after I had tried everything else.

Wish I knew why it worked, but there you go.

more ▼

answered Apr 24 '18 at 02:00 PM

avatar image

dreinzy
26 1 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

map build data was the culprit for me as well thanks for this so much!! for anyone new this data is in the same folder as the map file.

more ▼

answered May 18 '19 at 05:20 PM

avatar image

OGSWG
6 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question