x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Normals in Unreal vs Marmoset

Hey

So im trying to get normal maps to display correctly but they just wont, Its nothing wrong with the bake since they look perfect in Marmoset Toolbag, The green channel is flipped and everything is as it should be. But i get a nasty crease along my seam and the rest just looks slightly of, it does't pop. There is a feature in Marmoset called Scale and Bias, and when i check this it goes from looking like it does in unreal to looking correct, and i'm sure that its possible to achieve the same effect with the unreal material editor i'm just too dumb to figure it out. Is there any hopes me?alt text

Product Version: Not Selected
Tags:
untitled-1.jpg (1.2 MB)
screenshot010.jpg (532.7 kB)
more ▼

asked Nov 26 '14 at 09:45 PM in Rendering

avatar image

Emil.Klingberg
1 1 3 4

avatar image Emil.Klingberg Nov 26 '14 at 10:03 PM

Also I found out that if i rotate it one way it looks more correct, but if i rotate it the opposite it looks even more wrong, so the errors aren't even constant they change depending on the orientation of the static meshalt text

rotated.jpg (967.5 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I figured out the problem If anybody has the same issue, In the Texture viewer (double click the texture in the content browser) i found that the compressing setting for the Normal map was TC Default, for some reason. I changed it to TC normalmap and voila it works perfectly, however this only happens when i import TGA files from Xnormal bakes and not from Max bakes, its really odd.

more ▼

answered Nov 26 '14 at 10:51 PM

avatar image

Emil.Klingberg
1 1 3 4

avatar image Luos Nov 26 '14 at 10:57 PM

This has something to do with either the way a program compresses it, or the color value saved. It can be just a tad off resulting in UE4 not understanding its a Normal Map.

I dont seem to have this issue if I use .png, but with TGA it occasionally happens. (Perhaps forgot to disable or enable compression)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question