x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Strange Lighting and Shadows

So i built a small Level with one Directional Light representing the Sun (all contained in a Lightmass Importance Volume) Im new when it comes to Lighting in UE 4 but i understand the Basics. But when i build my Lighting i get a really weird Solution (see Screenshots below). It looks like the Sun is shining through my walls in the far back of the corridor and the walls shouldnt be that lit at all. They should be much darker and the end of the corridor should be completely black. I used the basic "Shape_Cube" (wich comes with UE) to build the whole Level. The Light Map Resolution of the Cube is 64 and i didnt change it. I also didnt override any Light Map Setting in the Level itself. Also i used the "Preview" Build method if that is important for that. Can someone tell me what i am missing or doing wrong here?

Picture 1 Picture 2

Product Version: Not Selected
Tags:
more ▼

asked Nov 28 '14 at 10:27 AM in Using UE4

avatar image

Pandabrain
16 4 7 8

avatar image Narghile Nov 28 '14 at 10:54 AM

What graphics level you running, have you view it under EPIC quality

avatar image Pandabrain Nov 28 '14 at 11:00 AM

i found the option and changed it to EPIC but that didnt do anything. Also setting the build quality to "Production" or overriding the Light Map Resolution on everything to 128 or higher didnt change anything.

avatar image Narghile Nov 28 '14 at 11:37 AM

I had this issue a second ago [1]: /storage/temp/22404-capture.jpg

But when I removed the sun, I got this [2]: /storage/temp/22405-capture-1.jpg

capture.jpg (45.8 kB)
capture-1.jpg (25.5 kB)
avatar image Pandabrain Nov 28 '14 at 11:45 AM

the thing is: if i remove the light, the sun is gone. The level part shown in the screenshots is only the inside of the level but there is an outdoor part aswell for wich i need the directional light EDIT: i removed the directional Light just to test it but the result isnt different at all. i also came across something called "Sky Light" and i watched some videos on it but it also didnt change anything

I change my line from before "I`m new to lighting but i know the basics" to "ok im totally new to lighting in UE4" xD

avatar image Narghile Nov 28 '14 at 11:54 AM

I am not going to be much help then. Sorry, I have issues with that aswell.

I will follow to see if there is an answer

avatar image Narghile Nov 28 '14 at 11:58 AM

You can see it the top picture, the sun creeping in the top right. Can you put it in a another box to compensate for now?

avatar image Narghile Nov 28 '14 at 12:02 PM

Found this, does it help

Try setting "cast shadow as two sided"

Try to give mesh some thickness and in World settings under lightmass change static lighting level scale to 0.75 and indirect lighting smoothness to 2 and Max occlusion distance between 200-260.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

If you're using a cube and scaling it non-uniformly while keeping a fairly low lightmap resolution you will get low quality lighting results.

The issue is that the lightmap UVs are made for a cube and they don't scale with the mesh unless you scale the same amount in each axis. Try using BSP brushes for early level design and then replace them with tailor made static meshes.

Remember that (somewhat counter-intuitively) high values for lightmap resolution on static meshes will give you higher quality results, but lower values for BSP geometry will yield better results.

more ▼

answered Nov 28 '14 at 11:55 AM

avatar image

Skuvnar
221 24 21 36

avatar image Pandabrain Nov 28 '14 at 12:09 PM

ha i already thought this was because i scaled the cubes. thanks for the clearup i will try to use BSP Brushes

EDIT: I now use BSP Brushes for the Level and it works fine. Thanks for the Help.

avatar image Skuvnar Nov 28 '14 at 12:13 PM

No problem, let me know how it goes.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question