x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Open Level Blueprint not working

I have a home level where I have a trigger box, that when collided with, it will load another map/level. This works perfectly in standalone. When I build the game, however, when I collide with the trigger box, it just reloads the home map. I would like to know what is going on if anyone has had this happen before. Thanks.

Product Version: Not Selected
Tags:
more ▼

asked Dec 02 '14 at 05:36 PM in Blueprint Scripting

avatar image

bzundel
51 6 11 12

avatar image ChiragR Mar 04 '15 at 08:57 AM

Hi,

Any solution to this? I am currently facing the same issue.

I have a Menu Map that is supposed to load a Level. It works perfectly in the editor (selected viewport, new editor window and standalone game) but the minute I try and and package the project it doesn't work anymore.

My default map is the 'Menu' and when I click on the button to load the other map, it just reloads the 'Menu' map.

Any help is most appreciated. Thanks!

avatar image JGI-Tom Jun 16 '15 at 04:20 PM

Hi.

Has anyone found the solution for this problem?

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Hi guys,

What engine version are you using?

Make sure all maps are cooked. In DefaultEditor.ini you must specify all maps in this section (create if not exists)

example:

 [AlwaysCookMaps] 
 +Map=/Game/Maps/InventoryLevel



However, if you are running engine version 4.7 I have experienced a problem running in android devices which OpenLevel does not work as reported here

more ▼

answered Dec 03 '14 at 07:40 PM

avatar image

Dredok
266 17 19 42

avatar image bzundel Dec 03 '14 at 08:00 PM

I'm running 4.5.1. The [AddCookMaps] worked for me. However, I think that is REALLY unintuitive. I would think that the engine would be smart enough to see that if you tell a level to open in a blueprint, it should be included in the cook by default. Is there a reason why it's not like that?

In addition, how do I help the levels to load faster? When I walk into the volume, there is a 4-5 second load time for the level. Can I load them in the background (they are small levels)?

Thanks for the help!

avatar image Dredok Dec 03 '14 at 08:06 PM

Well ... it works if you have a hard reference to the level. But using text the engine has no clue :/

You could have a look at async load level streaming and see if it can help with your load times.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi!

Try to create LoadLevel blueprint. Create Actor class blueprint. In Components add Scene component and Box component. Select Box component and Add Event - OnComponentBeginOvarlap and attach OpenLevel node with level name.

alt text

alt text

level01.png (234.1 kB)
level02.png (194.9 kB)
more ▼

answered Dec 03 '14 at 08:40 AM

avatar image

svv3dUDN
8.4k 254 41 399

avatar image Guvenc Dec 03 '14 at 09:00 AM

Hi, i have the same problem and i don't think that's the solution(i've already tried that). When i am in the editor "Play mode" it work's but when i try to launch the game or cook the game, i got the same result with "bzundel". I also tried to write a false map name in the editor "Play mode" for test, the result is same. If blueprint can't find the map it loads the first map somehow. I guess the problem is caused because of the map path or something like that. Does anyone has any idea about it? Thnaks.

avatar image bzundel Dec 03 '14 at 07:28 PM

Thanks for the reply, svv3dUDN.

I have exactly what you have described, but in the level blueprint. It isn't working at all. Instead of opening the level in the "Open Level" node, it reloads the current level. Would it make a difference to create Actor Blueprints that do the same thing?

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Make sure you have a player start in the level you are trying to load. Otherwise it will drop you back into the same map.

more ▼

answered Jul 21 '15 at 07:09 PM

avatar image

Strom
99 2 2 4

avatar image jetset_3566 Nov 07 '16 at 10:48 PM

hi storm, I am not sure, but maybe you answer help me load level, thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I figured it out on my game recently. Make sure to tick off the absolute value so it doesn't load a false and reset the level. I also added a make literal name function connected to the level name node and typed the name in the value there but I don't believe that was necessary. Try it if it still doesn't work after clicking off the absolute.

more ▼

answered Mar 03 '16 at 12:58 AM

avatar image

superfun64
11 1 1

avatar image superfun64 Mar 03 '16 at 01:04 AM

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question