x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Download infinitely restarting.

So I've been trying to get this to work but no luck so far. Basically what's happening is that it's completing the download and then as soon as it's finished it goes back to 0% and restarts. I tested it with Swing Ninja from the marketplace since it's only 97mb which is tiny compared to everything else and it just keeps going and going and going.

I could just keep trying until it works but I have a monthly download limit that I'd rather not breach (Downloading ue4 has probably already screwed me for this month but I'd rather not get more screwed :P)

Product Version: Not Selected
Tags:
more ▼

asked Mar 21 '14 at 01:34 PM in Installation & Setup

avatar image

leonn3k
39 1 2 7

avatar image leighswift STAFF Mar 21 '14 at 07:59 PM

Hi leonn3k,

Sorry to hear you're having issues. I could do with seeing some of your log files if that's ok.

You can find them here:-

C:\Users\User.Name\AppData\Local\UnrealEngineLauncher\Saved\Logs

Replace User.Name with your windows login name, and attach a zip of the log files you find in there.

Thanks,

Leigh

avatar image leonn3k Mar 21 '14 at 11:26 PM

Hi Leigh, Thanks for the reply. I've attached the log files as you asked. link text

logs.zip (294.1 kB)
avatar image Wrr Mar 22 '14 at 02:04 PM

I have the same problem with launcher restarting the download after completion on OS X too. I've downloaded the ~6gb content which starts automatically multiple times. First time: ERROR: Failed to construct file UE4Game-Redist-Engine-Mac-Shipping.a second time: Verify failed on UE4Game-Redist-Engine-Mac-Shipping.a next try: Verify failed on UE4Game-IOS-Shipping and last time: Verify failed on UE4Game-Redist-CrashTracker-IOS-Shipping.a

avatar image Benjaminkendzior Dec 07 '17 at 11:25 PM

I was having that same issue and it makes gets impossible to fix it all so i can't even get to play the game with a flash drive having enough storage on it to begin with so i was wondering if you could help me out here.

Maybe be able to fix it for me at all and if you give me a email i can message id gladly email you my issue so that i can play and have a fun time getting to play fortnite cause i've loved the game the whole time and would love even more to get to play the game with friends and so much more.

But yea i would gladly give you my gmail and you can get ahold of me that way cause i'm not always on a pc so i'd be very helpful if i can access contact with you wherever i may be during my day.

but here's my Gmail Bmkendzior@gmail.com cause id love to fix this issue that im having like leonn3k was having.

sincerely, Benjamin Kendzior

avatar image CHAOTICBOI786 Jan 28 '18 at 04:34 PM

I download 14 gb data Containing Engine folder and FortniteGame Folder , I think its incomplete , but when I click on resume It deletes my downloaded data and creates a folder .lysb containing Engine Folder and an unidentified app named as $resumedata.....Im tired of copying those 14 gb repeatedly...Is there a way That Launcher completes rest of download instead of Deleting everything and restarting??

avatar image leighswift STAFF Mar 22 '14 at 03:59 PM

Hey, just to update you, thanks for the logs, i'm looking into the issue now to see if i can come up with some suggestions for you.

However there is a known issue at the moment that when certain types of problems occur, we are seeing the whole download retry, instead of just the failed files. I think you are seeing this issue, which looks like infinite loop of downloading.

It looks like some of the patch data being downloaded is arriving corrupt.

(see log output that states "VerifyChunkFile chunk hashcheck failed" and "Failed to uncompress chunk data")

Have you got any further yet?

avatar image altares Mar 22 '14 at 04:43 PM

Hi, not sure if it is the same. My downloads do finish every time but the install fails saying exactly: Install Failed - A file access error has occurred. Please check your running processes. I'm on Mac OSX 10.9.2 up to date. My home folder is on an separate disk from my OS. Not sure if this changes anything..

avatar image leighswift STAFF Mar 22 '14 at 05:22 PM

I think this issue may be related to having user documents on a different volume to the launcher install. Does that apply to you? I'm investigating this too.

avatar image altares Mar 22 '14 at 05:44 PM

This applies to me yes. I've just tried putting the launcher on my Documents disk (home folder, I'm on OSX) but unfortunately it does not change a thing.. So maybe my issue is the same as this thread's no?

avatar image leighswift STAFF Mar 22 '14 at 07:32 PM

Sounds like it is related, unfortunately I haven't got to try to reproduce yet, but we are working on an attempt to fix the issue regarding different volumes.

avatar image J_U_D_G_E Mar 22 '14 at 09:37 PM

Did this fix, now the Engine... Finishes downloading.

However, it crashes at the very beginning of the install, and now, after the crash... well.... it starts downloading again.

I am installing on a Different Disk, like Altares is doing.

avatar image leighswift STAFF Mar 23 '14 at 04:46 PM

Hi again J_U_D_G_E. Sorry to hear that, are you running Mac or Windows?

avatar image J_U_D_G_E Mar 23 '14 at 06:58 PM

Hey Swifty, Im runningon Windows.

I was reading another thread, and it seems to be a Launcher issue. I went into the Folder Structure, and was able to launch the Engine, by clicking on the .exe

Seems to be a launcher issue!

At this time though, every time I open the editor, I have to cancel the launcher since it tries to re-download again.

avatar image leighswift STAFF Mar 23 '14 at 07:10 PM

Yes what you are launching there inside of the \4.0\ folder are files that the launcher has created so far, i do worry that it does mean you may not have the exact correct copy of the editor in there that you need and may be extra unstable.

It's great that you are managing to launch the editor though. But i'd really like to get you to a point where the launcher has synced it up properly :).

Do you think that at some point, when convenient, you could make sure the editor is not running, and then run the QFE2 hotfix and allow it to try and complete the install process without cancelling?

avatar image leighswift STAFF Mar 23 '14 at 07:13 PM

During that time, it may restart a couple times, but the QFE2 hotfix will ensure it only restarts the files that it found to be incorrect.

Also, to let you know, there is a 'retry' limit, so it will only restart a few times in a row to try and get a full install correct. If it fails after 5 attempts then you will see an error message.

Let us know how you get on and upload the logs from this process I can help some more if it is still no good.

avatar image J_U_D_G_E Mar 23 '14 at 07:36 PM

All I have done is with the QFE2 fix you provided below, if I dont do this, I cant run the engine, and still keeps downloading forever and I cannot open the engine.

avatar image leighswift STAFF Mar 23 '14 at 07:56 PM

Ahh ok. A zip of your logs folder would be great then. It may have info to help see why yours is failing. Just to confirm, were you able to allow launcher on QFE2 to keep trying until it presented an error message? I understand that it is frustrating I'm sorry about this.

Logs folder:- C:\Users\USER.NAME\AppData\Local\UnrealEngineLauncher\Saved\Logs

avatar image J_U_D_G_E Mar 23 '14 at 08:06 PM
avatar image leighswift STAFF Mar 23 '14 at 08:22 PM

Sorry, were there more files than that in the folder? If i am to help I will need to see a log that was generated from a full install attempt. (i.e when you have time to close the editor for a while, just let launcher try its best uninterrupted until it finishes trying or you get an error message). That one is a log that is from a download being canceled after a few minutes. There's no hurry if you are happy as is for the time being :)

avatar image J_U_D_G_E Mar 23 '14 at 08:42 PM

Uninterrupted Crash

link text

avatar image leighswift STAFF Mar 23 '14 at 09:44 PM

Thank you :). That's very peculiar that only a bunch of png files are not being created correctly. I can try and track this down now I have the info.

avatar image J_U_D_G_E Mar 23 '14 at 09:47 PM

Thank you so much ! Live up to your name :)

avatar image CHAOTICBOI786 Jan 28 '18 at 04:32 PM

I download 14 gb data Containing Engine folder and FortniteGame Folder , I think its incomplete , but when I click on resume It deletes my downloaded data and creates a folder .lysb containing Engine Folder and an unidentified app named as $resumedata.....Im tired of copying those 14 gb repeatedly...Is there a way That Launcher completes rest of download instead of Deleting everything and restarting??

avatar image mykdragn Apr 23 '14 at 07:15 AM

I am having the exact same issue as J_U_D_G_E where I have tried adding "-CPLabel=QFE2" to the shortcut but received an error "Unlisted build label QFE2"

i would like to be informed when a fix for this will happen.

link text

avatar image Stephen Ellis ♦♦ STAFF Apr 23 '14 at 11:33 AM

@mykdragn

Which version of the Launcher are you currently using? (displayed in the bottom-left corner)

Assuming you are on a more recent version than was being used late March, the QFE2 would be of no benefit, as the fix it contained has already been rolled into the latest versions.

avatar image leighswift STAFF Apr 23 '14 at 11:40 AM

Hi mykdragn. Is your problem that the "Unlisted build label QFE2" message appears? Or something else?

The QFE2 hotfix no longer exists as that is now in the main release, you should be running without any extra commandline options :)

avatar image cflies1121 Apr 30 '16 at 02:45 AM

Im having the same problem as above im on osx and its 2 years later.

avatar image Adam Davis STAFF May 09 '16 at 06:46 PM

Hi cflies1121,

I'm sorry that you are having an issue with the Epic Games Launcher. In order for us to offer the best support, we have recently modified the process for how Epic Games can help troubleshoot your Launcher issue. Please visit http://help.epicgames.com/ for technical support, here you can find information and solutions for common issues, as well as a contact form if you still need additional assistance. Thanks!

avatar image XxKierGamingxX Jan 13 '18 at 01:09 PM

Mine is not infinitelt restarting but i have played fortnite for two weeks but just of today fortnite restarted it needs to install again if anyone of you or any staff that can help me cause i dont wanna install fortnite again because it takes too long hope that you can help me guys

avatar image Smurfowner Apr 21 '18 at 09:16 AM

Hi,

I'm facing this issue too. I tried to add $movedMarker to C:\Users\emiel_000\AppData\Local\UnrealEngine\4.18

The launcher reports it has terminated prematurely.

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Ok, I have a fix for the problem with restarting downloads and chunk hash fails stalling the process. Try these steps to get the latest hotfix and let us know how you get on.

Please locate your desktop shortcut, and in the properties for the "Target:" box, add "-CPLabel=QFE2" to the end noting that QFE2 has to be capitalized.

The whole setting should look something like:

"C:\Program Files\Unreal Engine\Launcher\Engine\Binaries\Win64\UnrealEngineLauncher.exe" -CPLabel=QFE2

Please reply to this post with new logs if you still have problems.

Thanks!
Leigh

more ▼

answered Mar 22 '14 at 08:44 PM

avatar image

leighswift STAFF
1.8k 38 136 42

avatar image leonn3k Mar 23 '14 at 01:16 PM

Hi Leigh, I tried it and it didn't end up working unfortunately. I have managed to get it working by starting the launcher and stopping all of the downloads then going into C:\Program Files\Unreal Engine\4.0\Engine\Binaries\Win64 and launching UE4Editor.exe from there. If the launcher isn't open then running the editor .exe just opens the launcher. It's not optimal but it's working for now.

avatar image leighswift STAFF Mar 23 '14 at 04:53 PM

Hi leonn3k. Glad you are up and running. It does worry me a little that you may be running an editor with some corrupt file in it which is why the launcher has been retrying. You should be a little careful with saving often :). The fix in this QFE2 should mean that when the download/install appears to restart, it will only then fetch the files that were broken and so should finish off better.

Would you mind uploading some new logs after running the QFE2 version?

avatar image leonn3k Mar 24 '14 at 09:03 AM

Unfortunately I won't be able to help :( I've already downloaded it twice while trying to get it to work and as I said in my original post I have a limit on my downloads and if I go over it I'll literally have dial-up speeds for the remainder of the month which sucks a lot :\ There's three other people in my house using it as well :\ sorry :\

EDIT: Gah, now my editor crashes on startup after I tried to import an .fbx, likely something to do with the corrupted files. I think I might have to wait until a launcher patch that repairs an already installed installation.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

On closer inspection, I can see in one of your log files that when trying to install the engine, a whole bunch of png files fail to save out correctly. It strikes me as a bit odd that only png files would fail and nothing else :). Do you have any virus protection or data monitor programs running, like Panda Cloud Antivirus? Perhaps they could be interfering with the installation of the UI content for some obscure reason.

It does look like each time the installation got further and further though, down to just 15 png files failing on the final attempt. There is a quick hack that you can do to force the patcher to keep attempting to resume from the data currently contained in the installation folder. In your case I believe the steps will be as follows:-

  1. Navigate to "D:/unreal/4.0/"

  2. Create a new file named "$movedMarker". This file should have no extension (yes, that's a dollar sign!)

  3. You now have the following empty file "D:/unreal/4.0/$movedMarker"

You will need to do that just before starting the download again.

If successful, when you click install for UE 4.0, the process should begin with "Verifying Installation" and will then only attempt to download and install the png files that are still missing or corrupt. If this worked then you should notice that the downloading after verifying does not need to get the full 7.7GB.

Let us know how you get on, and please upload zipped logs folder again if you are still having no luck.

Thanks for your patience

more ▼

answered Apr 23 '14 at 12:19 PM

avatar image

leighswift STAFF
1.8k 38 136 42

avatar image mykdragn Apr 23 '14 at 06:32 PM

Thank you that worked perfectly.

avatar image Smurfowner Apr 21 '18 at 09:18 AM

Hi, I'm facing this issue too. I tried to add $movedMarker to C:\Users\emiel_000\AppData\Local\UnrealEngine\4.18 The launcher reports it has terminated prematurely. Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

On Mac OSX, I dug a little more and this is the kind of log I get:

MoveFile was unable to move '/Users/Shared/UnrealEngine/....SomeFiles' to '/Volumes/myDisk/Username/Documents/Unreal Projects/....SomeFiles', retrying in .5s...

This is why the install fails every time. Do you have a workaround for this? I already have my home directory on an other disk and I don't plan on putting everything back into the system, it would be a mess..

more ▼

answered Mar 22 '14 at 09:14 PM

avatar image

altares
16 1 3 6

avatar image leighswift STAFF Mar 22 '14 at 09:44 PM

Hey thanks, altares.

Yea we know the issue and a fix is in the pipeline.

I'm afraid a similar process to the windows one mentioned above is not available to OSX yet, until the next Launcher update release. This should be quite soon though!

Sorry again for the inconvenience. We are trying to see if there is a quicker way to hotfix individual OSX users and will update if we find one!

avatar image altares Mar 22 '14 at 10:05 PM

Ok found a workaround. One needs to sudo the Launcher in the terminal every time to start the engine or download contents. If one tries calling the app directly Mac OS style, he loses everything. At least for now, it WORKS! Sheers

avatar image leighswift STAFF Mar 23 '14 at 04:43 PM

Ahh that's interesting, thanks for sharing! So it was sort of a permissions issue in the end. It'd be great if you could help to specify a setup we might be able to reproduce this with.

What type of user account did you install the dmg from? Is that the same user account you then started using the Launcher from? Does your documents/home volume have different permission setup?

Thanks!
Leigh

avatar image altares Mar 24 '14 at 10:10 AM

Forget about this, it was more trouble that I had thought it would be. The disk space associated with my user account is no longer available from the Unreal Editor. When I try saving to it, I get nothing, guess its probably locked somehow. On the other hand, when I try saving to this "super user mode"'s user space I can't access its files from the finder no matter what I try. Its hidden location goes something like this

--to be continued

avatar image altares Mar 24 '14 at 10:11 AM

--continue reading

"/Volumes/MacOSXDisk/private/var/root". Now, I'm even struggling wanting to erase this stuff from there because it takes so much space on my SSD and I don't know how to access that folder..

Well, I guess I'll just have to wait for you to push a new patch or something. Anyways, sorry for the let down. Here are the answers you requested:

--to be continued

avatar image altares Mar 24 '14 at 10:12 AM

--continue reading

  • My usual user account is the only user account on my machine (the one I added right after the OS setup). I don't understand what else you want me to say about it, please clarify.

  • I installed the launcher from this one user account alright.

  • My home folder is on another disk. I used the classical method to make it so (right click on the user account in system prefs, change location, then reboot).

  • I didn't touch the permissions when I moved my home directory around. Heres what the finder tells me about that folder (me: RW, staff: R, Everyone: R).

Hope this helped.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

@StephenEllis reading closer my problem is when the editor is updating, not when trying a download. Sorry.

more ▼

answered Apr 02 '14 at 06:30 AM

avatar image

gwoodruf
46 4 10 10

avatar image Stephen Ellis ♦♦ STAFF Apr 02 '14 at 08:30 PM

@gwoodruf

Are your downloads still restarting after they complete?

What is your Launcher version number? (located in the bottom-left corner of the Launcher)

avatar image Stephen Ellis ♦♦ STAFF Apr 03 '14 at 06:43 PM

@gwoodruf (in response to your edit)

Okay. Please search for other posts related to your issue, and if I cannot find any, we suggest you make a new post.

Cheers

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question